Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 25 Apr 2014, 05:09
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Precise Puppy RC2, October 20, 2012
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 59 [875 Posts]   Goto page: 1, 2, 3, ..., 57, 58, 59 Next
Author Message
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 22 Mar 2012, 03:45    Post subject:  Precise Puppy RC2, October 20, 2012
Subject description: Based on Ubuntu Precise Pangolin 12.04.1 debs
 

RC2, October 20, 2012

Blog announcement:
http://bkhome.org/blog/?viewDetailed=03057

Feedback starts on page 54:
http://murga-linux.com/puppy/viewtopic.php?p=659581#659581

RC1, October 16, 2012

Blog announcement:
http://bkhome.org/blog/?viewDetailed=03039

Forum feedback starts on page 49:
http://murga-linux.com/puppy/viewtopic.php?p=658555#658555

Beta7, September 23, 2012

Blog announcement:
http://bkhome.org/blog/?viewDetailed=03000

...notice, two builds, PAE kernel and non-PAE kernel. Latter suits old hardware.

Forum feedback starts on page 44:
http://murga-linux.com/puppy/viewtopic.php?t=76961&start=645

Beta6, September 11, 2012

Blog announcement:
http://bkhome.org/blog/?viewDetailed=02988

Feedback starts on page 38:
http://murga-linux.com/puppy/viewtopic.php?t=76961&start=555

Beta5, September 4, 2012

Blog announcement:
http://bkhome.org/blog/?viewDetailed=02983

Feedback starts on page 33:
http://murga-linux.com/puppy/viewtopic.php?p=650349#650349

Beta4, August 30, 2012

Blog announcement, 5.2.73:
http://bkhome.org/blog/?viewDetailed=02976

Blog announcement, 5.2.72 (PAE-kernel, Radeon-KMS):
http://bkhome.org/blog/?viewDetailed=02975

Blog announcement, 5.2.71 (no-PAE, no Radeon-KMS):
http://bkhome.org/blog/?viewDetailed=02974

Forum feedback for 5.2.71 starts page 25:
http://murga-linux.com/puppy/viewtopic.php?p=649292#649292

Forum feedback for 5.2.72 and 5.2.73 starts page 26:
http://murga-linux.com/puppy/viewtopic.php?p=649387#649387

Beta3, August 26, 2012
Running very well!

Blog anouncement and download link:
http://bkhome.org/blog/?viewDetailed=02965

Feedback starts on page 22 of this Forum thread:
http://murga-linux.com/puppy/viewtopic.php?p=648697#648697

Beta 2, June 6, 2012
Lots of fixes and improvements in a very short time!

Download from here:
http://distro.ibiblio.org/quirky/test/precise-5.2.60/

Discussion starts on page 15 of this Forum thread:
http://murga-linux.com/puppy/viewtopic.php?p=632032#632032

Beta 1, June 3, 2012
Looking good! See blog announcement and download link:

http://bkhome.org/blog/?viewDetailed=02856

Forum feedback starts on page 12 of this thread:

http://murga-linux.com/puppy/viewtopic.php?p=631371#631371

Alpha 3, May 24, 2012
Working even better! See blog announcement and download link:

http://bkhome.org/blog/?viewDetailed=02842

Feedback for alpha 3 starts on page 7 of this Forum thread:

http://murga-linux.com/puppy/viewtopic.php?t=76961&start=90

Alpha 2, March 26, 2012
Working great! See blog announcement and download link:

http://bkhome.org/blog/?viewDetailed=02766

Alpha 1
This is just a plaything at this stage, which is why I have put it into "Cutting Edge" section.

Precise Puppy is built in Woof, from Ubuntu Precise Pangolin binary packages. (Precise Pangolin is Ubuntu's next version, due for release late April 2012).

My blog announcement:
http://bkhome.org/blog/?viewDetailed=02761

Anyone wants to play with it, you're welcome. If you want to fix anything, go for it!

Actually, there doesn't seem to be much wrong, just two things I identified, but I'm sure there will be more problems discovered.

Note, my main interest is to build an ARM CPU based version, to run on an ARM board that I have ordered. So far, only have an x86 build, but it should be easy to switch over to ARM DEBs.

Note2: It is built with the 3.0.17 kernel, should probably upgrade that.

Last edited by BarryK on Sat 20 Oct 2012, 11:21; edited 15 times in total
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5453
Location: Kentucky

PostPosted: Thu 22 Mar 2012, 04:28    Post subject:  

SeaMonkey 2.6.1 wouldn't launch... "bus error". Quick fix..... removed default SeaMonkey and installed the SeaMonkey 2.6 pet for Saluki. Seems to work correctly, posting from it.
Viewnior wouldn't launch..... missing lib. libxcb-xlib.so.0: Installed missing lib. Working.

As noted in the blog, MPlayer won't play anything but it's 3:30 am and I need sleep. Laughing
Precise Puppy 2.png
 Description   
 Filesize   143.16 KB
 Viewed   13074 Time(s)

Precise Puppy 2.png

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5459
Location: Finland

PostPosted: Thu 22 Mar 2012, 13:07    Post subject:  

Bug fixes...or better just noticed missing libs...
Mplayer and that way gnome-mplayer start to play dvd movie and also avi file after installing "some" missing libs.
Puppy Package Manager depends on wget and wget likes libssl...which was missing. You dont get it with PPM...also Mplayer needs one deb which needs straight download from precise net download page.
The included text file has my hasty findings. Remove the phony .gz

Same drunken touchpad as in Racy and Saluki. There really is something amiss with these new xorg drivers. The newer is not always better....back to dpup....
missing-libs-and-url-to-download.gz
Description 
gz

 Download 
Filename  missing-libs-and-url-to-download.gz 
Filesize  1.99 KB 
Downloaded  760 Time(s) 
Gnome-mplayer-after-fixing.jpg
Description 
jpg

 Download 
Filename  Gnome-mplayer-after-fixing.jpg 
Filesize  607.33 KB 
Downloaded  831 Time(s) 
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1276
Location: Malvern, Worcs, UK

PostPosted: Thu 22 Mar 2012, 14:30    Post subject: Libs needed for wifi  

Hi Barry

I had to install the following debs to get a working wpa wifi connection with sns through my b43 wifi:

libnl-3-200_3.2.3
libnl-genl-3.so.200_3.2.3
libssl.so.1.0.0_1.0.0g

Like others I installed the saluki version of seamonkey 2.7.2 and that worked fine (using it now to post this).

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 1936
Location: Ontario Canada

PostPosted: Thu 22 Mar 2012, 17:15    Post subject: Precise Puppy alpha1  

I removed the seamonkey 2.6.1, deleted the directory, etc, and
installed a seamonkey 2.8 pet that I have.

I was going to take a stab at compiling seamonkey 2.8 in Precise but
got the following error.

loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for gawk... gawk
checking for perl5... no
checking for perl... /usr/bin/perl
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for c++... c++
checking whether the C++ compiler (c++ ) works... no
configure: error: installation or configuration problem: C++ compiler cannot create executables.

I was able to compile the proprietary nvidia driver, it gave an error about the
gcc version being different from the one that compiled the kernel but it still
compiled successfully.

Fri 23 Mar 2012 Operating System: Precise Puppy-5.2.51 Linux 3.0.17

oem: NVIDIA product: G84 Board - p402h00 Chip Rev

X Server: Xorg Driver: nvidia
X.Org version: 1.11.4
dimensions: 1280x1024 pixels (382x302 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 8600 GT/PCIe/SSE2
OpenGL version string: 3.3.0 NVIDIA 295.20

# glxgears
50602 frames in 5.0 seconds = 10120.220 FPS
50730 frames in 5.0 seconds = 10145.913 FPS
50636 frames in 5.0 seconds = 10127.198 FPS

Intel(R) Core(TM)2 Quad CPU Q6600
Core 0: 1603 1: 1603 2: 1603 3: 1603 MHz

I just noticed that the date is out by 1 day.

I installed the newest flash player from adobe but flash videos at cnn don't
work in seamonkey or firefox 11 (nightly)
image-5small.jpg
 Description   
 Filesize   60.88 KB
 Viewed   12733 Time(s)

image-5small.jpg


Last edited by Billtoo on Thu 22 Mar 2012, 23:28; edited 1 time in total
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Thu 22 Mar 2012, 18:52    Post subject:  

pemasu, peebee,
Thanks, I am adding all the extra debs.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 23 Mar 2012, 21:27    Post subject:  

I posted a list of DEBs that you need to install to get WPA wireless, Mplayer, etc., working:
http://bkhome.org/blog/?viewDetailed=02761

You should be able to get these via the Puppy Package Manager. Most are in the "Main" repo, some may be in the "Universe" repo.

There are probably going to be even more needed. They will all be included in the next release of Precise Puppy.

Note also, the fix for Simple Network Setup:
http://bkhome.org/blog/?viewDetailed=02764

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
linux28

Joined: 05 Apr 2009
Posts: 179

PostPosted: Mon 26 Mar 2012, 11:37    Post subject:  

# gtkhash
gtkhash: error while loading shared libraries: libgtk-3.so.0: cannot open shared object file: No such file or directory
# homebank
homebank: error while loading shared libraries: libofx.so.4: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 758
Location: West Wales, Britain.

PostPosted: Mon 26 Mar 2012, 13:57    Post subject:  

Osmo is missing libtar.so.0 and libwebkitgtk-1.0.so.0. Maybe more.
_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
Terryphi


Joined: 02 Jul 2008
Posts: 758
Location: West Wales, Britain.

PostPosted: Mon 26 Mar 2012, 14:16    Post subject:  

Posted in error
_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile

Last edited by Terryphi on Tue 10 Apr 2012, 07:05; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5459
Location: Finland

PostPosted: Mon 26 Mar 2012, 17:14    Post subject:  

# ppm
/usr/local/petget/findnames.sh: line 56: getext: command not found

if [ "$FNDIT" = "no" ];then
pupmessage -bg red -center -title "$(getext 'PPM find')" "$(gettext 'Sorry, no matching package name')" & #110223 run as separate process.
else ----------------> gettext

# osmo
osmo: error while loading shared libraries: libtar.so.0: cannot open shared object file: No such file or directory
# osmo
osmo: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory
# osmo
osmo: error while loading shared libraries: libjavascriptcoregtk-1.0.so.0: cannot open shared object file: No such file or directory
# osmo
osmo: error while loading shared libraries: libgeoclue.so.0: cannot open shared object file: No such file or directory
# osmo
osmo: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory
# osmo
osmo: error while loading shared libraries: libicui18n.so.48: cannot open shared object file: No such file or directory
# osmo

libgstreamer-plugins-base and libicu48 were needed to provide those 2 latest. Osmo certainly needs own compile. Those dependencies are big.

Libtar you will find from this link, it is from oneiric, the precise one will be coming...http://launchpadlibrarian.net/70877572/libtar0_1.2.11-8_i386.deb. But...recompile would be better for Osmo.

Gtkhash will need recompile also.

Libicu stuff is something which needs to be avoided. It is big and if it is found many apps and libs includes the dependency into it when compiling.....like QT libs. And I didnt find a way to disable that when I compiled Qt libs in Polarpup.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5459
Location: Finland

PostPosted: Mon 26 Mar 2012, 17:34    Post subject:  

yes|uget||exe

# uget
bash: uget: command not found
# find /usr/ -name "*uget*"
/usr/share/icons/hicolor/16x16/apps/uget-icon.png
/usr/share/icons/hicolor/32x32/apps/uget-icon.png
/usr/share/applications/uget-gtk.desktop
/usr/share/pixmaps/uget-gtk.png
/usr/bin/uget-gtk
# uget-gtk
uget-gtk: error while loading shared libraries: librtmp.so.0: cannot open shared object file: No such file or directory
# uget-gtk
# started ok Smile

# ln -s /usr/bin/uget-gtk /usr/bin/uget
....and menu > internet > uget starts to work.


# ayttm
ayttm: error while loading shared libraries: libyahoo2.so.11: cannot open shared object file: No such file or directory
Well....I didnt chase that depenpency....guess why....Smile

# homebank
homebank: error while loading shared libraries: libofx.so.4: cannot open shared object file: No such file or directory
# homebank
homebank: error while loading shared libraries: libosp.so.5: cannot open shared object file: No such file or directory
# homebank
# started ok Smile after installing from ppm libosp and libofx4 from below link, Oneiric version. Pangolin version is stil under construction.

http://launchpadlibrarian.net/76079186/libofx4_0.9.4-2_i386.deb
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Mon 26 Mar 2012, 18:42    Post subject:    

Frugal installation of precise a2 on an ext4 partition works fine, including printer, although a few problems have been discovered so far.

A usb Logitech mouse does not work apparently since the usb Logitech receiver is not recognized. A regular usb mouse does work.

xsane does not work from the menu, however it does work using a terminal with the following warning:
    # xsane
    (xsane:13871): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

System: BFG NVIDIA Geforce 8400 GS 512MB, Asus P6T Motherboard, Intel core i7-920 (8MB Cache, 2.66 GHz), DDR3 3GB 1333MHz ram, Pioneer DVR-2910 DVD+-RW Dual Layer Burner, Realtek ALC1200 Audio, HP Photosmart C5280 All-in-One
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5453
Location: Kentucky

PostPosted: Mon 26 Mar 2012, 19:46    Post subject:  

I took the easy way out...... I just replaced Osmo and Homebank with Lucid packages.....quicker than replacing all the missing libs.
precise puppy.png
 Description   
 Filesize   196 KB
 Viewed   12302 Time(s)

precise puppy.png

Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5453
Location: Kentucky

PostPosted: Mon 26 Mar 2012, 22:16    Post subject:  

Rebuilt the iso..... replaced Osmo,Homebank, SeaMonkey w/ (2.8 ) and the kernel.

-Computer-
Processor : 4x AMD Athlon(tm) II X4 620 Processor
Memory : 3797MB (214MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Mon 26 Mar 2012 09:15:05 PM GMT+6
-Display-
Resolution : 1366x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA NVidia

-Version-
Kernel : Linux 3.1.0 (x86_64)
Compiled : #1 SMP PREEMPT Mon Jan 2 06:19:35 MST 2012
C Library : GNU C Library version 2.15 (stable)
Default C Compiler : Unknown
Distribution : Unknown distribution

# report-video
lspci: error while loading shared libraries: libpci.so.3: cannot open shared object file: No such file or directory
Precise Puppy, version 5.2.52 on Mon 26 Mar 2012

Chip description:



X Server: Xorg
Driver used: nouveau

X.Org version: 1.11.4
dimensions: 1366x768 pixels (361x203 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
#
experiment.png
 Description   
 Filesize   29.71 KB
 Viewed   12152 Time(s)

experiment.png

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 59 [875 Posts]   Goto page: 1, 2, 3, ..., 57, 58, 59 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1027s ][ Queries: 13 (0.0152s) ][ GZIP on ]