Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 24 May 2015, 13:54
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Default Sound Card = Random
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 05 Feb 2012
Posts: 1044
Location: London, England

PostPosted: Thu 15 Mar 2012, 19:17    Post_subject:  Default Sound Card = Random
Sub_title: Running 2 Sound Cards

I posted this in the "Bugs" section because I encountered it testing the beta of Racy but it may not be a bug as such and it is possible that this may be a more appropriate section of the forum in which to ask about this. I hope I can be forgiven for copying it here as well.

I like to run 2 sound cards in my computers so I can route audio from different applications to different places.

So I have "Soundcard A" (which is integrated on the motherboard) and "Soundcard B" (which is a PCI card).

My problem is that the process of establishing the default soundcard appears to be random.

At first I thought that the Multiple Sound Card Wizard just wasn't working, but I see that there is a file at /etc/asound.conf which appears to define the default soundcard.

But it only specifies a card and device NUMBER eg:

defaults.pcm.card 1
defaults.pcm.device 0

Am I looking at the correct file for this?
Note that the cards are not named.

The big problem arises from the fact that at each boot-up the process of allocating the card numbers seems totally random. Sometimes Soundcard A will be given the number 0 and Soundcard B will be given the number 1 and on another boot-up they can be allocated the other way round.

Would it be possible to have the file set the default card by specifying it by name?

Alternatively (and probably the ideal solution), is there a way to ensure that the allocation of number to name remains the same at every boot-up?

UPDATE - Think I may have solved it. Running the ALSA Wizard (despite my reluctance because of the scary dialog that pops up) seems to have enabled me to lock down the allocation of "Card 0" to the integrated soundcard on the motherboard.

I see that lines have been added to the file /etc/modprobe.d/alsa.conf thus:-

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.21 ---
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

The other soundcard does disappear from the options displayed in Multiple Sound Card Wizard when you do this, so I was worried that I may have lost my internal connection to it, but on re-boot they were both there again and on a couple of re-boots the order was staying the same.
I then had to use Multiple Sound Card Wizard (again) to change the default back from "Card 1" to "Card 0". This creates a new file at /etc/asound.conf leaving the previous one there with the suffix "old".
Back to top
View user's profile Send_private_message 

Joined: 23 May 2010
Posts: 2502
Location: near here

PostPosted: Sat 24 Mar 2012, 06:50    Post_subject:  

altering the alsa-base.conf file worked for me - using index to control the order modules load...


Added code to/etc/modprobe.d/alsa-base.conf

#choose order of sound modules
options snd-ca0106 index=0
options snd-intel8x0 index=1


helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0486s ][ Queries: 12 (0.0070s) ][ GZIP on ]