Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 20 Apr 2014, 15:48
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
.pet for MindGuard
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
Kristjan

Joined: 02 Apr 2012
Posts: 5

PostPosted: Mon 02 Apr 2012, 18:05    Post subject:  .pet for MindGuard  

Hi! I need help with getting this program to run. It's been bugging me for months...
I tried linux because of this program and started to love it but I still cannot get the program to run. Any help? I'm running the latest, regular Puppy 5.3.1 release.
Links: http://zapatopi.net/mindguard/
http://doc.gnu-darwin.org/mindguard/index.html
Thank you in advance!
Back to top
View user's profile Send private message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Mon 02 Apr 2012, 20:06    Post subject:  

Hi
The linux version is a tgz file, which I think will install with the puppy installer, but you may have to compile it, which will need the devx to be installed first

That looks like some crazy stuff to me....- mind the gooks don't getcha....

Aitch Smile
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1217
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Mon 02 Apr 2012, 23:09    Post subject:  

Aitch wrote:
That looks like some crazy stuff to me....- mind the gooks don't getcha....

Aitch Smile


I reckon one of John Lear's tin foil hat's should do the same job.

Back to top
View user's profile Send private message 
Kristjan

Joined: 02 Apr 2012
Posts: 5

PostPosted: Tue 03 Apr 2012, 09:25    Post subject:  

I installed gtk+ and glib 12.1.2.10 libraries from the Puppy 3 repository, and gdk_pixbuf10-0.22.0 (all the dependencies for GTK+ 1.2) and devx. Now the make command actually does something but GTK wont work.
Quote:
# cd /mindguard-0.0.0.4
# make
gcc `gtk-config --cflags` mindguard.c -o mindguard `gtk-config --libs`
/bin/sh: gtk-config: command not found
/bin/sh: gtk-config: command not found
In file included from mindguard.c:36:0:
mindguard.h:3:21: fatal error: gtk/gtk.h: No such file or directory
compilation terminated.
make: *** [mindguard] Error 1

What to do?
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 03 Apr 2012, 09:55    Post subject:  

I am hardly surprised that Belgium is now recognized as non existent
(I remember having visited - but how reliable is that?)
http://zapatopi.net/belgium/

Here I conclusively prove that the Eiffel Tower is non existent
http://web.archive.org/web/20070220223705/http://pages.britishlibrary.net/lobster/et/

I would warn those running such software and wearing tin hats . . . these are
used as homing beacons by the MIB, Aliens and others.
Not as deterrent as some of you have been led to believe . . .

Some are beginning to question the existence of the Raspberry Pi . . .
oh Ye, of Little Faith . . .

Very Happy

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
darkcity


Joined: 23 May 2010
Posts: 2411
Location: near here

PostPosted: Tue 03 Apr 2012, 10:25    Post subject:  

how come you used puppy 3 respository and not slacko, you may need newer gtk version, check mindguard documentation

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Kristjan

Joined: 02 Apr 2012
Posts: 5

PostPosted: Tue 03 Apr 2012, 10:51    Post subject:  

I've not come across any similar programs so I'm willing to take that risk Laughing
I just wanted to install something certain and I thought 1.2 would work well. I don't really want to experiment, just get the thing running.
Plus I cannot find anything to install in the Puppy 5 or Slacko repositories when I search for GTK anyway. What version do I need to make MindGuard work?
E: I'm trying to compile the latest GTK+ 3.4.0 but I ran into some trouble: glib wont compile ( a dependency) because it says I have libffi missing even though I installed it (at least I think so). Do I need to set some environmental variables or something?
Quote:
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBFFI_CFLAGS
and LIBFFI_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

How do I do this? I instaled pkg-config too but I haven't configured anything. They both installed to /usr/local/lib
Is that OK?
Back to top
View user's profile Send private message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Tue 03 Apr 2012, 16:43    Post subject:  

Perhaps this may help?

http://www.murga-linux.com/puppy/viewtopic.php?p=196741

Aitch Smile
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6666
Location: lisbon

PostPosted: Wed 04 Apr 2012, 00:36    Post subject:  

No idea if this is how it's supposed to work, but you can try this .pet. It's under Fun on the menu.
mindguard-0.0.0.4.pet
Description 
pet

 Download 
Filename  mindguard-0.0.0.4.pet 
Filesize  903.52 KB 
Downloaded  223 Time(s) 
Back to top
View user's profile Send private message 
Kristjan

Joined: 02 Apr 2012
Posts: 5

PostPosted: Wed 04 Apr 2012, 03:46    Post subject:  

E: The program is a sham, if you check the source code you can see that the depsych utility never stops and that the messages are randomly decoded from the carrier files. They are cool though, very imaginative author.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0568s ][ Queries: 13 (0.0054s) ][ GZIP on ]