Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 03:03
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
LHMP - Hiawatha MariaDB(mysql) PHP
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
growler


Joined: 24 Mar 2008
Posts: 209
Location: Kapiti - New Zealand

PostPosted: Fri 20 Aug 2010, 20:48    Post_subject:  LHMP - Hiawatha MariaDB(mysql) PHP  

I updated my LHMP package for Lucid 5.1

It contains:
Hiawatha 7.3
MariaDB - (Formerly known as mysql) 5.1.47
PHP 5.3.3 - using the new Fast CGI manager

It has accompanying scripts under /etc/init.d/ to start hiawatha (rc.httpd) and mariadb (rc.mysqld)

http://www.logicworks.co.nz/puppy/LHMP-7.3-5.1.47-5.3.3.pet
Back to top
View user's profile Send_private_message 
laredmemata

Joined: 20 Jan 2011
Posts: 4

PostPosted: Fri 21 Jan 2011, 17:56    Post_subject: thnks  

Thank you. I need a really portable solution for me. I was working with wampp in an usb stick, but in some old computers this was slow and desperating.
Then i find puppy, which brings me the posibility of working in a borrowed 500m ram pentiumIII at acceptable speed.

But lampp + puppy works horrible in this low end machine. It was hard to install, because of the size of the lampp, and sloooww. Even slower than it was with xp.

I tried some other flavour, like monkey webserver, but due to my low knoledge level i desist on tryng to solve some problems i found about connecting with the database.

I change some values in the hiawatha configuration files, basically making hiawatha more patient, so he don't generate 500 error while waiting for wordpress to do things. And change some other values in php.ini files to make puppy more similar to my server. (lugointernet), and to produce headers compliant with rfc-something. I did all changes at the same time. It works, and i dont mind which of them produces the desired result (timeout is better candidate because there was timeout errors in the error log).

Any way, thank you, and i leave this comment here to other people having error 500, and perhaps timeout errors.


Now
Back to top
View user's profile Send_private_message 
Atle

Joined: 19 Nov 2008
Posts: 295
Location: Oslo, Norway

PostPosted: Tue 02 Aug 2011, 20:12    Post_subject: Your Pet is nominated for QuickPet in Lucid 5.2.6  

Still i admit is has not been tested yet, but i am on to it.

Forum thread is here: http://murga-linux.com/puppy/viewtopic.php?t=70450
Back to top
View user's profile Send_private_message Visit_website MSNM 
gungsukma

Joined: 18 Sep 2011
Posts: 17

PostPosted: Wed 26 Oct 2011, 13:00    Post_subject:  

Cannot run it in Slacko and Wary. Lupu is fine.

http://localhost/ : "503 - Service Unavailable"

also, I think it broke PPLOG Personal Blog (editing hiawatha configuration file can fix it).
Back to top
View user's profile Send_private_message 
Atle

Joined: 19 Nov 2008
Posts: 295
Location: Oslo, Norway

PostPosted: Sun 26 Feb 2012, 04:53    Post_subject: Possible to upgrade?  

Dear Growler...

It tried and tried to upgrade the Pet with Hiawhata 8.0. I also looked at the latest MariaDB, only to find out it was like 93mb of whatever.

Is it possible to upgrade the LHMP with the latest software?

I love this package and are crossing my finger on this updating issue.

As I tried to "just" upgrade Hiawhata, I saw that the files in the 8.0, looked pretty different from the ones found in the LHMP.

Best

Atle
Back to top
View user's profile Send_private_message Visit_website MSNM 
chalkartist

Joined: 16 Mar 2009
Posts: 8

PostPosted: Wed 11 Apr 2012, 19:11    Post_subject: thanks
Sub_title: lhmp working for me in 5.28
 

Growler,

Thanks for this package... I tried for almost 2 days to get the hiawatha that comes with 5.28 to work... kept getting 403... I didn't remember it being this hard just to get a basic site working... anyway, sometimes the answer lies in starting with something else. I saw this and d'l and copied to my server and in like 5 minutes I saw the php.index. I am using this on an intranet site for work... it will be fun to solve some of my problems and learn at the same time.. I don't know anything about the db or php (yet) but I know I'll need them. Thanks again.

chalkartist
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0745s ][ Queries: 12 (0.0271s) ][ GZIP on ]