Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 02:14
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Precise Puppy RC2, October 20, 2012
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 59 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 57, 58, 59 Next
Author Message
linux28

Joined: 05 Apr 2009
Posts: 204

PostPosted: Wed 11 Apr 2012, 04:26    Post_subject:  

bcrypt
bug ????????Rolling Eyes
1.jpg
 Description   
 Filesize   25.56 KB
 Viewed   1858 Time(s)

1.jpg

Back to top
View user's profile Send_private_message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Wed 11 Apr 2012, 04:52    Post_subject:  

linux28 wrote:
bcrypt
bug ????????Rolling Eyes


It works for me but that may be as a result of a fix I have made for something else.

LATER:
I am using locale en_GB.UTF-8 . If you are not using UTF-8 perhaps bcrypt requires it?

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send_private_message Visit_website 
linux28

Joined: 05 Apr 2009
Posts: 204

PostPosted: Wed 11 Apr 2012, 06:13    Post_subject:  

devx_precise_5.2.52.sfs:
Quote:
# cmake ..
cmake: error while loading shared libraries: libarchive.so.12: cannot open shared object file: No such file or directory
# cmake ..
cmake: error while loading shared libraries: liblzma.so.5: cannot open shared object file: No such file or directory
# cmake ..
cmake: error while loading shared libraries: libnettle.so.4: cannot open shared object file: No such file or directory
# cmake ..
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/usr/bin
CMake Error: Error executing cmake::LoadCache(). Aborting.




firefox:
Quote:
# seamonkey

(seamonkey-bin:3607): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap
# firefox

(firefox:9384): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap
# firefox

(firefox:9805): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap
# firefox

(firefox:10331): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap
# firefox

(firefox:13422): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap
# firefox
1.jpg
 Description   
 Filesize   41.66 KB
 Viewed   892 Time(s)

1.jpg


Edited_time_total
Back to top
View user's profile Send_private_message 
linux28

Joined: 05 Apr 2009
Posts: 204

PostPosted: Wed 11 Apr 2012, 06:20    Post_subject:  

http://www.google.com/chrome
2.jpg
 Description   
 Filesize   34.18 KB
 Viewed   898 Time(s)

2.jpg

1.jpg
 Description   
 Filesize   11.3 KB
 Viewed   1784 Time(s)

1.jpg

Back to top
View user's profile Send_private_message 
sszindian


Joined: 24 Apr 2010
Posts: 608
Location: Pennsylvania U.S.

PostPosted: Wed 11 Apr 2012, 15:24    Post_subject: Printing Problem  

Terryphi Wrote:
----------------------------------------------------
CUPS Printer Wizard is not working for me.

Cannot connect to localhost:631CUPS Printer Wizard is not working for me.

Cannot connect to localhost:631

Can anyone confirm that they see this problem?


Can anyone confirm that they see this problem?
----------------------------------------------------

I was able to install my HP1050 all-in-one printer using cups without issue... however.... it won't print a test page, says no such file or directory found... and... it won't print anything else either? Also, the scanner won't even attempt to come work?

There is no doubt, there are serious 'Cups' issues?

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send_private_message 
gcmartin

Joined: 14 Oct 2005
Posts: 4368
Location: Earth

PostPosted: Wed 11 Apr 2012, 18:23    Post_subject:  

Environment
  • Laptop P4 1.5GB RAM with NO HDD!
  • 8GB USB stick formated 2 Primary partitions ===> 4GB SWAP and 4GB FAT partitions
  • booted Precise "pfix=ram" Live media (ISO was md5 validated)
Scenario
  • System booted straight to localization on desktop
  • Localization: Video OK, but ALL other fields adjusted for local needs including hostname change required
Problems - In reviewing Precise, I have 2 primary issues after localization settings restarts desktop
  • Cannot run personal scripts in a termnial session
  • Using Editor icon on desktop appears broken and I Cannot edit files text files because they dont show up as selections in the editor menu's File>Open screen
Hope this helps

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send_private_message 
jrb


Joined: 11 Dec 2007
Posts: 1040
Location: Smithers, BC, Canada

PostPosted: Sun 15 Apr 2012, 11:11    Post_subject: Re: Printing Problem  

sszindian wrote:
Terryphi Wrote:
----------------------------------------------------
CUPS Printer Wizard is not working for me.

Cannot connect to localhost:631CUPS Printer Wizard is not working for me.

Cannot connect to localhost:631

Can anyone confirm that they see this problem?


Can anyone confirm that they see this problem?
----------------------------------------------------

I was able to install my HP1050 all-in-one printer using cups without issue... however.... it won't print a test page, says no such file or directory found... and... it won't print anything else either? Also, the scanner won't even attempt to come work?

There is no doubt, there are serious 'Cups' issues?

>>>---Indian------>

I was able to go to localhost:631 in Seamonkey and install my Brother1435 printer as default, however I couldn't get it to print from Abiword or Geany and it printed a blank page from Gnumeric.

In Abiword and Geany I was able to print to .ps files and then use:
Code:
lp /root/output.ps
and they printed successfully. The Gnumeric .ps file still printed blank. Confused
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Sun 15 Apr 2012, 12:52    Post_subject:  

Quote:
There is no doubt, there are serious 'Cups' issues?

I am reluctant to spend much time on these proof-of-concept Pupplets. Like Drake before it, I don't expect that Precise is going anywhere.

However, here are some quick fixes.

1. Install the PET below.

2. Open the file /usr/share/cups/mime/mime.convs.

3. UNcomment line 41 - "application/pdf ....."

4. Restart CUPS.
cups_pdftops_filter-1.3.11.pet
Description 
pet

 Download 
Filename  cups_pdftops_filter-1.3.11.pet 
Filesize  7.11 KB 
Downloaded  290 Time(s) 

Edited_time_total
Back to top
View user's profile Send_private_message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Sun 15 Apr 2012, 13:39    Post_subject:  

I have found later versions of CUPS to be nothing but trouble and later versions of gutenprint do not have my printer as an option. I installed the following pets from the /quirky/ repository and it solved the problem:

cups-1.3.11-2-w5c.pet
gutenprint-5.2.6-w5.pet

This is the perfect combination for my HP DeskJet 510 printer.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send_private_message Visit_website 
sszindian


Joined: 24 Apr 2010
Posts: 608
Location: Pennsylvania U.S.

PostPosted: Sun 15 Apr 2012, 22:31    Post_subject: Printing  

rcrsn51:

You never cease to amaze me old buddy!!

You’re little fix (.pet) worked like a charm... printed just fine from Leafpad and Abiword I expect it will do the same from elsewhere. I will say, the printing was super fast! Only had hplip-3.11.10 print & hplip-3.11.10 scan installed.

Just to let you know a test I did... Installed jamiaha’s printer package .sfs from Saluki... it auto installed your peasyscan packages in Precise and low and behold... your peasyscan would print a beautiful graphic from a file (I did a .jpg I believe) Your scanner itself would do a preview then a scan but the scan-window just flashed briefly and would not display the scanned picture... As I say, just for your info!

Xsane scanner from graphics in Precise is just a ‘no go’ period, it is not even recognized?

You may well be right and Precise may never get going and I'm not really sure if BK wants it to get going, I believe it's more of a personal build he wanted... but I figure if BK took the time to create it, and make it available, someone may be able to use it, so... I'll give some time testing for him. I will say, what does work works very nice in Precise!

As always... "Thanks rcrsn51"

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Sun 15 Apr 2012, 23:00    Post_subject:  

Quote:
Just to let you know a test I did... Installed jamiaha’s printer package .sfs from Saluki...

Why on earth would you do that?
Quote:
Xsane scanner from graphics in Precise is just a ‘no go’ period, it is not even recognized?

It worked fine for me OOTB. Correction. It worked from the command line but not from the menu. Xsaneshell needs to run xmessage, which does not exist.
Quote:
it auto installed your peasyscan packages in Precise and low and behold... your peasyscan would print a beautiful graphic from a file (I did a .jpg I believe) Your scanner itself would do a preview then a scan but the scan-window just flashed briefly and would not display the scanned picture...

I installed Peasyscan from a PET and it worked fine.
Back to top
View user's profile Send_private_message 
jrb


Joined: 11 Dec 2007
Posts: 1040
Location: Smithers, BC, Canada

PostPosted: Mon 16 Apr 2012, 00:03    Post_subject:  

rcrsn51 wrote:
Quote:
There is no doubt, there are serious 'Cups' issues?

I am reluctant to spend much time on these proof-of-concept Pupplets. Like Drake before it, I don't expect that Precise is going anywhere.

However, here are some quick fixes.

1. Install the PET below.

2. Open the file /usr/share/cups/mime/mime.convs.

3. UNcomment line 41 - "application/pdf ....."

Great fix rcrsn51! Cool I installed and restart cups and everything prints. Following your lead I tracked down pdftops from the Precise repo and installed it but it didn't work Confused

As for time spent on this, I'm just looking for any excuse not to work on my taxes, eh?

Cheers, J
Back to top
View user's profile Send_private_message 
jrb


Joined: 11 Dec 2007
Posts: 1040
Location: Smithers, BC, Canada

PostPosted: Mon 16 Apr 2012, 00:16    Post_subject:  

epdfview needs liblcms2 available from liblcms2-2_2.2+git20110628-2ubuntu3_i386.deb which you can also get from the Puppy Package Manager.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 16 Apr 2012, 17:29    Post_subject:  

This took some time to figure out. Gsetting-desktop-schemas were not activated just by installing them. So...they needed some app to activate them. I did find references to gsettings application. Did find it, did hunt other needed stuff, fixed 3 dead symlinks, did hunt down gecko-media-player schema, placed it to appropriate ? place and then I compiled the schemas. And....Seamonkey started to work.

I did reduce the needed stuff to ready pet and it executes the compilation with pinstall.sh script:
glib-compile-schemas /usr/share/glib-2.0/schemas

You can use that command if you need to hunt more schemas and place them. I did put the gecko-mediaplayer schema to /usr/share/glib-2.0/schemas folder. Not the correct place...but I didnt bother to find out what is correct place and when you compile....it is easier to compile just one folder content.

Have fun.....

Oh...I got the ubuntu precise ghostscript to work. I didnt use Barrys version. Just for fun of it. It much bigger so Barrys one is better choice. And the printing has been solved already anyway.

This woofed build starts to behave....
gsettings-schemas-fix-0.0.1.pet
Description 
pet

 Download 
Filename  gsettings-schemas-fix-0.0.1.pet 
Filesize  52.02 KB 
Downloaded  294 Time(s) 
Back to top
View user's profile Send_private_message 
sszindian


Joined: 24 Apr 2010
Posts: 608
Location: Pennsylvania U.S.

PostPosted: Mon 16 Apr 2012, 19:11    Post_subject: Reply  

sszindian said:
Just to let you know a test I did... Installed jamiaha’s printer package .sfs from Saluki...

rcrsn51 asked:
Why on earth would you do that?

sszindian reply:
I do a lot of cross-testing of various programs to see what they will handle or... what will break them. Just something I like to do as most others test normally. Surprisingly, I do find a lot of programs that work from one version to another especially where a certain program I want to use isn't available from the source program. For example... Precise and the printing issue, in the PPM are hplip 12's that are listed for download but, no one listed even had them available at there repo., thus tried various other things!

I installed the '.pets' of Peasyscan and they both work great in Precise!

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 4 of 59 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, ..., 57, 58, 59 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1147s ][ Queries: 13 (0.0197s) ][ GZIP on ]