Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 18:46
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Xircom 10/100 RE-100 Adapter not working
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
FlashTrevor

Joined: 23 Feb 2012
Posts: 1

PostPosted: Thu 23 Feb 2012, 09:46    Post subject:  Xircom 10/100 RE-100 Adapter not working
Subject description: Xircom 10/100 RE-100 Credit Card Adapter not working
 

Please help a linux beginner:

I have installed MACPUP which in general I believe is one of the best OS's and DISTROs I have seen. It is so fast and takes up no space, and even the Ability to run live without installation is very fast.

Now onto the real point - the out of the box solution does not enable PCMCIA bus by default.

I have enabled this following several forums posts by using the command:
modprobe yenta_socket

I save this configuration so that it now detects the PCMCIA on startup, and correctly locates an adapter in location 0.

Now to detect the network card - this doesn't work using either of the network wizards. I then manually loaded the Xircom PCMCIA module included in the package xirc2ps_cs - this loads but doesn't correctly detect the card.

If I run
pccardctl eject and then
pccardctl insert commands it makes no difference.

I have tried dusing the pccardctl info command to list what it has found but it contains a blank list of PRODID and MANFIDs.

lsmod
shows the module by not being used by anything.

I briefly tried using the NDIS wrapper but the .inf file included by windows contains multiple adapaters and as such doesn't help me identify and correctly load for my adapter.

Please help as I would really like to get this old laptop online - it has breathed new life into all my old machines, and this appears to be the last hurdle.
Back to top
View user's profile Send private message 
ravenxau

Joined: 29 Apr 2012
Posts: 18

PostPosted: Tue 01 May 2012, 19:18    Post subject:  

I have a xircom 10/100 in a Compaq presario 1685 laptop - Using puppy 2.16.1, run the network wizard - it *should* autodetect, if not select the tulip module at the bottom of the list during the network wizard. Then Auto DCHP.

hope this help, as it works fine on my system
Back to top
View user's profile Send private message 
rokytnji


Joined: 20 Jan 2009
Posts: 1290
Location: Pecos/ Texas

PostPosted: Tue 01 May 2012, 19:40    Post subject:  

What does PupScan show for the card in question.

I haven't used a Xircom card in ages now. I sold the Laptop I was using it on and gave away the rest of my 16bit pcmcia ethernet cards.

If wanting to gather more info. Run

Code:
lspci -n


post in next post. I will go to

http://kmuto.jp/debian/hcl/

and paste your readout there.

To see what is going on with that pcmcia card and post the results here.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0440s ][ Queries: 12 (0.0040s) ][ GZIP on ]