Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 21:49
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use Brother HL2240d printer in Wary 5.2?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
n9viw

Joined: 17 Apr 2012
Posts: 21

PostPosted: Fri 20 Apr 2012, 10:44    Post subject:  How to use Brother HL2240d printer in Wary 5.2?  

I'm a complete noob to Linux in general, much less Puppy, although I did manage to install from a LiveCD. I've been using my Pup (Wary 5.2) for a couple months now, and apart from Jscripts freezing Firefox 4 (and occasionally crashing FF, as well as freezing X), it's been fun.

That said, I need to install a printer (in subj line), and I ALMOST have it, but it's still missing something. I followed Brother's instructions, and also some cmd info from an Ubuntu forum that seemed to help. So far, jobs sent to the printer cause it to 'wake up', heat up the toner bar and turn on the fan and whatnot, and the Ready light flashes several times, but then stops, and no printing does it make!

Here's what I've done so far:
* Followed instrux at http://ubuntuforums.org/showthread.php?t=1627516
* Followed Cupswrapper info at http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/instruction_prn1a.html
* Followed instrux to install ppd file (http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/instruction_prn1c.html)

I'd provide a screen shot of the installed printers page, but... please see line 1 of this message. particularly the first eight words. CUPS does seem to "know" the printer is there, but whatever it's sending the printer isn't getting printed.

I've done a search here on the forum, and found several threads about installing printers, most of which is a rehash of Brother's own instrux.

Any suggestions? Even pointing me to a beginner's *nix tutorial, Puppy-specific or not, would be much appreciated.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9376
Location: Stratford, Ontario

PostPosted: Fri 20 Apr 2012, 11:00    Post subject:  

Quote:
I've done a search here on the forum, and found several threads about installing printers, most of which is a rehash of Brother's own instrux.

Have you read here? It contains a link to the Brothers section.

If you still have trouble, post another message and I will build a driver for you.
Back to top
View user's profile Send private message 
n9viw

Joined: 17 Apr 2012
Posts: 21

PostPosted: Sun 22 Apr 2012, 21:41    Post subject:  

rcrsn51, You're a prince. I had to delete the other installed instances of the printer, then shut off and restart CUPS and re-find the printer. I did get the test page out! However, I cannot print from either Geany or AbiWord. (the latter always makes me think of Marty Feldman saying, "Abby... someone.")

When I open a file with either program, then select "Print", I go through all the necessary selections, then hit "Print". The Ready light on the printer flashes once, and that's it. No fan, no warming, no nothing.

Interesting note: when I just opened CUPS, the message by the printer says, "/usr/lib/cups/filter/pdftops failed". What is 'pdftops'? On a lark, I surfed over to that location, found the symlink 'pdftops' pointed over to /usr/bin where the exe sat. I ran it from a command shell, which (of course) gave me the version, usage info, etc. but didn't tell me why it may have failed before- incorrect command, I suppose. I gather this exe is the doohicky that converts my text file into whatever the printer needs in order to spit it out on paper, and something went wrong.

So, now: where and how to find out what went wrong? Is there a folder somewhere where failed commands go to be debugged later, or does it spit out a file from which I could decipher the problem?
Back to top
View user's profile Send private message 
n9viw

Joined: 17 Apr 2012
Posts: 21

PostPosted: Sun 22 Apr 2012, 21:54    Post subject:  

I went back into CUPS and nosed around, found the logs, and cracked open the error and access logs. Since I still don't know how to give you a screenshot, here's a clipping from my error log, just the last couple jobs (Geany and AbiWord):

Quote:

I [22/Apr/2012:19:08:58 -0500] [Job ???] Request file type is application/pdf.
I [22/Apr/2012:19:08:58 -0500] [Job 23] Adding start banner page "none".
I [22/Apr/2012:19:08:58 -0500] [Job 23] Adding end banner page "none".
I [22/Apr/2012:19:08:58 -0500] [Job 23] File of type application/pdf queued by "root".
I [22/Apr/2012:19:08:58 -0500] [Job 23] Queued on "Brother_HL-2240D_series_USB_1" by "root".
I [22/Apr/2012:19:08:58 -0500] [Job 23] Started filter /usr/lib/cups/filter/pdftops (PID 18717)
I [22/Apr/2012:19:08:58 -0500] [Job 23] Started filter /usr/lib/cups/filter/brlpdwrapperHL2240D (PID 18718)
I [22/Apr/2012:19:08:58 -0500] [Job 23] Started backend /usr/lib/cups/backend/usb (PID 18719)
E [22/Apr/2012:19:08:58 -0500] PID 18717 (/usr/lib/cups/filter/pdftops) stopped with status 1!
I [22/Apr/2012:19:08:58 -0500] Hint: Try setting the LogLevel to "debug" to find out more.
E [22/Apr/2012:19:08:58 -0500] [Job 23] Job stopped due to filter errors.
I [22/Apr/2012:19:11:32 -0500] [Job ???] Request file type is application/pdf.
I [22/Apr/2012:19:11:32 -0500] [Job 24] Adding start banner page "none".
I [22/Apr/2012:19:11:32 -0500] [Job 24] Adding end banner page "none".
I [22/Apr/2012:19:11:32 -0500] [Job 24] File of type application/pdf queued by "root".
I [22/Apr/2012:19:11:32 -0500] [Job 24] Queued on "Brother_HL-2240D_series_USB_1" by "root".
I [22/Apr/2012:19:11:32 -0500] [Job 24] Started filter /usr/lib/cups/filter/pdftops (PID 22122)
I [22/Apr/2012:19:11:32 -0500] [Job 24] Started filter /usr/lib/cups/filter/brlpdwrapperHL2240D (PID 22123)
I [22/Apr/2012:19:11:32 -0500] [Job 24] Started backend /usr/lib/cups/backend/usb (PID 22124)
E [22/Apr/2012:19:11:32 -0500] PID 22122 (/usr/lib/cups/filter/pdftops) stopped with status 1!
I [22/Apr/2012:19:11:32 -0500] Hint: Try setting the LogLevel to "debug" to find out more.
E [22/Apr/2012:19:11:33 -0500] [Job 24] Job stopped due to filter errors.


Don't know if that's too much, or not enough, but hopefully you'll know what it all means- I sure don't!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9376
Location: Stratford, Ontario

PostPosted: Sun 22 Apr 2012, 22:21    Post subject:  

Wary 5.2 had a problem with printing. Read here for the solution.
Back to top
View user's profile Send private message 
n9viw

Joined: 17 Apr 2012
Posts: 21

PostPosted: Tue 24 Apr 2012, 09:04    Post subject: Success!  

That's got it exactly, thank you again! Off and printing...
Back to top
View user's profile Send private message 
n9viw

Joined: 17 Apr 2012
Posts: 21

PostPosted: Tue 01 May 2012, 21:26    Post subject: Woops, spoke too soon...
Subject description: PDFTops fails when printing from browser
 

My wife just asked me to print a page from our bank account, and the computer woke up the printer, but didn't send the job. A check on CUPS said, "PDFTOPS FAILED". (running Firefox 11)

I managed to save the page as a text file, and that printed out just fine.

Any suggestions?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9376
Location: Stratford, Ontario

PostPosted: Tue 01 May 2012, 22:43    Post subject:  

I set up Wary 5.2 with the pdftops patch and installed a printer. I then installed Firefox 701 along with the dbus stuff that Wary needs to run it.

I could print some web pages but not others and it was slow.

I then repeated the procedure with Slacko. It has a newer CUPS and dbus built-in.

I could print the web pages that Wary could not.

I then went back to Quirky. It has almost the identical print chain as Wary and contains dbus. It printed fine from FF 701.

[Edit] Install the PET below. It makes Wary's print system work more like Quirky's. It worked in my tests with FF701.
gtk_printbackend-2.10.0.pet
Description 
pet

 Download 
Filename  gtk_printbackend-2.10.0.pet 
Filesize  24.86 KB 
Downloaded  563 Time(s) 
Back to top
View user's profile Send private message 
n9viw

Joined: 17 Apr 2012
Posts: 21

PostPosted: Thu 03 May 2012, 09:35    Post subject:  Success! (Again)  

That's got it, I just printed off the first page of this thread to test. Thank you again ever so much... I really would like to learn how to do such things, but I'm no programmer, and I just need the blasted thing to do what I tell it! Laughing Your expertise is much appreciated.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9376
Location: Stratford, Ontario

PostPosted: Thu 03 May 2012, 10:38    Post subject: Re: Success! (Again)  

n9viw wrote:
That's got it, I just printed off the first page of this thread to test.

Just to be sure, please print off the bank statement that caused the original problem.
Back to top
View user's profile Send private message 
n9viw

Joined: 17 Apr 2012
Posts: 21

PostPosted: Wed 25 Jul 2012, 18:18    Post subject: Well, crap!
Subject description: Now printer isn't working again
 

Apropos of absolutely nothing, the printer is refusing to cooperate again. It HAD been working, but now when I select File-> Print... or hit CTRL-P, I get the print options window, hit "Print", I get the "Printing xxx..." progress window, and... nothing.

I've tried reinstalling the files suggested here, but no luck. A new wrinkle I just discovered: Since accidentally uninstalling Firefox (foolishly trying to 'clean up old files', didn't think the FF 4.0 entry in PPM meant my FF11.0!), then reinstalling Firefox, I've 'lost' the factory linkset "Browse" that used to be on the desktop. As a result, CUPS does not load into my browser! I get the Help Surfer, which provides links to this forum, and it says a CUPS interface should open in my default browser in "3-30 seconds", but it never does.

What the heck did I do? Any Linux gurus in the Springfield, MO area who will work for beer? Please don't tell me to go back to Microsoft, I couldn't bear the shame...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0782s ][ Queries: 13 (0.0070s) ][ GZIP on ]