Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 08:54
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary5.3 and Lupu5.28
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 31 Oct 2011
Posts: 8

PostPosted: Thu 03 May 2012, 07:52    Post_subject:  Wary5.3 and Lupu5.28
Sub_title: don't use PPPOE-Connection

Since June 2009 I'm running a frugal install of Puppy421 on a 2GB pen-drive (FAT-16, Superfloppy-mode) and I'm very happy with it. Thank you very much!

AMD Athlon XP3200+
Memory 2075MB, 515MB used
Board K7S8XE+ from 2004
ATI Radeon 9550
SATA 234GB, NTFS formatted, no System

But now I want to start some development on a microcontroller with Forth and serial I/0 to the PC.
Stumbling about Barry Kaulers Page with his experiences about bacon and nicoedit etc, I thought that would be a good choice, even there was a devx for C-development with actual libraries which I would probably need too.

I downloaded Wary5.3, made a CD and a frugal install on a second, equal 2GB pen-drive,
but it didn't boot, not even after a lot of tries, copying back 4.21 with PUDD worked fine, but Wary didn't.

Booting from the CD and connect to my DSL worked like always, PPPOE said 'Connected!',
but Seamonkey timed out. I checked the settings in Seamonkey:
direct connection, I stopped the firewall, checked the settings of DNS-addresses, everything was as usually in 4.21, but still didn't work.

Not knowing, what to do, I tried Lupu5.28 from CD and was very pleased when he correctly found (first time!) my monitor-resolution 1280x720 with the ATI-Radeon 9550.
Sad to say, that the problem with DSL-Connection was the same, even worse, because PPPOE said 'Connected!' too, but for the download of a browser the connection was not accepted, it said:
'Error, please connect to internet.'
The same applied when booting from the CD.

Anyone has experienced one of the problems and knows, how to fix it? Or is there an other version that I should better use?

Of course I'll provide more information if needed.
Back to top
View user's profile Send_private_message 

Joined: 05 Sep 2006
Posts: 9938
Location: Stratford, Ontario

PostPosted: Thu 03 May 2012, 08:36    Post_subject:  

Type this command: cat /etc/resolv.conf.

What do you get back?
Back to top
View user's profile Send_private_message 

Joined: 31 Oct 2011
Posts: 8

PostPosted: Thu 03 May 2012, 11:58    Post_subject: resolv.conf
Sub_title: Screenshot added

Thanks for your instant reply, rcrsn51.

I prepared a Laptop for the test with the WARY5.3 CD, booted, made the setup for PPPOE and started the connection as you can see on the added screenshot.
Then I opend the Browser and tried to open one of the Puppy sites. You can see the result: after about a minute he gave up.
Then I displayed the resolve.conf file with geany.
I compared it with the file in my Puppy4.21 and they have the same contents, of course, the DNS addresses that the provider delivered and I put in at the initial configuration of PPPOE.

But I found some differences:
Examining with MENUE / SYSTEM / HARDINFO
if get from Network / Devices
three interfaces with puppy4.21: lo, eth0 and ppp0.

With Wary5.3 the ppp0 is missing (despite I made the setup!)
But I confess, that at the moment I had plugged out the eth0-cable and connected it with puppy4.21

With IP-Connections its a difference too, Wary5.3 has only two: and
whereas puppy 4.21 has three IP-addresses more:
one with one of the DNS-servers and two local addresses from puppy and the router.

The routing table from Wary has only the loop back address,
and the tab for DNS Servers is empty - which is not in puppy4.21.

That's what I found so far. I hope it helps in finding the problem.

Filename  resolv,conf.png 
Filesize  95.53 KB 
Downloaded  221 Time(s) 
Back to top
View user's profile Send_private_message 

Joined: 11 Oct 2009
Posts: 6270
Location: Charleston S.C. USA

PostPosted: Fri 04 May 2012, 23:54    Post_subject:  

Maybe something here will help.

I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 

Joined: 31 Oct 2011
Posts: 8

PostPosted: Sat 05 May 2012, 12:40    Post_subject:  

Hello bigpup,
you hit the bull's eye! (correct?)

I read the manual, but already the first item didn't apply, because Wary5.3 doesn't have a 'Network Wizard" to configure my LAN-card.

I went on and did the PPPOE-setup by terminal, put in all the needed stuff - same as every time and after PPPOE-start I got the message 'Connected!' again.

But this time a few seconds later a window popped up, telling me that there is no flash-player and I should download it. I ignored that message and invoked the Seamonkey-browser instead and clicked to open one of the Puppy-sites. Surprisingly this time the browser opened the website without any problem.
I did not need to make the 'route del' and 'route add' commands as suggested at point 12 of the manual that you pointed to..

I rebooted several times from the live-CD and I can say that the problem is reproducible, except that the following times I always had manually to delete the default route and add the ppp0 as default.

That was the the problem.

I can make the PPPOE-setup by GUI or by terminal, if the connection is not usable, then the default route needs to be corrected.

Also starting and stopping the connection can be done either way.
I made a Wary.2sf file and after rebooting the problem was still resolved.

Remains the problem with booting from the USB-stick. I read a lot of stuff these days and if I remember correct, someone found, that the Wary.sfs file is expected in a directory named wary5.3, is it?
Back to top
View user's profile Send_private_message 

Joined: 31 Oct 2011
Posts: 8

PostPosted: Sat 05 May 2012, 12:53    Post_subject:
Sub_title: resume.

I thought, I added that file to show the settings, but anyhow it didn't show up.
Description  System-messages/settings

Filename  resume.zip 
Filesize  984 Bytes 
Downloaded  172 Time(s) 
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0596s ][ Queries: 13 (0.0062s) ][ GZIP on ]