Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Dec 2014, 21:06
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
audacity 2.0
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 3 [34 Posts]   Goto page: 1, 2, 3 Next
Author Message
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sat 12 May 2012, 00:14    Post subject:  audacity 2.0  

hey guys...
i have tried to create a pet file with all the needed files to run the latest version of audacity (so far, version 2.0.0.1)...
this is a i386 version...

https://hotfile.com/dl/155658054/d5969ea/audacity-2.0.0.1libc6-2.15.tar.gz.html

here it is the link to download the file...
it's a tar.gz file with 2 pets...
one is the audacity with (hopefully) all the libs and the other one is a critical lib that can be needed or not...
run audacity from terminal and tell me the output...
if you see an error message saying that GLIBXX_3.4.15 whas not found, or GLIBC_2.15 was not found, install the second pet...
it's just to avoid deleting critical files when uninstalling audacity...

p.s.: i had too much problems uploading files and attach them...
to solve that, i created an account on hotfile just to upload my files...
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2481
Location: near here

PostPosted: Sat 12 May 2012, 07:59    Post subject:  

Hi espertalhao04

Nice work, I have recently compiled Audacity 2.0 as well. Will compare notes. I think some forums users may be willing to host large files -small ones are okay to attach to forum. I've been using sendspace but its far from ideal.

Cool

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sat 12 May 2012, 11:57    Post subject:  

I didn't needed to compile anything...
Just went to search for ubuntu packages for quantal and i just had to run from console to check missing libs and searched for them in ubuntu repositories (http://packages.ubuntu.com) and in debian snapshot servers (http://snapshot.debian.org/)...
Then i started to install lib by lib until i found a weird behavior on Opera 11.60...
Chat on facebook had problems (didn't sent and received messages and images where missing all over the page), some slowlyness and stability problems...
Then i installed the debian package with libc6-2.15 and everything is now working fine...
But the debian package had a problem that made my cpu to be loaded at 100% and i couldn't do anything...
The package never finished to install...
Then i decided to create that small pet with the lib...
It may not be needed in slacko or warry but was needed to me (puppy linux 4.3.1)...
It took 3 days to do this...
I hope it is working...
If you have tested my package, please, tell me the exact output from terminal...
It's important...

_________________
asus a6000: intel m 1.6ghz, 2gb ram ddr, no hdd, usb 2.0 pendrive running puppy linux 4.3.1
Back to top
View user's profile Send private message 
kevin bowers

Joined: 20 Dec 2009
Posts: 143

PostPosted: Sat 12 May 2012, 19:25    Post subject:  

Just tried your .pets on Lucid 528.004. Sorry no go. Installed Audacity 2.0.0.1 first, got missing lib message, so installed glibc215. I still get the same output from terminal:

sh-4.1# audacity
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by audacity)
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libwx_gtk2u_adv-2.8.so.0)
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libwx_baseu_net-2.8.so.0)
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libwx_baseu-2.8.so.0)
sh-4.1#

Apparently Audacity still cannot find the necessary libs even after installing the .pet. I tried restarting the computer to no avail. Where does your glibc .pet install to?
Back to top
View user's profile Send private message 
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sat 12 May 2012, 20:38    Post subject:  

i'm having some troubles to find the right lib...
i've found that in debian snapshot servers...
as soon as i find it, i'll post the link to download and the instructions...

_________________
asus a6000: intel m 1.6ghz, 2gb ram ddr, no hdd, usb 2.0 pendrive running puppy linux 4.3.1
Back to top
View user's profile Send private message 
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sat 12 May 2012, 20:58    Post subject:  

i've checked the second pet and it installs to /usr/lib/
it has 2 (relevant) files:

/usr/lib/libc-2.15.so
/usr/lib/libc.so.6

check if everything is ok...

try this on terminal:
strings /usr/lib/libc.so.6 | grep GLIBC

the output should be similar to this:



(i've extracted the lib from the pet and put on that folder, since that i have only a pendrive with fat32 filesystem and it deletes the link, which is important for the lib to work)

_________________
asus a6000: intel m 1.6ghz, 2gb ram ddr, no hdd, usb 2.0 pendrive running puppy linux 4.3.1
Back to top
View user's profile Send private message 
kevin bowers

Joined: 20 Dec 2009
Posts: 143

PostPosted: Sat 12 May 2012, 23:34    Post subject:  

That's just what I get:

sh-4.1# strings /usr/lib/libc.so.6 | grep GLIBC
GLIBC_2.0
GLIBC_2.1
GLIBC_2.1.1
GLIBC_2.1.2
GLIBC_2.1.3
GLIBC_2.2
GLIBC_2.2.1
GLIBC_2.2.2
GLIBC_2.2.3
GLIBC_2.2.4
GLIBC_2.2.6
GLIBC_2.3
GLIBC_2.3.2
GLIBC_2.3.3
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.5
GLIBC_2.6
GLIBC_2.7
GLIBC_2.8
GLIBC_2.9
GLIBC_2.10
GLIBC_2.11
GLIBC_2.12
GLIBC_2.13
GLIBC_2.14
GLIBC_2.15
GLIBC_PRIVATE
GNU C Library (Ubuntu EGLIBC 2.15-0ubuntu11) stable release version 2.15, by Roland McGrath et al.
sh-4.1#

If I read this correctly, Audacity is looking for the file in /lib rather than /usr/lib:

sh-4.1# audacity
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by audacity)
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libwx_gtk2u_adv-2.8.so.0)
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libwx_baseu_net-2.8.so.0)
audacity: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/libwx_baseu-2.8.so.0)
sh-4.1#

So perhaps add a symlink? I'll try that manually & get back to you, probably tomorrow.
Back to top
View user's profile Send private message 
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sat 12 May 2012, 23:57    Post subject:  

try that and tell me the results so that i can post an updated pet...
i've by mistake deleted an older version of libc and Opera got weird...
i put those 2 files in that dir, and everything went ok again...
so, try it...
(right now i'm not trying to use audacity since my savefile is "poisoned" with useless files and there are some pets that i need installed that are not avaiable anymore...)

_________________
asus a6000: intel m 1.6ghz, 2gb ram ddr, no hdd, usb 2.0 pendrive running puppy linux 4.3.1
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2481
Location: near here

PostPosted: Sun 13 May 2012, 07:53    Post subject:  

Here's my attempt at compiling Audacity 2.0.0 for Puppy.

==Installation==
Install audacity-2.0.0-i486.pet

==Compatibility==
Works on Polarpup 005, Puppy 5.29 (3headed dog), Slacko 5.31, Macpup 528, Dpup Exprimo and Precise 5.3.3.3 . Any feed back welcome, especially how to trim down file size.

==Components==
Audacity binary and support libs can be installed separately-
audacity_BIN-2.0.0-i486.pet
audacity_LIB-2.0.0-i486.pet

==Libraries==
Here is a list of the support libraries.(I've tested on polar and slacko. I've included libjack.so.0.0.28, as slacko doesn't come with this lib)
Code:
/usr/lib/libFLAC++.so.6.2.0
/usr/lib/libjack.so.0.0.28
/usr/lib/libSoundTouch.so.1.0.0
/usr/lib/libwx_baseu-2.8.so.0.6.0
/usr/lib/libwx_baseu_net-2.8.so.0.6.0
/usr/lib/libwx_baseu_xml-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_adv-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_aui-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_core-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_fl-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_gizmos-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_gizmos_xrc-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_gl-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_html-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_media-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_ogl-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_plot-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_qa-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_richtext-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_stc-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_svg-2.8.so.0.6.0
/usr/lib/libwx_gtk2u_xrc-2.8.so.0.6.0


==Recording==
If your recording with Audacity you will need to

-set the correct input device, see A 'select input device' (if your using JACK switch it ALSA to select device, then back to JACK)

-turn the capture level up, see D 'capture level up'. Don't confuse Capture with Mic. Mic sets the volume of Mic 'thru' but no the record level.

-you can use Jack to monitor if your system is recording correctly.
audacity-record-levels-up.png
Description  capture level up
png

 Download 
Filename  audacity-record-levels-up.png 
Filesize  58.34 KB 
Downloaded  1107 Time(s) 
audacity_input_soundsubsys.png
 Description   select input device
 Filesize   34.33 KB
 Viewed   2111 Time(s)

audacity_input_soundsubsys.png


_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")

Last edited by darkcity on Sun 20 May 2012, 15:21; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sun 13 May 2012, 12:58    Post subject:  

i didn't needed to compile...
but all the libs included in my pet are from ubuntu and debian...
i've been able to run audacity successfully once...
i didn't done it again because (as i said) my savefile is "poisoned"..
but today i'll try again...
you can check my pet and compare all the libs...
try deleting some libs and check the output...
my advice is to create 2 pets:
one with the audacity bin and all the audacity files (as i got from ubuntu servers) and other with all the required libs...
i've made that version specially to puppy 4.3.1, because it's the version i'm using and i don't have access some needed pets...
they're not available anymore...
but anything i can help, just post here or send pm...

_________________
asus a6000: intel m 1.6ghz, 2gb ram ddr, no hdd, usb 2.0 pendrive running puppy linux 4.3.1
Back to top
View user's profile Send private message 
kevin bowers

Joined: 20 Dec 2009
Posts: 143

PostPosted: Sun 13 May 2012, 16:22    Post subject:  

I think I'm dead-in-the-water. I found that /lib/libc.so.6, which is where Audacity is looking, is a symlink to libc-2.11.1.so, which is apparently too early a version. I tried changing the link to point at libc.215.so--DON'T DO IT! It seems to completely disable Rox and any file operations at all, even opening a new Rox window or any program from the desktop icons. I had to boot to CD and put things back.

Somebody with much more know-how than I must tackle this, at least in Lucid 528-004!
Back to top
View user's profile Send private message 
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sun 13 May 2012, 16:46    Post subject:  

try this from your boot cd (without recording session):
1-rename the second pet to .tar.gz (add it to the end)...
2-open and extract the libc-2.15.so and the symlink to anywhere you want...
3-paste BOTH (first the libc-2.15.so) files at /lib/
4-try running audacity or any program that requires this specific lib, from console...

tell me the results...
i'm trying to get as much info as possible...
so that i can know how to make audacity available to every possible puppy version i can find...

_________________
asus a6000: intel m 1.6ghz, 2gb ram ddr, no hdd, usb 2.0 pendrive running puppy linux 4.3.1
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2481
Location: near here

PostPosted: Sun 13 May 2012, 17:11    Post subject:  

@espertalhao04

espertalhao04 wrote:
...
my advice is to create 2 pets:
one with the audacity bin and all the audacity files (as i got from ubuntu servers) and other with all the required libs...
...


This is what I've done see above- Audacity works for me on 5.29, Polarpup 005 and Slacko. But haven't tested without first installing jack.

@kevin bowers
did you test the Pets that I posted?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
espertalhao04

Joined: 11 May 2012
Posts: 70

PostPosted: Sun 13 May 2012, 17:38    Post subject:  

i can't test you pets right now...
i have my savefile all "poisoned"...
i'll create a new usb drive and i'll test it...
(sorry but this is the only way to get the most reliable results)...
as soon as i test it, i'll post here or pm...

_________________
asus a6000: intel m 1.6ghz, 2gb ram ddr, no hdd, usb 2.0 pendrive running puppy linux 4.3.1
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2481
Location: near here

PostPosted: Sun 13 May 2012, 18:35    Post subject:  

sorry to hear about your savefile problem, have you tried e2fsck, for example-

e2fsck -y /mnt/home/puppy3head/lucisave-super.2fs

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 3 [34 Posts]   Goto page: 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0868s ][ Queries: 13 (0.0054s) ][ GZIP on ]