Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 20:30
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Filesystem
XFE (X File Explorer) - file manager for Lucid 525
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [38 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Wed 07 Sep 2011, 14:49    Post subject:
Subject description: Open pet files with xfe
 

Hi sylvander !

Thanks for your hard effort to help me.
I deleted and reinstalled XFE.

Made a new test to open pet files right clicking(pet file)> click open (pet file)

For several seconds a round symbol appears then stops
nothing happenend ,no asking for installation, no installation.

Right clicked the pet file > menu attributes properties> file connections
it is not connectet to any command.

"PET files should already be associated with the program that opens them [I forget the program]. "

Exactly this is what could lead me out of my misery

I am not in a hurry.
Maybe If your health is getting better ,would you please have a look to this "open with " command on your filebrowsers to give me any advice .
Thanks in advance.
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3401
Location: West Lothian, Scotland, UK

PostPosted: Wed 07 Sep 2011, 15:03    Post subject:  

1. Which PET file[s] did you use to install Xfe?

2. I used this version.
And...
I use this xfe_staticFOX-1.32.1-i486.pet.
It's the best I've found so far.

3. The program to use to "Open..." PET files is:
/usr/sbin/petget
Back to top
View user's profile Send private message 
backi

Joined: 27 Feb 2011
Posts: 433
Location: GERMANY

PostPosted: Wed 07 Sep 2011, 16:12    Post subject:  

Hi sylvander !

Connect "open with" to petget.
Works fine now .

Thank you
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3401
Location: West Lothian, Scotland, UK

PostPosted: Wed 07 Sep 2011, 17:00    Post subject:  

Good result. Very Happy Cool
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sun 13 May 2012, 09:34    Post subject:  

I got curious on this XFE after reading about Mu file manager? over here:
http://www.murga-linux.com/puppy/viewtopic.php?p=627287#627287

So is this the latest then?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3401
Location: West Lothian, Scotland, UK

PostPosted: Sun 13 May 2012, 11:54    Post subject:  

nooby wrote:
So is this the latest then?

So many versions going around.
Here in Lupu-528.005...
I installed the version included in the "Puppy Package Manager" [PPM]...
Which is...
xfe-1.32.2-lucid52
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sun 13 May 2012, 15:15    Post subject:  

Thanks maybe best if I use that one instead then.
_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
`f00


Joined: 06 Nov 2008
Posts: 809
Location: the Western Reserve

PostPosted: Sun 13 May 2012, 15:54    Post subject:
Subject description: fairly basic
 

Yep, only a *.**.2-4 change - funny, I cobbled together a 'duo' with both 1.19.2 and 1.32.2 just so I could have the luxury of two separate xfe fms and their distinct add-ons (works great but F3 always gives the 132 for a new instance) .. 119 might be a trifle quicker but it's a wash with 132's features/gui. Kind of a brown theme for 119 and greenish for 132

'way adaptable, even got it working in pup104 barebones Laughing
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3401
Location: West Lothian, Scotland, UK

PostPosted: Sun 13 May 2012, 16:14    Post subject:  

@f00
Any chance of you fixing the problem with the "Open with..." feature? Very Happy
Back to top
View user's profile Send private message 
`f00


Joined: 06 Nov 2008
Posts: 809
Location: the Western Reserve

PostPosted: Sun 13 May 2012, 18:03    Post subject:
Subject description: mwahahah
 

That one is a sleeping dog for me (since so far I can't rebuild the gui to only have a dropdown box, ideal would be a context menu branch if it could be done which I doubt in a simple hierarchy). Normally I simply edit a nice selection of 'History' apps for anything that fits a personal openwith kit for the dropbox and leave the other button alooone .. dog sleeps nice enough.

Some like to 'associate' filetypes, I find it easier to edit the rc - tip! to make it easier to find ext-lines, sort the filetypes section in medit or any text editor that has the sort function .. it gets unsorted afterwards but helps for when you're working there (search is another, but sometimes gives too much). One of the few pitbs to making xfe universal is the wide array of different apps in different pups (like media players and bare html viewers).

xfe needs a general discussion catchall thread Very Happy
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Mon 14 May 2012, 01:12    Post subject:  

I feel so out of the loop Smile
What is this "Open with" everybody talks about.
I'm totally lost ...You mean it is not added to the Menu?
Does one need to go to terminal and call it up with parameters?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3401
Location: West Lothian, Scotland, UK

PostPosted: Mon 14 May 2012, 02:25    Post subject:  

2. If I'm running Xfe...
And I right-click on a file...
Lets say it's a PET file...
The context menu displayed includes "Open with..." as one of the listed choices.
So...

2. If I then click on "Open with..."...
A dialog opens that aught to offer the means to choose a program to use to "Open" the file.
[Also offers a tick-box to associate the program to always automatically be used to open that file type.]
But...

3. Unless I apply a workaround...
The drop-down-box is EMPTY!
[The workaround populates the drop-down-box with programs that I specify]
So...

4. In the case where the drop-down-box is empty...
I would be forced to manually navigate to a suitable program [e.g. petget to open a PET file]...
Which is an inconvenience.

5. Right now...
Having applied the workaround...
My Xfe->"Open with..." drop-down-box includes:
leafpad, abiword, epdfview, ffconvert, foxit, geany, gnome-mplayer, md5sum, mplayer, mtpaint, notepad.
Note that petget isn't included! Sad
Must get around to adding that to the list.
Tried to do it right now, but it fails to take for some reason. Confused

6. Here's a post [in my Puppy Linux thread at the PC-Guide forums] with a link to the workaround method I'm using.
Back to top
View user's profile Send private message 
capicoso

Joined: 13 Jan 2012
Posts: 172
Location: Argentina

PostPosted: Thu 17 May 2012, 15:02    Post subject:  

Hi. I wonder if you can help me...
I use Lucid Puppy 5.28-004 and JWM. I installed XFE from the PPM. I wanted to make it my default file manager so i downloaded Sylvander's pet to make it default instead of ROX.
Everything is ok, except the drive icons on my desktop. When i click them, XFE opens, that's ok. But they don't refresh. If i connect i.e an external HDD, it won't figure on my desktop because it's not refreshing, also, i don't know when they're mounted or not... any solution?

Thanks
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3401
Location: West Lothian, Scotland, UK

PostPosted: Thu 17 May 2012, 15:35    Post subject:  

1. "I use Lucid Puppy 5.28-004"
(a) How about updating to the latest version = lupu-528.005?
What kind of install are you running?
"Live" CD, and pupsave file?

2. "I wanted to make it my default file manager so i downloaded Sylvander's pet to make it default instead of ROX"
(a) Is THIS the kind of thing you used to make Xfe the default file manager?
That's rather ancient now, and I no longer use it, because it's something of a pest to have Xfe open each time a partition is mounted by being clicked on the desktop.
I leave the Puppy as originally set up, so that ROX opens by default...
Then I just close ROX and open Xfe instead if I prefer [and I usually do].

3. "But they don't refresh. If i connect i.e an external HDD, it won't figure on my desktop because it's not refreshing, also, i don't know when they're mounted or not... any solution?"
(a) If it were me...
I'd uninstall the program used to make Xfe the default file manager...
Or by any means you prefer->[restore a pupsave backup], go back to using ROX as the default file manager.
Then...

(b) Update to lupu-528.005.
Back to top
View user's profile Send private message 
`f00


Joined: 06 Nov 2008
Posts: 809
Location: the Western Reserve

PostPosted: Thu 17 May 2012, 18:37    Post subject:
Subject description: addenda (disguised spitball)
 

3) yep, leave rox as the default fm for desktop driveicons (a bit involved to change that so it works correctly with anything else) - an alternative is pmount, not so hard to edit so that it doesn't automatically load rox when mounting (search 'rox' after you open pmount in a text editor and try some selective commenting out of lines 'til you get the one that doesn't auto rox when it's #'d). Either way works (pmount is a bit less convenient than desktop driveicons, but if you don't use the rox pinboard .. it all depends on how much you use something as to how convenient it is).

xfe132 should display mounted drive-fs in /mnt with a fairly obvious icon (at least it's not a folder image), rclick to get unmount or use pmount or.. (pmount should 'refresh' itself as part of probe if used) - to refresh an xfe panel ctrl+r, or F1 for the very useful built-in tips Wink

for sfs, 2-4fs filetypes I have filemnt as the 'open' operator in xferc's filetypes section - rclick->'open' to mount, 'open' again to unmount (almost like the clickon in rox). These are a somewhat special case, especially sfs types (older/newer can "fail to mount" depending on compatibility with the running pup .. then you have to clear it to unmount the parent drive-fs)

@capicoso - you can always put xfe in the rox openwith (can't recall offhand which xapplication***etc so it gets inode proper Confused , rox/mimetypes is fun that way Laughing )

@Sylvander - lately on the saluki thread, there's a request for xfe Smile interesting..
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [38 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Filesystem
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0892s ][ Queries: 13 (0.0122s) ][ GZIP on ]