Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 06:14
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Imagemagick error
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
ravensrest


Joined: 22 Feb 2008
Posts: 321
Location: Hood Canal, WA

PostPosted: Mon 21 May 2012, 16:15    Post_subject:  Imagemagick error  

I installed ImageMagick6.6.2-6-w5 in Wary 5.3 from the Puppy Package Manager. When I tried to run it, I got this:

Quote:
[~]> convert /data/lm124.pdf /data/lm124.jpg
convert: /usr/lib/libxml2.so.2: no version information available (required by /usr/lib/libMagickCore.so.3)
CRIT: rangecheck in .setuserparams
Operand stack:
--nostringval-- --nostringval-- --nostringval--
convert: Postscript delegate failed `/data/lm124.pdf': @ error/pdf.c/ReadPDFImage/645.
convert: missing an image filename `/data/lm124.jpg' @ error/convert.c/ConvertImageCommand/2970.


I notice that libxml2.so.2 is symlinked to libxml2.so.2.7.8. Any idea what I need to do to get it working?
Thanks,
BS
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4050
Location: World_Hub

PostPosted: Mon 21 May 2012, 18:44    Post_subject:  

Here's what I don't like after running: convert -list configure >> No gs in delegates and the bolded bit..
Quote:
DELEGATES bzlib fontconfig freetype jpeg jng jp2 lcms mpeg png rsvg tiff x11 xml zlib
DISTCHECK_CONFIG_FLAGS 'CFLAGS=-O2 -pipe -fomit-frame-pointer' --disable-deprecated --with-quantum-depth=16 --with-umem=no --with-autotrace=no --with-gslib=no --with-fontpath= --with-perl=no

Seems gs is essential- http://www.multipole.org/discourse-server/viewtopic.php?f=1&t=18289

Not sure where I'd take this just yet.. IM's got a lotta deps....

Maybe these conversions I'd pass to Gimp..
Back to top
View user's profile Send_private_message 
ravensrest


Joined: 22 Feb 2008
Posts: 321
Location: Hood Canal, WA

PostPosted: Tue 22 May 2012, 16:37    Post_subject:  

Thanks, Semme. I still don't understand what is happening, but here is a bit more info. I run Imagemagick6.6.9.5 under lupu_528 just fine. It has the same DELEGATES line as Imagemagick6.6.2.6 under Racy53 or Wary53 which gives me the error originally posted. In addition, if I use 6.6.2.6 under Racy or Wary to convert, say, jpg to tiff, I get the same error re no version info for libxml2, but it goes ahead and completes the conversion anyway.

Guesses?
BS
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4050
Location: World_Hub

PostPosted: Tue 22 May 2012, 16:57    Post_subject:  

From reading through several threads I'm leaning towards a versioning mismatch over any missing libs..

That the conversion goes through, does adding the -density switch help?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Tue 22 May 2012, 18:04    Post_subject:  

Wary has a much older version of Ghostscript compared to Lupu, so that might be the problem. Or it might be that Imagemagick in Wary was never built against Ghostscript.

However, it is possible to convert PDFs to JPGs in Wary with a bit of scripting. But it assumes that your PDF is a simple one-page document.

Is that what you are looking for?
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4050
Location: World_Hub

PostPosted: Tue 22 May 2012, 23:04    Post_subject:  

Older? BINGO! Right'choo are Rcrsn. Wary 5.1.2- pacman offers v8.15.4.

On your tip I overwrote the existing GS with v8.71 and guess what?

She's FLAWLESS!
Back to top
View user's profile Send_private_message 
ravensrest


Joined: 22 Feb 2008
Posts: 321
Location: Hood Canal, WA

PostPosted: Wed 23 May 2012, 12:59    Post_subject:  

Thank you rcrsn51 and semme for your continued comments. What I am trying to do is extract specific pictures from multipage pdf documents in jpg format. I can do this perfectly well in lupu528 using imagemagick (and converseen if I don't want to use command line). I have been trying to get the same process working in racy/slacko/wary with no luck. I can use screen captures, but that limits my resolution to 72 dpi.

As an aside, lupu528 is the only distro I've had since puppy431 that lets me do everything I want without hangups. I can make some stuff run in wary, some in slacko, but only 528 and 431 let me do everything.

Most recently I downloaded ghostscript8.71 as suggested. It made no difference whatsoever. Still get the original error messages.
BS

Edited_time_total
Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4050
Location: World_Hub

PostPosted: Wed 23 May 2012, 13:48    Post_subject:  

I don't run Wary per se, and like you prefer the fluid performance of 5.28.

That you still had errors, bump it- ghostscript-9.02-i486-1_slack13.37.txz

I don't have 5.3 to test- nor will I be dwnlding anytime soon....
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0550s ][ Queries: 12 (0.0036s) ][ GZIP on ]