Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 21:09
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Precise Puppy RC2, October 20, 2012
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 59 [875 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 57, 58, 59 Next
Author Message
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Tue 05 Jun 2012, 10:05    Post subject:  

LateAdopter wrote:
To summarize, I think it's like this:

Radeon R600g Driver requires DRI2 KMS does not do userspace modesetting

Precise Kernel + Radeon Module does KMS DRI2, which is correct.

DRI can do KMS or userspace or no modesetting

DRI2 requires KMS

My RS880 will do DRI or DRI2 with R600

01micko's Evergreen only does DRI2 with R600

drm has decided that KMS is not supported, which is incorrect. WHY?

My RS880 ends up with DRI2 in the kernel and DRI in the R600 hence no display at all.

01micko's ends up with DRI2 in the kernel and no DRI/DRI2 in the R600 hence display but no acceleration.

With modeset=0 kernel falls back to DRI

My RS880 ends up with DRI in the kernel and R600, hence 2D acceleration but no 3D acceleration.

01micko's Evergreen can't do DRI with R600. So probably no change.


I hope that makes sense!


Hmmm! Oh well, beta2 will have yet another permutation to try!

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
peebee


Joined: 21 Sep 2008
Posts: 1275
Location: Malvern, Worcs, UK

PostPosted: Tue 05 Jun 2012, 12:46    Post subject: Re: WiFi problem  

sszindian wrote:
# lsusb
Bus 001 Device 002: ID 13b1:002f Linksys AE1000 v1 802.11n [Ralink RT3572]
>>>---Indian------>


Hi Indian

Well you defo don't have a Broadcom device so pets for Broadcom should have no effect!!

To try and help I've been doing a bit of Googling and investigating.

Your lsmod confirms that the driver for RT3572 is rt2800usb and this is present in Precise.

Also needed for the RT3572 is firmware rt2870.bin - this is stored in
Code:
/lib/modules/all-firmware/rt2x00/lib/firmware

I've checked the dates for this firmware in Precise and in Slacko and they are different:
    Precise - 2012-02-27 12:34 rt2870.bin
    Slacko - 2012-04-25 06:35 rt2870.bin
so what I would try is to copy the firmware directory from Slacko to Precise.

I'd also load and try Frisbee - have you tried Frisbee?

Another silly thought - given that this is a usb device - are you sure that the usb slot is working reliably and that the stick is firmly inserted into the slot??

That's the limit of my contribution I'm afraid.
Cheers
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 578
Location: Pennsylvania U.S.

PostPosted: Tue 05 Jun 2012, 17:06    Post subject: 5.2.58 New Install  

peebee...

Enough to make me want to pull out what little hair I have left!!!!!

I tried installing the firmware from Slacko in a fresh pfix=ram 5.2.58 and that didn't work!

So just out of frustation I did another fresh ram-install of 5.2.58 and tried the original Precise with everything it comes with... no changes... configured WiFi with original setup package and.... everything now appears to be working just fine, been online about an hour without a drop... shutdown, created a savefile, re-booted, WiFi came right online....

I guess it's possible somehow I may have had a corrupt original savefile???? also I haven't tried an 'eth0 config' yet to see what that does... one thing at a time!

I will run this for a few days and see how it goes!

I appreciate your help, and sorry to take up your time but maybe something good will come from this and help someone on down the line somewhere? 'If A Problem Occurs... Start All Over From Scratch' then go tweaking from there if problems persist, sometimes the simplest is the best route to go.

Now I will try adding stuff to 5.2.58 and see if maybe somewhere there something may cause Precise to go haywire?... if so, I'll post!

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 578
Location: Pennsylvania U.S.

PostPosted: Tue 05 Jun 2012, 19:11    Post subject: 5.2.58  

When I access Precise 5.2.58 'savefile' from a different Puppy version and go to the 'usr' file this comes up.... 'Is something not working?'

>>>---Indian------>
image-1.png
 Description   
 Filesize   21.94 KB
 Viewed   2221 Time(s)

image-1.png


_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
BHINTZ

Joined: 08 Aug 2006
Posts: 137

PostPosted: Tue 05 Jun 2012, 20:38    Post subject:  

Has anyone been working on sleep/resume for laptops.

I tried to move acpi from upup, but that didn't work

bob
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1077
Location: Republic of Vermont

PostPosted: Tue 05 Jun 2012, 21:51    Post subject:  

BHINTZ wrote:
Has anyone been working on sleep/resume for laptops.

I tried to move acpi from upup, but that didn't work

bob


OT, but yes:

http://murga-linux.com/puppy/viewtopic.php?p=631539#631539

_________________
New Acer Aspire 5349-2635 dual proc, 4gb ram, re-partitioned with frugal Racy 5.3, dual boot, running rings around Win 7.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Tue 05 Jun 2012, 23:34    Post subject:  

Precise Puppy 5.2.60 (beta2) is out.

Download from here:

http://distro.ibiblio.org/quirky/test/precise-5.2.60/

I haven't documented everything on my blog. For example, this pup has shinobar's getflash. Pemasu sent me a list of what packages he had installed in his Upup, and I adjusted my build to use most of them also.

My Raspberry Pi has arrived, so I will switch over to playing with that for awhile.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2386
Location: Japan

PostPosted: Wed 06 Jun 2012, 00:37    Post subject: mirror  

BarryK wrote:
Precise Puppy 5.2.60 (beta2) is out.
Download from here:
http://distro.ibiblio.org/quirky/test/precise-5.2.60/

mirrored.
http://shino.pos.to/party/bridge.cgi?puppy/precise/

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5453
Location: Kentucky

PostPosted: Wed 06 Jun 2012, 01:45    Post subject:  

Precise Puppy 5.2.60...... live with a savefile on usb flash drive. Sound and internet working on initial boot. For a change, the screen resolution is the correct 1366x768 on initial boot....the first Precise build to do so.

# report-video
Precise Puppy, version 5.2.60 on Wed 6 Jun 2012

Chip description:
d.0 VGA compatible controller
NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

X Server: Xorg
Driver used: # vesa

X.Org version: 1.11.3
dimensions: 1366x768 pixels (361x203 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
#
Actually using the "nouveau" driver.

-Computer-
Processor : 4x AMD Athlon(tm) II X4 620 Processor
Memory : 3884MB (179MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Wed 06 Jun 2012 12:45:29 AM CDT
-Display-
Resolution : 1366x768 pixels
OpenGL Renderer : Gallium 0.4 on NV4C
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA NVidia

# free
total used free shared buffers
Mem: 3884252 524612 3359640 0 56496
-/+ buffers: 468116 3416136
Swap: 0 0 0
#
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 1936
Location: Ontario Canada

PostPosted: Wed 06 Jun 2012, 01:52    Post subject: Precise Puppy beta2, June 6, 2012  

Manual frugal install to an 8gb flash drive.

Precise Puppy, version 5.2.60 on Wed 6 Jun 2012

Chip description:
0.0 VGA compatible controller
NVIDIA Corporation G84 [GeForce 8600 GT] (rev a1)
oem: NVIDIA
product: G84 Board - p402h00 Chip Rev

X Server: Xorg
Driver used: nvidia

X.Org version: 1.11.3
dimensions: 1280x1024 pixels (382x302 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
# glxgears
50525 frames in 5.0 seconds = 10104.836 FPS
50584 frames in 5.0 seconds = 10116.737 FPS
50540 frames in 5.0 seconds = 10107.931 FPS

OpenGL
Vendor NVIDIA Corporation
Renderer GeForce 8600 GT/PCIe/SSE2
Version 3.3.0 NVIDIA 295.53
Direct Rendering Yes

Computer
Processor 4x Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Memory 8310MB (260MB used)

Gtkhash is still not working so I downloaded the source and made a pet of it.
gtkhash-0.6.0-i686.pet
Description 
pet

 Download 
Filename  gtkhash-0.6.0-i686.pet 
Filesize  41.67 KB 
Downloaded  287 Time(s) 
gtkhash_NLS-0.6.0-i686.pet
Description 
pet

 Download 
Filename  gtkhash_NLS-0.6.0-i686.pet 
Filesize  8.19 KB 
Downloaded  279 Time(s) 
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2481
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Wed 06 Jun 2012, 07:19    Post subject: Re: bug
Subject description: fix
 

BarryK wrote:
L18L wrote:
# puppyhelp
/usr/local/bin/gtkmoz: line 29: exec: mozilla: not found
#

Code:
ln -s /usr/lib/seamonkey/seamonkey-bin /usr/local/bin/mozilla

and
Code:
puppyhelp

is showing translated index.html now Smile


L18L,
I am running Precise 5.2.58, and /usr/bin/mozilla exists. Running 'puppyhelp' works.

Thank you, it has been my fault dealing with multiple langpack versions for seamonkey.
BTW: latest langpack_de always here

-------
edit
HOWTO-localize-Mozilla

Last edited by L18L on Wed 06 Jun 2012, 16:16; edited 4 times in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 1936
Location: Ontario Canada

PostPosted: Wed 06 Jun 2012, 11:06    Post subject: Precise Puppy beta2, June 6, 2012  

After using beta 2 for a while and doing a bit of customizing I
haven't had any problems.
I haven't tested every application etc, but it's working well so far.
screenshot.jpg
 Description   
 Filesize   151.34 KB
 Viewed   1969 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1275
Location: Malvern, Worcs, UK

PostPosted: Wed 06 Jun 2012, 12:30    Post subject: PPM oddity on update  

I updated my 5.2.58 savefile which included installed pets.

When I ran the Package Manager in 5.2.60 only the description of the pets was displayed (no pet name) and if that was clicked to uninstall then a big red error box appeared (sorry didn't capture).

However easily fixed as if PPM is exited and then restarted both the name of the pet and an icon are displayed and an uninstall click works correctly.

Thought I'd mention....
Cheers
peebee

_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
cowonjolt

Joined: 10 May 2012
Posts: 14

PostPosted: Wed 06 Jun 2012, 13:08    Post subject:  beta2  

On toshiba tecra 1.66ghz core duo w/1.5gb ram beta2 will not boot. Had no trouble with 5.2.55 or with 5.2.58 except 5.2.58 takes 6 minutes to boot up with long wait time to load drivers etc. With 5.2.60 it just sits and never loads drivers or moves forward. Have burnt iso 2 times and verified the burn both times with same result. I am running a live multi session of 5.2.58 with no working hard drive.
PS: not to sound dumb but what do the deltas do and/or how do you apply it?; I assumed the delta was to update 5.2.58 to 5.2.60 without a full install but I am not finding info on it.
Also, thanks to runtt21 for the fix for 2 of my first post questions and to OscarTalks for the vlc pet link. I will give the vlc pet a try and post back if it works... thanks again.
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1388

PostPosted: Wed 06 Jun 2012, 14:07    Post subject: Re: Geany colors  

mavrothal wrote:
Geany has "funny" colors in screens with 16 bit depth.
I remember having seen some comment on Pemasu's Precise but no solution.
Even if you get new color schemes for geany, the problem persists.
Googling for it, looks like an Ubuntu problem though I came across a likely bug in Fedora 17.
Anyone has any idea?


I do not have any idea Rolling Eyes but I compiled Geany from the latest git in Precise 5.2.60 using the defaults and works fine.
No green background color.
The exe, dev, doc,and nls pets are all together here, in case someone with this problem needs them (md5sum: 5a1f194888d1121dcaa6c0adb650bc32)

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 15 of 59 [875 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 57, 58, 59 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0936s ][ Queries: 13 (0.0125s) ][ GZIP on ]