Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 28 Aug 2014, 07:31
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Fatdog64-600 alpha2
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 17 [246 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17 Next
Author Message
Billtoo


Joined: 07 Apr 2009
Posts: 2081
Location: Ontario Canada

PostPosted: Mon 04 Jun 2012, 23:47    Post subject:
Subject description: gtkhash
 

Here's a pet of Gtkhash checksum utility,the icon will show up in the general utilities section of the puppy menu.
gtkhash-0.6.0-x86_64.pet
Description 
pet

 Download 
Filename  gtkhash-0.6.0-x86_64.pet 
Filesize  31.02 KB 
Downloaded  320 Time(s) 
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Tue 05 Jun 2012, 01:30    Post subject:  

Some little bugs uncovered.

If I install "slim" login manager it seems that the drive icons don't show up. I traced it to the "get_USER" function and I got USER=

Naturally the script exited. For now I just replaced xinit with init, as that is where it was failing for me, drive icons returned. There was no xinit process listed in the output of "ps -eo user,comm" Confused

Also, if slim is installed it breaks anything that is called with user spot. I guess you knew that Smile .

-

Symlink /usr/lib64/libpcre.so.0 is missing, sven daemon complains but sven still works, maybe just not 100%.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 2120
Location: The Blue Marble

PostPosted: Tue 05 Jun 2012, 05:09    Post subject:  

01micko wrote:
Some little bugs uncovered.

If I install "slim" login manager it seems that the drive icons don't show up. I traced it to the "get_USER" function and I got USER=

Naturally the script exited. For now I just replaced xinit with init, as that is where it was failing for me, drive icons returned. There was no xinit process listed in the output of "ps -eo user,comm" Confused
Yes. Slim does not use xinit to launch X server, it launched xinitrc directly. I replaced "xinit" with "freememappletd".

Quote:
Also, if slim is installed it breaks anything that is called with user spot. I guess you knew that Smile .
Yes, same comment above. This is because slim runs the X server with security enabled (using .Xauthority file), thus simply changing user to spot will not work because spot does not have the required "cookie". Again, this is fixed in the next release (where the spot scripts pass the authority file to spot before doing su).

Slim isn't really supported for alpha2 - it will be supported fully in the next release (or from the current trunk build).

Quote:
Symlink /usr/lib64/libpcre.so.0 is missing, sven daemon complains but sven still works, maybe just not 100%.
I need to look at this ... anyway what does sven have to do with regular expression library? odd Rolling Eyes
_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Tue 05 Jun 2012, 05:21    Post subject:  

jamesbond wrote:

Quote:
Symlink /usr/lib64/libpcre.so.0 is missing, sven daemon complains but sven still works, maybe just not 100%.
I need to look at this ... anyway what does sven have to do with regular expression library? odd Rolling Eyes


I've no idea! Confused (more in a moment)

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 2120
Location: The Blue Marble

PostPosted: Tue 05 Jun 2012, 05:26    Post subject: Re: Use of Remaster tool  

gcmartin wrote:
(BTW, I know that other things have priority, is it on your list for your Netboot PET to get an upgrade to handle the naming in FATDOG?)

Here to help

No update is needed. Fatdog can be pxe-booted directly from ISO image. My syslinux.cfg/default file looks like this:
Code:
default fatdog

label fatdog
kernel memdisk
initrd test.iso
append iso raw

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Tue 05 Jun 2012, 05:33    Post subject:  

Yeah it's a sven plugin...

here's the error in the /var/log/slim.log
Code:
DIR:/root/.sven/plugins
DIR:/usr/lib64/sven/plugins
Plugin Add[0]:/usr/lib64/sven/plugins/autoconvert.so
Could not load plugin: "/usr/lib64/sven/plugins/autoconvert.so"
Dynamic Loader Error: libpcre.so.0: cannot open shared object file: No such file or directory
Make the link, no error.

Understood on the other stuff mentioned in the earlier post Wink

While I'm at it... a similar error to Jim's regarding libxml , both with libreoffice 3.5.4 and pidgin....
Code:
# pidgin
pidgin: /usr/lib/libxml2.so.2: no version information available (required by /usr/lib/libpurple.so.0)


Pidgin still runs but I haven't fully checked out yet, will shortly. Libreoffice-3.4.6 however (older version) runs fine.

EDIT: yep, online @ #puppylinux right now, so that works.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 2120
Location: The Blue Marble

PostPosted: Tue 05 Jun 2012, 06:30    Post subject:  

01micko wrote:
Yeah it's a sven plugin...

here's the error in the /var/log/slim.log
Code:
DIR:/root/.sven/plugins
DIR:/usr/lib64/sven/plugins
Plugin Add[0]:/usr/lib64/sven/plugins/autoconvert.so
Could not load plugin: "/usr/lib64/sven/plugins/autoconvert.so"
Dynamic Loader Error: libpcre.so.0: cannot open shared object file: No such file or directory
Make the link, no error.

Not sure what the plugin is for. The text says it is "automatic russian / english layout", and there are pictures of national flags, running it seems to show the currently chose XKB layout. But I don't see anyway to change it. Plus, after it is activated (by adding the link) - I can't even configure sven anymore. Trying to add more hotkeys will crash it. That being said, sven is old and un-maintained. The website seems to be down. But it is still the nicest keyboard daemon out there.

EDIT: I patched sven a little bit to make it less crash-o-matic. I removed autoconvert plugin as I'm not sure what it is for and I can't get it to work properly anyway (disabling the pluging will crash sven).

Quote:
Understood on the other stuff mentioned in the earlier post Wink
Ahhh, that's for the brave and the bold ... the latest trunk will allow you to do "su - spot; xinit -- :1" - and have two desktops running ...

Quote:
While I'm at it... a similar error to Jim's regarding libxml , both with libreoffice 3.5.4 and pidgin....
Code:
# pidgin
pidgin: /usr/lib/libxml2.so.2: no version information available (required by /usr/lib/libpurple.so.0)


Pidgin still runs but I haven't fully checked out yet, will shortly. Libreoffice-3.4.6 however (older version) runs fine.
That's probably because pidgin is still the old pidgin in 521, while libxml has been upgraded. But it should still work ...

Quote:
EDIT: yep, online @ #puppylinux right now, so that works.
Yes! Very Happy
_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 2120
Location: The Blue Marble

PostPosted: Tue 05 Jun 2012, 08:26    Post subject:
Subject description: gtkhash
 

Billtoo wrote:
Here's a pet of Gtkhash checksum utility,the icon will show up in the general utilities section of the puppy menu.

Updated to the pet repo, thanks Bill.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2081
Location: Ontario Canada

PostPosted: Tue 05 Jun 2012, 17:32    Post subject:
Subject description: cmus music player
 

I found out how to play radio streams in cmus.
I open the terminal and do:
su spot
cmus

Most secure way to run it for streams I think.

I've found Icecast streams work, in the cmus playlist screen (3) you
need to enter : then add, plus a space, then you can copy and paste the
stream or enter it manually and it will be remembered.
x to start the stream, b to switch to the next stream in the playlist,
and v to stop playing the current stream.

I think cmus is a pretty cool application Smile
cmusscrn.jpg
 Description   
 Filesize   167.66 KB
 Viewed   862 Time(s)

cmusscrn.jpg

Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 2120
Location: The Blue Marble

PostPosted: Thu 07 Jun 2012, 04:43    Post subject:  

irishrm wrote:
kirk:
jamesbond:

I did a very careful re-install directly to USB.

During the install i was given the default option of moving the download file outside of the savefile.
I un-ticked that box and my downloads are appearing in spot as they should do.

I have downloaded some small and large downloads even a youtube video without any hiccup.

so far so good "upward and onwards"
irishrm.

I may have found the source of this problem and fixed it. Let's see if this works on the next release.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 2120
Location: The Blue Marble

PostPosted: Thu 07 Jun 2012, 04:56    Post subject: Re: Post #1 Fd64-600a2 request quick how-to frugal & grub menu
Subject description: Want to frugal install on sda6 along side Fatdog64- 521 on sda3
 

openwell3 wrote:
Hi,
I have failed trying to do frugal install.
New boot options, new homogenus frugal, new grub stuff difficult.
My request may help many users-

Can you edit post#1 to add-
1. Frugal install of "600" steps
2. Then, grub menu.lst example(s)

Seems everything is different, and I know others are having trouble too.
Thread seems to refer to FAQ, but cluttered with too many specific problems. No offense to Jim1911 or others.

I want to keep frugal install "521" on sda3 and do frugal install of "600a2" on sda6
Many thanks,
Openwell

I don't think anyone has answered this before. Assuming you already have grub installed somewhere and comfortable to edit menu.lst yourself, the easiest way to do it is to copy vmlinuz and initrd from Fatdog iso to the root directory of sda6, and add this to your menu.lst:
Code:
title Fatdog 600
root (hd0,5)
kernel /vmlinuz
initrd /initrd

Good luck.

PS: The FAQ link is already on the first post.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1602

PostPosted: Sat 09 Jun 2012, 02:21    Post subject:  

Tried alpha2 briefly on a manual frugal install and found no way to get sfs loader to load the devx.
I guess this is answered somewhere in the pervious 14 pages. Would someone point me to it please (and maybe add it to the top or Q&A post).

Another strange thing is that although vmlinuz/initrd were in the /FatDog folder of the boot device, the savefile went to the root of the device with no option to change that.
That makes it a bit messy when FatDog is installed along few other puppies in a partition.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 2120
Location: The Blue Marble

PostPosted: Sat 09 Jun 2012, 04:50    Post subject:  

Hi,

mavrothal wrote:
Tried alpha2 briefly on a manual frugal install and found no way to get sfs loader to load the devx.
I guess this is answered somewhere in the pervious 14 pages. Would someone point me to it please (and maybe add it to the top or Q&A post).

I can't remember whether it is in System or Setup menu, but there is a "System SFS Loader" that enables you to any sfs that you need. The SFS loader can load SFS from anywhere (by default from /mnt/home) - just choose the folder that contains the SFS, then click "refresh". If you want to load the SFS at every boot, click "load permanently" before loading it.

Quote:

Another strange thing is that although vmlinuz/initrd were in the /FatDog folder of the boot device, the savefile went to the root of the device with no option to change that.
That makes it a bit messy when FatDog is installed along few other puppies in a partition.

You can put the savefile anywhere. By default Fatdog only tries to look at the root of the partition to make it faster. But if you know exactly where is the savefile, you can put the "savefile" boot parameter as follows: savefile=direct:device:sda6:/path/to/savefile.
- direct means directly use savefile (not using RAM layer) - just like standard puppy PUPMODE=12
- device means you want to specify the device name
- sda6 is - well - that's your partition
- /path/to/savefile

For for possibilities on the savefile, you can read the boot-options FAQ specified in the 1st (or 2nd) post.

When running without any savefile (savefile=none), during shutdown you will be asked to create a savefile. This savefile doesn't have to be in the root partition, it can be elsewhere too. Just type the full path as needed (don't worry if the subdirectory doesn't exist yet; the savefile creation tool will create it for you).

cheers!

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1602

PostPosted: Sat 09 Jun 2012, 07:04    Post subject:  

jamesbond wrote:
Hi,

mavrothal wrote:
Tried alpha2 briefly on a manual frugal install and found no way to get sfs loader to load the devx.
I guess this is answered somewhere in the pervious 14 pages. Would someone point me to it please (and maybe add it to the top or Q&A post).

I can't remember whether it is in System or Setup menu, but there is a "System SFS Loader" that enables you to any sfs that you need. The SFS loader can load SFS from anywhere (by default from /mnt/home) - just choose the folder that contains the SFS, then click "refresh". If you want to load the SFS at every boot, click "load permanently" before loading it.


That's exactly what I was trying to no avail. From terminal, it spits no errors but no SFS loaded ever and PUPSTATE/BOOTCONFIG agrees with that. Confused
BTW I did not see any load button. Just select, click load permanently and "done" is enough?

I do not know if it is relevant but I'm booting with grub4dos and its standard configuration (just editing the menu list as needed).
Also this is running on a VM (Paralles) with all the other puppies. The VM runs 64bit distros (Fedora, Ubuntu) just fine.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9058
Location: Stratford, Ontario

PostPosted: Sat 09 Jun 2012, 07:36    Post subject:  

mavrothal wrote:
Tried alpha2 briefly on a manual frugal install and found no way to get sfs loader to load the devx.

1. Setup > System SFS Loader
2. Click the Folder icon.
3. Browse to the folder containing your SFS. Note that you are selecting the folder, not the actual SFS file.
4. Click the Refresh button.
5. Select your SFS from the list.
6. Click Load.
7. Click Done.

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 15 of 17 [246 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1142s ][ Queries: 13 (0.0078s) ][ GZIP on ]