Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 14:28
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
(request)Focus Writer and/or TextRoom .Pet Please.
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Author Message
Geoffrey


Joined: 30 May 2010
Posts: 1509
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sun 10 Jun 2012, 20:56    Post subject:  

In regard to Focuswriter, I have been unable to get the icons to show in the application, I've downloaded and compiled it myself and still no luck, any ideas?.. the icons are located /usr/share/focuswriter/icons/hicolor.
_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Sun 10 Jun 2012, 22:24    Post subject:  

I decided to try pyroom. It only needs python and some related libraries and is gtk based. However I can't it to run.

Could someone try pyroom and tell me what dependencies it needs and how to get it working?

Homepage: pyroom.org

Pyroom .deb: http://archive.ubuntu.com/ubuntu/pool/universe/p/pyroom/pyroom_0.4.1-2_all.deb
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1509
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Mon 11 Jun 2012, 07:52    Post subject:  

Gnuxo wrote:
I decided to try pyroom. It only needs python and some related libraries and is gtk based. However I can't it to run.

Could someone try pyroom and tell me what dependencies it needs and how to get it working?

Homepage: pyroom.org

Pyroom .deb: http://archive.ubuntu.com/ubuntu/pool/universe/p/pyroom/pyroom_0.4.1-2_all.deb


Here is pyroom for Saluki, I've made a package that will get the dependencies for Saluki, the dependencies being Python, pyxdg and gettext-tools, It appears to work fine, the download site says that it's been tested with Python 2.4, 2.5 and 2.6, Saluki uses Python 2.7, http://murga-linux.com/puppy/viewtopic.php?p=633319#633319

Or you could try AdobeAIR Focused that should work on any version of puppy though AdobeAIR runtime is a little on the large size, Focused has more features than pyroom, Focused here http://www.murga-linux.com/puppy/viewtopic.php?p=627713#627713 get AdobeAIR-2.6-SDK.pet from here http://www.murga-linux.com/puppy/viewtopic.php?p=627376#627376

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Mon 11 Jun 2012, 14:59    Post subject:  

*Sigh* So much to uninstall.

Do you know what would be nice to improve the PPM? When you uninstall a package and it's dependencies are no longer needed, there should an option to automatically remove them.

Similar to Apt-get auto-remove.
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Mon 11 Jun 2012, 15:12    Post subject:  

The link to get adobe-air is broken.

So I can't even try focused.

...Also when I open the pyroom.pet, it doesn't fetch any dependencies.

I'm using Macpup, so that's probably the reason. Do you think that python 2.6 would still work?

Where can I get python 2.7?
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1509
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Mon 11 Jun 2012, 18:08    Post subject:  

Gnuxo wrote:
The link to get adobe-air is broken.

So I can't even try focused.

...Also when I open the pyroom.pet, it doesn't fetch any dependencies.

I'm using Macpup, so that's probably the reason. Do you think that python 2.6 would still work?

Where can I get python 2.7?


Sorry about that, I must of missed it during my house keeping, it's working now.

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1509
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Mon 11 Jun 2012, 19:10    Post subject:  

Gnuxo wrote:
I'm using Macpup, so that's probably the reason. Do you think that python 2.6 would still work?


Gnuxo,

I've had a look a little deeper, seems to run ok without the gettext-tools
Quote:
Please note that gettext is required for a translated PyRoom
so I've repackaged pyroom and pyxdg so that they will be located within python2.6, give these a go they may work with the python 2.6 version you are using now, If that don't work someone will need to package them for Macpup.

good luck Cheers Geoff
PyRoom-0.4.1-2.6.pet
Description 
pet

 Download 
Filename  PyRoom-0.4.1-2.6.pet 
Filesize  81.03 KB 
Downloaded  225 Time(s) 
pyxdg-0.19-2.6.pet
Description 
pet

 Download 
Filename  pyxdg-0.19-2.6.pet 
Filesize  67.56 KB 
Downloaded  225 Time(s) 

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE

Last edited by Geoffrey on Mon 11 Jun 2012, 19:32; edited 1 time in total
Back to top
View user's profile Send private message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Mon 11 Jun 2012, 19:25    Post subject:  

It works!!! Thank you!!!!

I was even able to save a test document without the whole program just freezing!!!
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1509
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Mon 11 Jun 2012, 19:40    Post subject:  

Gnuxo wrote:
It works!!! Thank you!!!!

I was even able to save a test document without the whole program just freezing!!!


Great, I'm glad it worked for you, I just finished making sure it worked also, everything seems fine, that gettext-tools wasn't required, it's only needed for a translated PyRoom.

Cheers Geoff

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0600s ][ Queries: 13 (0.0044s) ][ GZIP on ]