Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 16:03
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
1st try at compiling Hamfax didn't work. Why?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Tue 12 Jun 2012, 09:00    Post_subject:  1st try at compiling Hamfax didn't work. Why?  

hi gang, after years of letting you guys do all the hard work for me, i thought its about time i started doing my own compiling. theres lots of software i want but its all in source. im running 528 with dev and lots of stuff under a remaster copy i did for my ham radio hobby.
im looking for someone to spare a little time and walk me through a few compiles on puppy and hold my hand until i can run.

i got this far on my first attempt at compiling hamfax:
Code:

sh-4.1# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for Qt4... no
configure: error: Package requirements (QtCore QtGui) were not met:

No package 'QtCore' found
No package 'QtGui' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables Qt4_CFLAGS
and Qt4_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

sh


now i tried putting libqtgui.so.4 and libqtcore.so.4 in the source directory and that didnt work. not really sure why i thought it would.

searchmonkey found lots of libqtcores and libqtguis.

so are these even what the ./configure is asking for, and if so, where do i put them?
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2130
Location: Ontario Canada

PostPosted: Tue 12 Jun 2012, 10:02    Post_subject: newbie compiling advice?  

You need Qt installed, Fatslacko has it installed so you just need to add the
devx_slacko_5.3.3x.sfs and you can compile applications that require
qt.
I compiled and made a pet of hamfax-0.8.1.tar.bz2.

./configure --prefix=/usr
make -j4
new2dir make install

the new2dir script makes the pets, some have menu entries (hamfax
doesn't even though it said it did) so you start them from the
terminal.There is also an option during the new2dir script that lets
you create your own hamfax.desktop and that allows you to assign an
icon to it etc.

I can compile the easy stuff, you'll need someone else to help with
more advanced compiling but maybe this will help you a little, you can
go wild compiling qt apps in Fatslacko at least Smile
hamscrn.jpg
 Description   
 Filesize   44.56 KB
 Viewed   995 Time(s)

hamscrn.jpg

Back to top
View user's profile Send_private_message 
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Tue 12 Jun 2012, 11:21    Post_subject:  

i am pretty sure i had qt installed due to the fact i had to sort out libqtgui and libqtcore to run qsstv.

am i missing something big here?

are quicktime and qt libraries different animals? i have libqtcore.so.4 and libqtgui.so.4 littered libraly throughout my filesystem.

im not getting into making pets yet, not until i understand compiing and installing source linux apps direct. i imagine i would otherwise cause others problems if i did so.

so back to the main points; is qt and the qt libs one and the same, or different things?
when i compile other software and it needs dependencies, in what form should i obtain them, and where should i put them so makec and make can find where they are?

hamfax is just a little test for me, although a useful program to have, i used to use it years back when i ran ubuntu Rolling Eyes

the next big thing on the list will be gnuradio, and that i think will be a big challenge. its a behemoth of an app that can make various hardware do stuff its not supposed to. Wink

ultimately i want to build a amateur radio and techie pup that is comprehensive in hardware control and modes. i want it to be 'the last pup you will ever wear' at least for radio freaks.
Back to top
View user's profile Send_private_message 
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Tue 12 Jun 2012, 13:03    Post_subject:  

qt 471 was loaded from the start by the way. via the sfs.
does that make any sense of the situation?
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2130
Location: Ontario Canada

PostPosted: Tue 12 Jun 2012, 13:35    Post_subject:  

drspastic wrote:
qt 471 was loaded from the start by the way. via the sfs.
does that make any sense of the situation?


Sorry, I didn't read your post carefully enough.

If you have qt-471.sfs installed it should allow you to compile qt apps, maybe the qt-471-dev part is missing from the sfs.

playdayz is the man to ask I think.
Back to top
View user's profile Send_private_message 
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Tue 12 Jun 2012, 15:15    Post_subject:  

well just to be sure i added the full devx.sfs even though the puplet i started from already had dev system installed.

where does the standard compiling system look for dependencies?
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2130
Location: Ontario Canada

PostPosted: Tue 12 Jun 2012, 16:51    Post_subject: 1st try at compiling Hamfax didn't work. Why?  

drspastic wrote:
well just to be sure i added the full devx.sfs even though the puplet i started from already had dev system installed.

where does the standard compiling system look for dependencies?


pfind is good for finding libs etc.

Here's what I have installed:

lupu_devx_528-4.sfs
qt-everywhere-opensource-src-4.7.4-lupu-i686.pet
qt-everywhere-opensource-src_DEV-4.7.4-lupu-i686.pet

You need all 3 installed to compile hamfax or any other qt
applications.

I'd make a new save file with the original 528 disk and
use that to practice compiling instead of your remastered 528.

I've uploaded the two qt-474 pets so you can download them, the first
qt pet is large (42mb)

The download link for qt-everywhere-opensource-src-4.7.4-lupu-i686.pet
is:

http://www.datafilehost.com/download-55aadd47.html

The download link for qt-everywhere-opensource-src_DEV-4.7.4-lupu-i686.pet
is:

http://www.datafilehost.com/download-b0c19375.html


I'll attach the hamfax-0.8.1-i686.pet to this message too, this one has a menu entry in the network section of the puppy menu.
hamfax-0.8.1-i686.pet
Description 
pet

 Download 
Filename  hamfax-0.8.1-i686.pet 
Filesize  82.58 KB 
Downloaded  443 Time(s) 
screenshot1.jpg
 Description   
 Filesize   21.41 KB
 Viewed   924 Time(s)

screenshot1.jpg

Back to top
View user's profile Send_private_message 
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Tue 12 Jun 2012, 17:20    Post_subject:  

thanks for that, it seems dependencies are tricky. i will have to learn a lot more.
how is the best way to find what dependancies/libs one might need, and where is the best source to find them?

thanks very much for the pets of qt, im just certain that in future i will need libs that arnt in pet format, so how do i do it from scratch?

would i be better off starting with a blank slate os like DSL?
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2130
Location: Ontario Canada

PostPosted: Tue 12 Jun 2012, 17:25    Post_subject:  

drspastic wrote:

how is the best way to find what dependancies/libs one might need, and where is the best source to find them?


I use google and search for the source code of the needed lib and download and compile that.

packages.ubuntu.com has debs that you can download and install too.
Back to top
View user's profile Send_private_message 
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Tue 12 Jun 2012, 19:12    Post_subject:  

so i will be compiling libs to use to compile libs to compile software? that could get very big.

anyway, thanks to your link to qtdev, i got hamfax compiled. it has a bug, and its not my compile. your compile has the same bug. the program crashes when you attempt to load an image file from disk. so transmit wont work. do you think this is librarys again?
heres the error:
hamfax: symbol lookup error: hamfax: undefined symbol: _ZN9QListData11detach_growEPii

im thinking its an error in the source code but where to start looking?
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2130
Location: Ontario Canada

PostPosted: Tue 12 Jun 2012, 19:36    Post_subject:  

drspastic wrote:
so i will be compiling libs to use to compile libs to compile software? that could get very big.

anyway, thanks to your link to qtdev, i got hamfax compiled. it has a bug, and its not my compile. your compile has the same bug. the program crashes when you attempt to load an image file from disk. so transmit wont work. do you think this is librarys again?
heres the error:
hamfax: symbol lookup error: hamfax: undefined symbol: _ZN9QListData11detach_growEPii

im thinking its an error in the source code but where to start looking?


Chasing libs can be frustrating for sure.

I've loaded png and jpg images in hamfax and don't get an error, maybe google the error and see what comes up.

EDIT:I'm not sure but it might be that I compiled hamfax in qt-474 and you have qt-471 installed, maybe unload your qt-471 sfs and install the two qt-474 pets,or,try starting with a new save file with just the 528 devx + the two qt-474 pets.
screenshot2.png
 Description   
 Filesize   230.39 KB
 Viewed   971 Time(s)

screenshot2.png

Back to top
View user's profile Send_private_message 
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Wed 13 Jun 2012, 02:55    Post_subject:  

yes it looks like i really need so put a clean install on another sd card for compiling practice. thats the best thing with puppy, you can have a different system for each purpose and poke it in the laptop on a card.
im trying to run before i can walk, and a loooong way off from getting gnuradio to work.

a thing im dissapointed with is that there is not full compatability between lib versions, os versions, and binarys. i think sfs is the best way always to work. not sure why.

it reminds me of long gone windows days trying to track down elusive hardware drivers, usually for the network card followed by every part in the box including the power cord. i had to install windoze on my brother in laws pc the other day after changing the graphics card, all standard parts, but jesus! on a distro the size of xp they cant even fit in the most basic hardware support.

so later i will make my compiling system. do you have a list of suggstions for packages i will be needing outside the devx?
i hope someone has put together a master sfs of al the latest qt, libs, dependancies etc. something to just drop in.

another point, why are all these things not in the standard PPM repo?
there is hardly anything interesting there at all, and even enabling the ubuntu stuff gives a pretty limited selection, most of which install broken due to dependancies.
thats the only thing i miss from ubuntu, you click install, it works. you type apt-get, it works. i never once had issue with dependancies that were not automaticly resolved.

i think the official repos and ppm are holding puppy back on a very short leash. there is software out there but its all over the place and mainly not labeled as to what version puppy its good to run on. Evil or Very Mad
Back to top
View user's profile Send_private_message 
drspastic


Joined: 29 Aug 2008
Posts: 90
Location: ruse, bulgaria

PostPosted: Wed 13 Jun 2012, 03:03    Post_subject:  

Billtoo wrote:
drspastic wrote:
so i will be compiling libs to use to compile libs to compile software? that could get very big.

anyway, thanks to your link to qtdev, i got hamfax compiled. it has a bug, and its not my compile. your compile has the same bug. the program crashes when you attempt to load an image file from disk. so transmit wont work. do you think this is librarys again?
heres the error:
hamfax: symbol lookup error: hamfax: undefined symbol: _ZN9QListData11detach_growEPii

im thinking its an error in the source code but where to start looking?


Chasing libs can be frustrating for sure.

by the way,i did install those 2 pets you posted, thanks again. they are what let me compile the app. system says no unmet dependancies.
so my qt must be the same version as yours. Confused
do you think it would help if i go through my system with searchmonkey and manually deleter all the old qt libs?

I've loaded png and jpg images in hamfax and don't get an error, maybe google the error and see what comes up.

EDIT:I'm not sure but it might be that I compiled hamfax in qt-474 and you have qt-471 installed, maybe unload your qt-471 sfs and install the two qt-474 pets,or,try starting with a new save file with just the 528 devx + the two qt-474 pets.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1007s ][ Queries: 13 (0.0100s) ][ GZIP on ]