Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 09:34
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
How to use Fujitsu Siemens Amilo 7440 wireless? (Solved)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
mecmast

Joined: 25 Apr 2012
Posts: 10

PostPosted: Wed 25 Apr 2012, 02:25    Post_subject:  How to use Fujitsu Siemens Amilo 7440 wireless? (Solved)
Sub_title: Unable to compile driver
 

Hi all.

I am using a Fujitsu Siemens Amilo 7440 laptop.

There was a big bug about the wireless button. And here was the solution for Ubuntu:

http://fsam7440.sourceforge.net/index2.html

But in Puppy i couldnt do it. I dunno why? I am new at Puppy and lunix also.

I`ve did everything step by step and here they are:

1. Downloaded the driver. OK
2. When tried to use the command `make` i got this message:


Also there is another problem:

There wasnt a `build` folder in the /modules/2.6.37.6

I had to create an empty `build` folder to compile.

Hope i was able to explain the problem.

Shortly again: my wireless radio on/off button doesnt work. And cannot compile the driver file.

Thanx.
Back to top
View user's profile Send_private_message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11121
Location: Arizona USA

PostPosted: Wed 25 Apr 2012, 08:06    Post_subject:  

What version of Puppy are you using? Newer versions of Puppy may already have the driver you need. Also, Puppy cannot compile without additional software. Have you installed it?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Wed 25 Apr 2012, 10:05    Post_subject:  

It looks like you are using Slacko. Here is a PET for you. However, the source code for this module is not 100% compatible with kernel 2.6.37.6, so I don't know if it will work.

Note the instructions:
Code:
To choose the state of the radio when the module is loaded you
can edit 'radio' parameter.

   modprobe fsam7440 radio=0  (ON)
   modprobe fsam7440 radio=1  (OFF)

Also you can change the state of the card edit /proc/fsam7440/radio
and view the state in this file:

   echo 0 > /proc/fsam7440/radio (Turn OFF)
   echo 1 > /proc/fsam7440/radio (Turn ON)

   cat /proc/fsam7440/radio (View the state)
     0 = OFF       1 = ON


I was confused by whether "0" means ON or OFF.
fsam7440_k2.6.37.6-0.4.pet
Description 
pet

 Download 
Filename  fsam7440_k2.6.37.6-0.4.pet 
Filesize  2.17 KB 
Downloaded  372 Time(s) 
Back to top
View user's profile Send_private_message 
mecmast

Joined: 25 Apr 2012
Posts: 10

PostPosted: Wed 25 Apr 2012, 13:38    Post_subject:  

Very Happy Very Happy

It worked !

Thank you very much rcrsn51.

Now i am online via wireless.

But how should i add it to startup? i mean how to enable wireless radio on by the puppy starts?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Wed 25 Apr 2012, 15:57    Post_subject:  

Add your "modprobe" line to the file /etc/rc.d/rc.local.

Was it "radio=0" or "radio=1"?
Back to top
View user's profile Send_private_message 
mecmast

Joined: 25 Apr 2012
Posts: 10

PostPosted: Wed 25 Apr 2012, 16:01    Post_subject:  

Yep worked too. Cool

I've added as:

Code:
modprobe fsam7440 radio=0
echo 1 > /proc/fsam7440/radio


Thank you again for everything. I've spent 6 hours yesterday to solve it. lol Laughing With your help it's been solved.

Btw, how did you created the "pet" file? Is there a document for this how to do?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Wed 25 Apr 2012, 16:03    Post_subject:  

mecmast wrote:
Btw, how did you created the "pet" file? Is there a document for this how to do?

Read here.
Back to top
View user's profile Send_private_message 
mecmast

Joined: 25 Apr 2012
Posts: 10

PostPosted: Wed 25 Apr 2012, 16:07    Post_subject:  

Very nice. Ty. Smile
Back to top
View user's profile Send_private_message 
josete600

Joined: 11 Jun 2012
Posts: 1

PostPosted: Mon 11 Jun 2012, 14:56    Post_subject: How you did it?  

Sorry, I have the same problem but i dont know how you did for wireless working. Can you tell me briefly how you did it?

I have installed the pet archive but when i try do:
Code:
 modprobe fsam7400 radio=0
in console, i have a error: FATAL: Module fsam7400 not found.
My puppy linux version is: Lucid version 5.2.8

Thanks Very Happy
Back to top
View user's profile Send_private_message 
mecmast

Joined: 25 Apr 2012
Posts: 10

PostPosted: Mon 11 Jun 2012, 15:07    Post_subject:  

i had changed the main sfs file to an older version. Nothing else than you did. I couldnt remember the version now. Because i've formatted my usb drive Sad
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5271
Location: Australia

PostPosted: Thu 14 Jun 2012, 09:00    Post_subject:  

josete600 has Puppy Lucid 5.2.8.
rcrsn51 compiled the fsam7440 driver for Slacko, because that's the version of Puppy that the original poster has.

Puppy Lucid and Puppy Slacko have different kernels; 2.6.33.2 versus 2.6.37.6. Thus rcrsn51's driver is incompatible with Puppy Lucid.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Thu 14 Jun 2012, 11:28    Post_subject:  

@josete600: Here is the same package, but built for Lupu.
fsam7440_k2.6.33.2-0.4.pet
Description 
pet

 Download 
Filename  fsam7440_k2.6.33.2-0.4.pet 
Filesize  2 KB 
Downloaded  294 Time(s) 
Back to top
View user's profile Send_private_message 
mecmast

Joined: 25 Apr 2012
Posts: 10

PostPosted: Thu 14 Jun 2012, 12:06    Post_subject:  

Yesterday i've tried the old pet "rcrsn51" has created on puppy 5.3.3 but it didn't work. If i download the new pet file, will it work on 5.3.3?

Thanx.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Thu 14 Jun 2012, 12:39    Post_subject:  

By 5.3.3, do you mean Slacko? The original PET was built for Slacko. So if it doesn't work any more, something has changed with your hardware.

The new version is ONLY for Lupu. It definitely will NOT work in Slacko.
Back to top
View user's profile Send_private_message 
mecmast

Joined: 25 Apr 2012
Posts: 10

PostPosted: Thu 14 Jun 2012, 13:32    Post_subject:  

Yes it's slacko. Nothing's changed about my computer. After failing with 5.3.3 i've installed 5.3.1 back again. The file worked. I guess something's changed about the 5.3.3.

After installing fsam7440. i've entered the code modprobe. and it has given a message saying cannot find fsam7440.

weird. Confused
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0691s ][ Queries: 13 (0.0040s) ][ GZIP on ]