Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 03 Sep 2014, 03:54
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
BINO 3d movie player
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Author Message
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Sun 04 Mar 2012, 01:06    Post subject:  BINO 3d movie player  

Hi,

at this time i'm trying to compile BINO : http://bino3d.org/index.html
Quote:

About Bino

Bino is a video player with the following main features:

Support for stereoscopic 3D video, with a wide variety of input and output formats.
Support for multi-display video, e.g. for powerwalls, Virtual Reality installations and other multi-projector setups.

Bino currently works on GNU/Linux, FreeBSD, Mac OS X, and Windows. It uses the following libraries:

FFmpeg to decode video and audio files. FFmpeg version 0.7 or later is required.
LibASS to render subtitles.
OpenAL (on GNU/Linux: OpenAL Soft) for audio output.
OpenGL (with Glew) for video output. Hardware accelerated OpenGL 2.1 with framebuffer objects is required.
Note that proprietary drivers are not required! Recent Linux kernel + Mesa + X.org versions should work fine.
Qt for the user interface and video window.
Optionally Equalizer for multi-display support.

Bino is free software, licensed under the terms of the GNU GPL version 3 or later.


but i have difficulty finding qt4 for puppy, and the only version i found did ./compile bino,but fail when i run "make" bino.

i already download and compiling qt4 myself which takes many hours now...

I wonder if anyone has clue ?

PS: i also compile ffmpeg 7.11 and it show alot of "deprecated" warning sign... should i worry ???

PS2: Lucid 528

thank you

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
Adagio

Joined: 06 May 2011
Posts: 126
Location: TerraAustralis

PostPosted: Sun 04 Mar 2012, 01:36    Post subject:  

There is a Qt4 .sfs posted not long back.
Version 4.8.4 I think.
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Sun 04 Mar 2012, 02:47    Post subject:  

Hi,


I'll try and post the result here.
RESULT :::
installed :

ffmpeg_runall_DEV-0.7.2-p4.pet ( http://182.164.209.214/puppy/pup4/opt/pets/ )
libass_0.10.0.orig.tar.gz
libglew1.5-dev_1.5.2-0ubuntu1_i386.deb
qt4
from:
http://www.smokey01.com/ttuuxxx/2.14X/iso-sfs/qt-everywhere-opensource-src-4.6.3-i386.pet

it was compiled correctly but then when I make :
Quote:

make[4]: Entering directory `/root/bino-1.2.1/src'
CXXLD bino
media_object.o: In function `media_object::set_subtitle_box_template(int)':
/root/bino-1.2.1/src/media_object.cpp:702: undefined reference to `av_dict_get'
media_object.o: In function `media_object::set_audio_blob_template(int)':
/root/bino-1.2.1/src/media_object.cpp:652: undefined reference to `av_dict_get'
/root/bino-1.2.1/src/media_object.cpp:692: undefined reference to `av_get_sample_fmt_name'
media_object.o: In function `media_object::set_video_frame_template(int, int, int)':
/root/bino-1.2.1/src/media_object.cpp:580: undefined reference to `av_dict_get'
media_object.o: In function `subtitle_decode_thread::run()':
/root/bino-1.2.1/src/media_object.cpp:1707: undefined reference to `avsubtitle_free'
media_object.o: In function `media_object::open(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, device_request const&)':
/root/bino-1.2.1/src/media_object.cpp:762: undefined reference to `avformat_open_input'
/root/bino-1.2.1/src/media_object.cpp:768: undefined reference to `av_dict_free'
/root/bino-1.2.1/src/media_object.cpp:779: undefined reference to `av_dump_format'
/root/bino-1.2.1/src/media_object.cpp:783: undefined reference to `av_dict_get'
/root/bino-1.2.1/src/media_object.cpp:764: undefined reference to `av_dict_free'
/root/bino-1.2.1/src/media_object.cpp:757: undefined reference to `av_dict_set'
/root/bino-1.2.1/src/media_object.cpp:752: undefined reference to `av_dict_set'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtOpenGL.a(qgl_x11.o): In function `QGLContext::tryVisual(QGLFormat const&, int)':
qgl_x11.cpp:(.text+0x2902): undefined reference to `XRenderFindVisualFormat'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `sm_setProperty(char const*, char const*, int, SmPropValue*)':
qapplication_x11.cpp:(.text+0x214b): undefined reference to `SmcSetProperties'
qapplication_x11.cpp:(.text+0x2172): undefined reference to `SmcDeleteProperties'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSmSocketReceiver::socketActivated(int)':
qapplication_x11.cpp:(.text+0x242f): undefined reference to `SmcGetIceConnection'
qapplication_x11.cpp:(.text+0x2437): undefined reference to `IceProcessMessages'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::~QSessionManager()':
qapplication_x11.cpp:(.text+0x25c7): undefined reference to `SmcCloseConnection'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::~QSessionManager()':
qapplication_x11.cpp:(.text+0x2667): undefined reference to `SmcCloseConnection'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::~QSessionManager()':
qapplication_x11.cpp:(.text+0x2707): undefined reference to `SmcCloseConnection'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::release()':
qapplication_x11.cpp:(.text+0x277d): undefined reference to `SmcInteractDone'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::allowsErrorInteraction()':
qapplication_x11.cpp:(.text+0x291a): undefined reference to `SmcInteractRequest'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::allowsInteraction()':
qapplication_x11.cpp:(.text+0x2a1a): undefined reference to `SmcInteractRequest'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::QSessionManager(QApplication*, QString&, QString&)':
qapplication_x11.cpp:(.text+0x4175): undefined reference to `SmcOpenConnection'
qapplication_x11.cpp:(.text+0x42b9): undefined reference to `SmcGetIceConnection'
qapplication_x11.cpp:(.text+0x42c1): undefined reference to `IceConnectionNumber'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `QSessionManager::QSessionManager(QApplication*, QString&, QString&)':
qapplication_x11.cpp:(.text+0x4625): undefined reference to `SmcOpenConnection'
qapplication_x11.cpp:(.text+0x4769): undefined reference to `SmcGetIceConnection'
qapplication_x11.cpp:(.text+0x4771): undefined reference to `IceConnectionNumber'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `.L7303':
qapplication_x11.cpp:(.text+0xde59): undefined reference to `XRenderQuerySubpixelOrder'
qapplication_x11.cpp:(.text+0xe017): undefined reference to `XRenderQueryExtension'
qapplication_x11.cpp:(.text+0xe958): undefined reference to `XRenderQueryVersion'
qapplication_x11.cpp:(.text+0xf5d9): undefined reference to `XRenderFindVisualFormat'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `qt_cleanup()':
qapplication_x11.cpp:(.text+0x10a2f): undefined reference to `XRenderFreePicture'
qapplication_x11.cpp:(.text+0x10a7e): undefined reference to `XRenderFreePicture'
/usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtGui.a(qapplication_x11.o): In function `sm_performSaveYourself(QSessionManagerPrivate*)':
qapplication_x11.cpp:(.text+0x15743): undefined reference to `SmcInteractDone'
qapplication_x11.cpp:(.text+0x1586f): undefined reference to `SmcSaveYourselfDone'
qapplication_x11.cpp:(.text+0x15d40): undefined reference to `SmcRequestSaveYourselfPhase2'



_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199

Last edited by Master_wrong on Mon 05 Mar 2012, 09:11; edited 1 time in total
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2445
Location: near here

PostPosted: Mon 05 Mar 2012, 06:25    Post subject:  

Can you give the output from .configure too? Arrow
_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Tue 06 Mar 2012, 00:19    Post subject:  

@darkcity

yes surely...
bino-error.zip
Description 
zip

 Download 
Filename  bino-error.zip 
Filesize  6.37 KB 
Downloaded  310 Time(s) 

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Thu 08 Mar 2012, 04:33    Post subject:  

@second attempt
ffmpeg_runall-0.7.2-p4.pet
ffmpeg_runall_DEV-0.7.2-p4.pet ( http://182.164.209.214/puppy/pup4/opt/pets/ )
libass_0.10.0.orig.tar.gz
libglew1.5-dev_1.5.2-0ubuntu1_i386.deb

qt4
http://www.smokey01.com/ttuuxxx/2.14X/iso-sfs/qt-everywhere-opensource-src-4.6.3-i386.pet

BINO
http://www.murga-linux.com/puppy/viewtopic.php?p=610213#610213

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 13 Jun 2012, 15:55    Post subject:  

To run Bino on Fluppy 013 (based on Puppy 4.3.1):

I use the ATI Catalyst Graficscard driver, that supports OpenGL 2.1.
Somewhere I have read, that Bino requires OpenGL 2.1. Several of the free Xorg graficsdrivers support only OpenGL 1.x, atleast that was the case 2 or 3 years ago. So ATI or Nvidia drivers were the only way to get OpenGL 2.x. Maybe this still is valid.

Bino: pets from:
http://www.murga-linux.com/puppy/viewtopic.php?t=68796&search_id=1639412035&start=450

QT4:
http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt-4.8.0-webkit-phonon-gstreamer-opengl-dpup.pet

If you do not have /usr/lib/libavformat.so.53, then also:
ffmpeg_runall-0.7.2-p4.pet
from: http://shino.pos.to/party/bridge.cgi?puppy/pup4/opt/pets/

And I needed the 3 pets I attach, too.

If you run "bino" in console, and there still miss libs, let me know. I use this savefile since a long time now, and might have other requirements installed in the past.

Here is the full dependency list:

Code:
# ldd /usr/bin/bino
   linux-gate.so.1 =>  (0xffffe000)
   libavformat.so.53 => /usr/lib/libavformat.so.53 (0xb7666000)
   libavcodec.so.53 => /usr/lib/libavcodec.so.53 (0xb6d58000)
   libavutil.so.51 => /usr/lib/libavutil.so.51 (0xb6d46000)
   libavdevice.so.53 => /usr/lib/libavdevice.so.53 (0xb6d3d000)
   libswscale.so.2 => /usr/lib/libswscale.so.2 (0xb6d1f000)
   libass.so.4 => /usr/lib/libass.so.4 (0xb6d04000)
   libopenal.so.1 => /usr/lib/libopenal.so.1 (0xb69c3000)
   libGL.so.1 => /usr/lib/libGL.so.1 (0xb68e5000)
   libQtOpenGL.so.4 => /opt/qt4/lib/libQtOpenGL.so.4 (0xb67e2000)
   libQtGui.so.4 => /opt/qt4/lib/libQtGui.so.4 (0xb5cee000)
   libQtCore.so.4 => /opt/qt4/lib/libQtCore.so.4 (0xb5a0b000)
   libX11.so.6 => /usr/X11R7/lib/libX11.so.6 (0xb590d000)
   librt.so.1 => /lib/librt.so.1 (0xb5905000)
   libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb581e000)
   libm.so.6 => /lib/libm.so.6 (0xb57f6000)
   libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb57eb000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb57d4000)
   libc.so.6 => /lib/libc.so.6 (0xb5693000)
   libz.so.1 => /lib/libz.so.1 (0xb5684000)
   libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0xb5678000)
   libx264.so.118 => /usr/lib/libx264.so.118 (0xb5552000)
   libvpx.so.0 => /usr/lib/libvpx.so.0 (0xb54b7000)
   libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0xb533f000)
   libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb5316000)
   libtheoraenc.so.1 => /usr/lib/libtheoraenc.so.1 (0xb52d2000)
   libtheoradec.so.1 => /usr/lib/libtheoradec.so.1 (0xb52b9000)
   libspeex.so.1 => /usr/lib/libspeex.so.1 (0xb52a5000)
   libopencore-amrwb.so.0 => /usr/lib/libopencore-amrwb.so.0 (0xb5290000)
   libopencore-amrnb.so.0 => /usr/lib/libopencore-amrnb.so.0 (0xb5263000)
   libmp3lame.so.0 => /usr/lib/libmp3lame.so.0 (0xb51e8000)
   libfaac.so.0 => /usr/lib/libfaac.so.0 (0xb51d7000)
   libasound.so.2 => /usr/lib/libasound.so.2 (0xb5142000)
   libdc1394.so.22 => /usr/lib/libdc1394.so.22 (0xb50d2000)
   libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb505c000)
   libfribidi.so.0 => /usr/lib/libfribidi.so.0 (0xb5046000)
   libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb5018000)
   libdl.so.2 => /lib/libdl.so.2 (0xb5014000)
   libXext.so.6 => /usr/X11R7/lib/libXext.so.6 (0xb5007000)
   libatiuki.so.1 => /usr/lib/libatiuki.so.1 (0xb4ffe000)
   libXrender.so.1 => /usr/X11R7/lib/libXrender.so.1 (0xb4ff6000)
   libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb4ff2000)
   libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb4f27000)
   libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb4f04000)
   libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb4ed1000)
   libSM.so.6 => /usr/X11R7/lib/libSM.so.6 (0xb4eca000)
   libICE.so.6 => /usr/X11R7/lib/libICE.so.6 (0xb4eb6000)
   /lib/ld-linux.so.2 (0xb7715000)
   libxcb.so.1 => /usr/X11R7/lib/libxcb.so.1 (0xb4ea1000)
   libogg.so.0 => /usr/lib/libogg.so.0 (0xb4e9c000)
   libraw1394.so.11 => /usr/lib/libraw1394.so.11 (0xb4e8e000)
   libusb-1.0.so.0 => /usr/lib/libusb-1.0.so.0 (0xb4e83000)
   libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb4e67000)
   libXau.so.6 => /usr/X11R7/lib/libXau.so.6 (0xb4e64000)
   libuuid.so.1 => /lib/libuuid.so.1 (0xb4e5f000)


The nice thing about Bino is, that it can play 2 videos simultaneously, and offers a big variety of how to display them (side by side, top/bottom, anaglyph).
It also supports webcams, but can only play the content of 1 cam, not 2 like with the videos.

http://bino3d.org/

Mark
libass-0.10.0-i486.pet
Description  compiled on my system
pet

 Download 
Filename  libass-0.10.0-i486.pet 
Filesize  256.46 KB 
Downloaded  254 Time(s) 
fribidi-0.19.2-i486.pet
Description  compiled on my system
pet

 Download 
Filename  fribidi-0.19.2-i486.pet 
Filesize  112.34 KB 
Downloaded  247 Time(s) 
libopenal.so.1-for-blender-2.pet
Description  found this lib as tar.gz in a blender thread here in the forum, corrected a symlink and repackaged it as pet.
pet

 Download 
Filename  libopenal.so.1-for-blender-2.pet 
Filesize  64.45 KB 
Downloaded  257 Time(s) 

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Makoto


Joined: 03 Sep 2009
Posts: 1793
Location: Out wandering... maybe.

PostPosted: Wed 13 Jun 2012, 19:34    Post subject:  

MU wrote:
To run Bino on Fluppy 013 (based on Puppy 4.3.1):

......

QT4:
http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt-4.8.0-webkit-phonon-gstreamer-opengl-dpup.pet


Side question - does this mean Qt 4.8.0 can run on Puppy 4.3.1? And, that the above .pet would work on my 4.3.1 setup? I've been thinking about compiling Qt programs for a while, although I was told a while back that Qt versions above 4.5 might not work with the Puppy 4.3.1 kernel.

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 14 Jun 2012, 00:23    Post subject:  

Makoto, I think Fluppy 013 uses a newer Kernel and Xorg than Puppy 4.3.1, so there is no guarantee.
But simply try it, almost all files go to /opt/qt4/, so the pet is easily uninstalled, if it will not work.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 14 Jun 2012, 01:27    Post subject:  

Thanks for getting those compiles in good use. I also learnt what I was missing. It was Ati proprietary driver what I would have needed to get the test files to play.
Thank you for information.
I might at some stage rebuild the bino package with instructions in pinstall.sh.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 14 Jun 2012, 01:40    Post subject:  

Fluppy uses 2.6.35.7 kernel compiled by jemimah, optimized for intel atom processor.
The packages and libs infrastructure was highly updated and the 4.3.1 build is not true with Fluppy. Jemimah manually updated and improved far beyound 4.3.1.
Fluppy is/was the build of its own.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1793
Location: Out wandering... maybe.

PostPosted: Thu 14 Jun 2012, 03:31    Post subject:  

Just to be absolutely sure, is there a way I can test to see if this version of Qt is actually working on my system, or not, such as a console command? All of the programs I've tried so far (and yes, I downloaded your compile of qcomicbook again, pemasu Very Happy) are (of course) compiled for later version of Puppy, so they all complain about the glib version. Neutral

I do have a version of qtconfig around, but that version appears to be static-compiled against Qt 4.6.3 (one of Dingo's releases, I think.)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1362
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Thu 14 Jun 2012, 06:50    Post subject:  

Makoto wrote:
Just to be absolutely sure, is there a way I can test to see if this version of Qt is actually working on my system, or not, such as a console command? All of the programs I've tried so far (and yes, I downloaded your compile of qcomicbook again, pemasu Very Happy) are (of course) compiled for later version of Puppy, so they all complain about the glib version. Neutral

I do have a version of qtconfig around, but that version appears to be static-compiled against Qt 4.6.3 (one of Dingo's releases, I think.)


Here are a few small qt apps I compiled with qt-4.8.0 for Saluki, they might work to test things http://murga-linux.com/puppy/viewtopic.php?p=626985#626985

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1793
Location: Out wandering... maybe.

PostPosted: Thu 14 Jun 2012, 16:31    Post subject:  

Thanks. I did a little digging, though, and found the qtconfig binary included with the above package. So, yeah, it complains about not finding the glib version it's expecting, too.

I know that ideally, probably the best way for me to be sure would be to grab Qt 4.8 and attempt to compile it. But then, I'd likely have to expand my pupsave another two gigabytes, and I'm not confident about downloading the whole ~800MB package. Mr. Green

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 14 Jun 2012, 18:54    Post subject:  

I had the glibc error with the new skype 4 in Fluppy013 with the qt4 pet I mentioned above (though qtconfig worked):

Code:
./skype
./skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./skype)


So I chose this method to run it:
downloaded:
http://ftp.de.debian.org/debian/pool/main/g/gcc-4.4/libstdc++6_4.4.5-8_i386.deb

saved it to /root/glibc3411/ and extracted it with undeb.

Then wrote this script /usr/bin/skype4 to start skype:

Code:
#!/bin/bash

export LD_LIBRARY_PATH=/root/glibc3411/usr/lib/:$LD_LIBRARY_PATH

skype


Now skype starts fine.

Maybe this methood works for you, too.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [16 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1172s ][ Queries: 13 (0.0046s) ][ GZIP on ]