Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Sep 2014, 11:44
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Amarok won't work in Lucid?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
gerryggg


Joined: 11 Jan 2009
Posts: 36
Location: Florida, USA

PostPosted: Tue 26 Jun 2012, 13:36    Post subject:  Sound on USB boot of HP Pavillion - Solved!  

I have a 64GB flash drive that I have installed Puppy on to try to use with Amarok as a music player. After Installing Lucid and the Amarok SFS, I found I had no sound when booting it off my laptop. It worked fine off my Acer desktop and a Dell at work, but I couldn't get the sound to work on the laptop. I upgraded the Puppy installation to Slacko 5.3.3, but still no sound. I cured the wireless problem by installing r8192ce_pci-k2.6.33.2.pet. I was finally able to cure the sound problem by running the multiple sound card wizard to switch from the default HDMI card setting to the speaker. Unfortunately although it seemed to be configured right, no sound came out of the speaker. After scouring posts on here for days, I finally stumbled across the answer. In the ALSA mixer, <MM> means the sound is muted and you have to hit "M" to unmute it! While that might be old hat to many Puppy users, as one who primarily works in Kubuntu and has mainly used Puppy on older machines as a music player, it was a mystery. I can't find the actual post where I saw that, but, mysterious benefactor, whoever you are, many thanks. Thanks too, for all the help that all you long time "puppyphiles" dispense. Now, if I can just find a way to get Amarok to work with Slacko I'll be happy. The Lucid SFS file won't work. If I can't find an updated SFS I may have another crack at getting the sound to work with Lucid.
Back to top
View user's profile Send private message 
gerryggg


Joined: 11 Jan 2009
Posts: 36
Location: Florida, USA

PostPosted: Fri 29 Jun 2012, 06:58    Post subject: Re: Sound on USB boot of HP Pavillion - Solved!  

gerryggg wrote:
If I can't find an updated SFS I may have another crack at getting the sound to work with Lucid.


Long and short - couldn't get Amarok to work in Slacko. Re-installed Lucid. Now have sound and so far seems to be working.
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2452
Location: near here

PostPosted: Sat 30 Jun 2012, 04:40    Post subject:  

where did you get the Lucid Amarok sfs from?

my guess is that it won't run is slacko due to missing some library.

it can be instructive to run a program from the terminal - as it will output any errors rather than just not running. Cool

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
gerryggg


Joined: 11 Jan 2009
Posts: 36
Location: Florida, USA

PostPosted: Sun 01 Jul 2012, 08:44    Post subject:  

darkcity wrote:
where did you get the Lucid Amarok sfs from?

my guess is that it won't run is slacko due to missing some library.

it can be instructive to run a program from the terminal - as it will output any errors rather than just not running. Cool


I downloaded it from here quite some time ago as I have it running on an old Dell someone gave me that I use as a jukebox. I'll have to try setting up another flash drive with Slacko and see if I can get more info. I have a 16gb drive with nothing on it I can use.
Back to top
View user's profile Send private message 
gerryggg


Joined: 11 Jan 2009
Posts: 36
Location: Florida, USA

PostPosted: Sun 01 Jul 2012, 23:42    Post subject:  

gerryggg wrote:
darkcity wrote:
where did you get the Lucid Amarok sfs from?

my guess is that it won't run is slacko due to missing some library.

it can be instructive to run a program from the terminal - as it will output any errors rather than just not running. Cool


I downloaded it from here quite some time ago as I have it running on an old Dell someone gave me that I use as a jukebox. I'll have to try setting up another flash drive with Slacko and see if I can get more info. I have a 16gb drive with nothing on it I can use.


So I installed Slacko on the 16gb flash drive, Installed SFSinstall.pet, installed and loaded the amarok SFS file, and, as you suggested, ran amarok in a terminal window. I got the following error message:

Amarok: [Loader] Starting amarokapp...
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarokapp: error while loading shared libraries: libpcreposix.so.3: cannot open shared object file: NO such file or directory

I found the missing library, but it seemed no matter where I put them it wouldn't work. Then I discovered that someone had made a pet of the missing library. I installed it and amarok loads and runs fine! I went back and it seems the links to the SFS file for Lucid are broken. If someone needs it I can upload it here. I now have amarok working fine on two flash drives, one with Slacko and one with Lucid and a full install on an old Dell running Lucid.
libpcre3_7.6-2.1_i386.pet
Description  install this to get Amarok 1.4 working in Slacko after installing the Lucid SFS file.
pet

 Download 
Filename  libpcre3_7.6-2.1_i386.pet 
Filesize  90.7 KB 
Downloaded  301 Time(s) 
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0554s ][ Queries: 13 (0.0043s) ][ GZIP on ]