Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 03:29
All times are UTC - 4
 Forum index » Taking the Puppy out for a walk » Suggestions
The State of Package Management
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 15 of 15 Posts_count   Goto page: Previous 1, 2, 3, ..., 13, 14, 15

Should Puppy's package format be changed?
Yes, without backwards compatibility.
28%
 28%  [ 11 ]
Yes, with backwards compatibility.
25%
 25%  [ 10 ]
No, but the PET format should be standardized/stricter.
20%
 20%  [ 8 ]
No, the PET format works fine.
25%
 25%  [ 10 ]
Total_votes : 39

Author Message
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Wed 25 Apr 2012, 15:41    Post_subject:  

Vector linux?...maybe my comment on 18th sparked that...?

http://murga-linux.com/puppy/viewtopic.php?p=620978#620978

Aitch Smile
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2596
Location: New Zealand

PostPosted: Wed 25 Apr 2012, 16:06    Post_subject:  

Aitch wrote:
Vector linux?...maybe my comment on 18th sparked that...?

Actually I was picking up on this:
http://murga-linux.com/puppy/viewtopic.php?t=290&start=32
Maybe micko was picking up on this:
http://murga-linux.com/puppy/viewtopic.php?t=290&start=28
So maybe all that came from your comment?

Hows that for a dev/loop?? Smile
Back to top
View user's profile Send_private_message 
Aitch


Joined: 04 Apr 2007
Posts: 6825
Location: Chatham, Kent, UK

PostPosted: Thu 26 Apr 2012, 05:23    Post_subject:  

I think I was hinting that Barry used to use Vector Dev Tools,'back in the days'....? Wink

That's a real devloop Very Happy

Aitch Smile
Back to top
View user's profile Send_private_message 
DocSalvage


Joined: 30 Jun 2012
Posts: 10
Location: Tallahassee, FL, USA

PostPosted: Thu 05 Jul 2012, 11:02    Post_subject:  

Am a programmer of 30 years and 30 some languages but new here and new to Puppy so I'll briefly throw in my 1 cent worth...

I've just spent an hour trying to find PupGet and Puppy Basic so I can install unrpm.undeb.pup so I can extract Synergy 1.3.1 .rpm to install it on on Puppy 5.2.2. From this thread, I now see this has probably been folly due to fully understandable incompatibilities. We can't make software better without breaking a few old versions.

However, I wish the current Package Manager included perhaps a link from the main screen to a help page explaining step-by-step what a newbie might do (like finding the source and recompiling) in this situation.

From this thread, it appears that the package manager definitely needs to be more robust. That probably means a rewrite that can't be backward compatible. However, to remain inviting to newcomers, it really needs to guide users to a solution, if there is one, for using software that only exists via what will be 2 obsolete package managers or source. A builtin launcher for Xarchive, make, configure, etc. for those source compiles would be very helpful too.

Puppy Linux is the best *nx I've ever used!

Kudus to Barry and all that keep making it better!

As I continue to convert 6 systems to Puppy, I look forward to many happy [Return]s.
Back to top
View user's profile Send_private_message Visit_website 
noryb009

Joined: 20 Mar 2010
Posts: 540

PostPosted: Thu 05 Jul 2012, 18:40    Post_subject:  

Thank you, DocSalvage. You pretty much summarized why the PPM should be remade: if a programmer of 30 years can't install a program within a few minutes (let alone an hour), how can we expect regular users to do so?

Puppy claims to be user friendly, yet programmers can't even install things.

Quote:
From this thread, I now see this has probably been folly due to fully understandable incompatibilities. We can't make software better without breaking a few old versions.

It's not understandable incompatibilities. Pretty much every other linux distro has a better package manager then Puppy, and you can easily install programs on them.

Puppy is a great distro, but it's package management is it's weakness.
Back to top
View user's profile Send_private_message 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Thu 05 Jul 2012, 19:52    Post_subject:  

DocSalvage wrote:
Am a programmer of 30 years and 30 some languages but new here and new to Puppy so I'll briefly throw in my 1 cent worth...

I've just spent an hour trying to find PupGet and Puppy Basic so I can install unrpm.undeb.pup so I can extract Synergy 1.3.1 .rpm to install it on on Puppy 5.2.2.


unrpm:
Code:

#!/bin/sh
exec rpm2cpio "$@" | cpio -i -d
Back to top
View user's profile Send_private_message 
DocSalvage


Joined: 30 Jun 2012
Posts: 10
Location: Tallahassee, FL, USA

PostPosted: Fri 06 Jul 2012, 00:33    Post_subject:  

unrpm:
Code:

#!/bin/sh
exec rpm2cpio "$@" | cpio -i -d
[/quote]


Thanks for the code jpeps!
Back to top
View user's profile Send_private_message Visit_website 
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Fri 06 Jul 2012, 02:19    Post_subject:  

DocSalvage wrote:
unrpm:
Code:

#!/bin/sh
exec rpm2cpio "$@" | cpio -i -d



Thanks for the code jpeps!


welcome to puppy linux Smile
Back to top
View user's profile Send_private_message 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Fri 06 Jul 2012, 09:37    Post_subject:  

Thank you for agreeing with me.

I never found the interface in PPM very intuitive.

...And some daily operations in it are tedious.

I'm no programmer but even I can tell that it's missing a few usable features.

One interesting Idea would be to merge PPM and Quickpet/Slickpet into one user friendly interface. I know the PPM is puppy's answer to Synaptic and Quickpet is puppy's software center, treat caterer.

However I'd like to see Quickpet have more applications to view and maybe search Quickpet for applications...

I know it can be done and still keep a small footprint because I trust the ability of the Puppy devs.
Back to top
View user's profile Send_private_message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 839
Location: USA

PostPosted: Tue 10 Jul 2012, 20:33    Post_subject:  

I think the PPM is fine the way it is.
_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
(Slacko) Puppy Arcade 11 on USB Stick
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Wed 11 Jul 2012, 01:58    Post_subject:  

bark_bark_bark wrote:
I think the PPM is fine the way it is.

So you like the package manager, but do you think there should be an improvement in the package repository, or are you happy with the forum being the de facto repository?

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 839
Location: USA

PostPosted: Wed 11 Jul 2012, 07:38    Post_subject:  

well maybe there should be on going updates for packages in the OFFICIAL repos, while the packages here get signed (by the devs) and added to the repo.
_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
(Slacko) Puppy Arcade 11 on USB Stick
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 15 of 15 Posts_count   Goto page: Previous 1, 2, 3, ..., 13, 14, 15
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Taking the Puppy out for a walk » Suggestions
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0983s ][ Queries: 15 (0.0268s) ][ GZIP on ]