Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 22:25
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
get iplayer 2.8.3 UPDATE 10
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 5 [70 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Tue 27 Mar 2012, 11:59    Post subject:  

updated... now working on slacko Smile
_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Thu 29 Mar 2012, 07:01    Post subject:  

@ 666philb

Occasionally I get errors when I try to download radio streams and it would complain about 'rtmpdump'.

Anyway, I have compiled the latest builds of 'rtmpdump' and 'flvstreamer' for use with this application.

I still get error messages with 'rtmpdump' but at least this time it continues and finishes the conversion process.

I have attached the binaries for you if you want to test them out. Not sure if Slacko has these updated, but I'm using Lucid 528-004.

Here's my logfile just to show it works:

http://pastebin.com/6dNu0Fiv
updated-files.tar.gz
Description  flvstreamer-2.1c1 and rtmpdump-2.3
gz

 Download 
Filename  updated-files.tar.gz 
Filesize  273.97 KB 
Downloaded  345 Time(s) 
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Fri 30 Mar 2012, 15:19    Post subject:  

hi chrome307

i gave your package a go and i get this error when trying to download tv........


_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Tue 03 Apr 2012, 07:49    Post subject:  

@ 666philb ... thanks for the update Smile

I'm using Lucid 528-004 as my OS.

When I use the application, get_iplayer reports that I was using Flvstreamer v1.9.

I updated flvstreamer to v2.1 and at the same time I compiled RTMPdump 2.3 as I occasionally got errors when downloading and failing to encode the file,; usually podcasts or live radio.

In your screenshot, you seem to have an older version of flvstreamer ie v1.8

Also in all builds so far, swf verfication has not been built into the binaries.

It's strange, as I have just grabbed some stuff today with the updated files and it seems to work for me.



Here's the updated files working on mine ....... as you see I have an error whilst downloading ....... this would usually mean that I end up with a file that cannot be converted from *.flv to another format.



and here it shows, that even though I had the error, it has allowed me to convert the file to *.mp4a.

Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Tue 03 Apr 2012, 08:59    Post subject:  

hi chrome307

i just tried again with the latest flvstreamer and rtmpdump, and instead of putting rtmpdump in its default usr/local... i put everything in /usr/ and it seems to be working Smile

anyway.... i've uploaded the newer version

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Tue 03 Apr 2012, 09:48    Post subject:  

Thanks again for maintaining this app ...... what would be super if the tv guide could have incorporated into this somehow lol .... well I can always dream Smile

btw ... in the zipped up attached I think I put all the files in their corresponding directories, so they just need to be unzipped and placed in the same location ..... better still you've updated the app !!!
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 195
Location: Scotland

PostPosted: Tue 10 Jul 2012, 16:10    Post subject:  

Hello All

I am now unable to get any of the live TV channels to work except the BBC Parliament and even this locks up and stops. This is the case for both vlc and mplayer. The stuff on the TV cache seems to work. Is this the same for every body?

Regards,

Ken.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Sat 14 Jul 2012, 14:39    Post subject:  

hi keniv, yes i'm finding that is happening as well
_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
keniv

Joined: 06 Oct 2009
Posts: 195
Location: Scotland

PostPosted: Sat 14 Jul 2012, 16:25    Post subject:  

Hi 666philb

Thanks for the information. At least I know it is not a problem with my machine. Do you know if this is caused by a change made by the BBC. Seems a bit odd that only live TV seems to be affected. Is it fixable?

Regards,

Ken.
Back to top
View user's profile Send private message 
simes

Joined: 29 Sep 2007
Posts: 38
Location: Cheshire, UK

PostPosted: Sun 05 Aug 2012, 12:38    Post subject: www.infradead.org  

Hi everyone,
I was very pleased to discover get-iplayer today and installed it with great enthusiasm on my lupu528 system. But when I start the program it tries to connect to www.infradead.org to obtain plugins and updates. That site no longer exists and get-iplayer times out. is there a workaround please?
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Sun 05 Aug 2012, 13:26    Post subject:  

hi simes

yes the site seems down at the moment, this is quite a recent occurence and the site may well come back on line soon.

the version on the first page (2.80) is still working apart from the updates, so i wouldn't worry about it.

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
simes

Joined: 29 Sep 2007
Posts: 38
Location: Cheshire, UK

PostPosted: Sun 05 Aug 2012, 15:44    Post subject:  

Thanks, Phil. I used version 2.80 and installed it from your PET at the top of this thread. It insists on visiting the (unavailable) site to check for updates and drivers, then times out and ends. is there a way to bypass the check for updates so I can use v2.80?
Back to top
View user's profile Send private message 
simes

Joined: 29 Sep 2007
Posts: 38
Location: Cheshire, UK

PostPosted: Mon 06 Aug 2012, 11:09    Post subject:  

It's working for me today. I didn't change anything, so either the program found the updates it needed or gave up politely without complaint. Either way, thank you - a very useful utility indeed.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Tue 11 Dec 2012, 14:51    Post subject:  

updated

now working on Precise ... i've attached a .pet on the first post.

For this version i've updated how the gui acts, windows now don't overlap each other and you can press the 'enter' key to input information instead of having to click 'ok' Smile

i've removed flvstreamer from the package as i think that was causing problems.

live streaming is still not working, but i've posted a work-around in the 'Notes' on the first post. there's also a possible fix for audio/video sync problems if you're experiencing them.

i'll update the other .pets when i get time and make a .pet for the new slacko. in the mean time, if you're having problems with your version try deleting flvstreamer from /usr/bin

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
Barkingmad

Joined: 21 Nov 2008
Posts: 121

PostPosted: Wed 18 Sep 2013, 11:48    Post subject: Is get iplayer still working?  

Hello

I've found get-iplayer useful in the past but not used it for some time. I tried to download a programme today and found it doesn't seem to be working.

It gathers the big text list of all programmes (*tv.cache) OK but whatever I try to download just gives output as in the attchment.

Have the BBC altered something again and brocken the utility or am I unlucky?
Get_iplayer output.png
 Description   
 Filesize   27.76 KB
 Viewed   134 Time(s)

Get_iplayer output.png

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 5 [70 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0788s ][ Queries: 13 (0.0119s) ][ GZIP on ]