Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 05 Aug 2015, 04:36
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Pencil 0.4.4b
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
sheepy


Joined: 06 May 2011
Posts: 235
Location: GA

PostPosted: Sat 03 Sep 2011, 02:07    Post subject:  Pencil 0.4.4b
Subject description: Animation
 

Pencil is an animation/drawing application for Mac, Windows, and Linux.
Last edited by sheepy on Thu 23 Aug 2012, 16:23; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
eagleye31


Joined: 04 Jun 2012
Posts: 16

PostPosted: Wed 04 Jul 2012, 08:44    Post subject:  

thanks for the post, i am going to go and try this out. This should be very useful!
Back to top
View user's profile Send private message 
eagleye31


Joined: 04 Jun 2012
Posts: 16

PostPosted: Wed 04 Jul 2012, 21:38    Post subject:  

Did you test this on slacko?
Because when I tried installing it, my puppy crashed and I had to uninstall pencil to get working again. Thanks for posting the .pet anyway im sure it works much better on older puppy versions.
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1816
Location: Queensland

PostPosted: Thu 05 Jul 2012, 04:38    Post subject:  

eagleye31 wrote:
Did you test this on slacko?
Because when I tried installing it, my puppy crashed and I had to uninstall pencil to get working again. Thanks for posting the .pet anyway im sure it works much better on older puppy versions.


It has not been packaged correctly, I can't get it to work even after repackaging it.

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
sheepy


Joined: 06 May 2011
Posts: 235
Location: GA

PostPosted: Tue 07 Aug 2012, 19:31    Post subject:  

eagleye31 wrote:
Did you test this on slacko?
Because when I tried installing it, my puppy crashed and I had to uninstall pencil to get working again. Thanks for posting the .pet anyway im sure it works much better on older puppy versions.

Geoffrey wrote:
eagleye31 wrote:
Did you test this on slacko?
Because when I tried installing it, my puppy crashed and I had to uninstall pencil to get working again. Thanks for posting the .pet anyway im sure it works much better on older puppy versions.


It has not been packaged correctly, I can't get it to work even after repackaging it.

It was packaged in Lucid 525. It works for me. O.o It contains most of the dependencies for Pencil included in it. I never made the menu for this though.
Back to top
View user's profile Send private message Visit poster's website 
Geoffrey


Joined: 30 May 2010
Posts: 1816
Location: Queensland

PostPosted: Wed 08 Aug 2012, 00:31    Post subject:  

sheepy wrote:

It was packaged in Lucid 525. It works for me. O.o It contains most of the dependencies for Pencil included in it. I never made the menu for this though.


The problem with the package is that it installs the contents of /usr into "/", if I turn the pet into a tar.gz and extract,
the folder name is usr, when it should be pencil-0.4.4b in which /usr needs to be contained.

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
sheepy


Joined: 06 May 2011
Posts: 235
Location: GA

PostPosted: Thu 23 Aug 2012, 16:23    Post subject:  

Geoffrey wrote:
sheepy wrote:

It was packaged in Lucid 525. It works for me. O.o It contains most of the dependencies for Pencil included in it. I never made the menu for this though.


The problem with the package is that it installs the contents of /usr into "/", if I turn the pet into a tar.gz and extract,
the folder name is usr, when it should be pencil-0.4.4b in which /usr needs to be contained.

Whoops, you are so right! I repackaged it and re-uploaded it. Sorry for the inconvenience, my head must have been on backwards that day @_@ Thank you Smile
Back to top
View user's profile Send private message Visit poster's website 
pagestep007

Joined: 13 Jan 2015
Posts: 5

PostPosted: Wed 11 Mar 2015, 11:09    Post subject: pencil2d
Subject description: pencil to pencil2d
 

Hi, I managed to install pencil 4.4 animation program onto a puppy. I use it a lot. I found there has been a fork of the program called pencil2d. It looks like a good upgrade. I have tried installing .deb and .rpm packages offered on the pencil2d site, but although it appears in the menu, it does not run (and it zapped the older version of pencil 4.4). Doing a dependency check I found two dependencies missing. Installed them... and no luck yet. I was wondering if anyone has found Pencil2d and figured out how to get it to work.. like a .pet package maybe? Hopeful Smile
Back to top
View user's profile Send private message 
sonny


Joined: 29 Jan 2015
Posts: 32
Location: Washington State

PostPosted: Wed 11 Mar 2015, 13:11    Post subject:  

Try the puppy package manager (PPM), I just installed pencil2d with no problems. I am running vividpuppy....good luck. Idea
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1816
Location: Queensland

PostPosted: Wed 11 Mar 2015, 18:32    Post subject:  

I have Pencil2D working in Carolina, I repackaged the deb file from HERE, there is no documentation in the menu help, all that's required is that you have qt4 installed.
As a test I made a animation of a few frames, that worked and exported as an avi file.

pencil2d-0.5.4.pet
pencil2d.jpg
 Description   
 Filesize   49.17 KB
 Viewed   201 Time(s)

pencil2d.jpg


_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
pagestep007

Joined: 13 Jan 2015
Posts: 5

PostPosted: Wed 11 Mar 2015, 22:26    Post subject: Pencil2d
Subject description: installing Pencil2d
 

Thank you sonny and Geoffry for your fast replies and help.
I am running slacko 5.7 puppy. I tried the PET you suggested Geoffry (thanks). I made sure Qt4 was installed , and I appear to have libjson-c.so.2 and libsystemd.so.0 missing. Not sure where to get them from....any suggestions?
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1816
Location: Queensland

PostPosted: Thu 12 Mar 2015, 00:57    Post subject: Re: Pencil2d
Subject description: installing Pencil2d
 

pagestep007 wrote:
Thank you sonny and Geoffry for your fast replies and help.
I am running slacko 5.7 puppy. I tried the PET you suggested Geoffry (thanks). I made sure Qt4 was installed , and I appear to have libjson-c.so.2 and libsystemd.so.0 missing. Not sure where to get them from....any suggestions?


I just looked in X-slacko, they don't appear to be there, Try checking the PPM, just search for libjson and libsystemd.

If anyone is interested it works in Tahr NOP, I had to install these packages from the PPM.

libqt4-declarative_4.8.5+git192-g085f851+dfsg
libqt4-script_4.8.5+git192-g085f851+dfsg
libqt4-sql_4.8.5+git192-g085f851+dfsg
libqt4-svg_4.8.5+git192-g085f851+dfsg
libqt4-xml_4.8.5+git192-g085f851+dfsg
libqt4-xmlpatterns_4.8.5+git192-g085f851+dfsg
libqtcore4_4.8.5+git192-g085f851+dfsg
libqtdbus4_4.8.5+git192-g085f851+dfsg
libqtgui4_4.8.5+git192-g085f851+dfsg
qtcore4-l10n_4.8.5+git192-g085f851+dfsg
libqt4-dbus_4.8.5+git192-g085f851+dfsg
libphonon4_4.7.80

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
pagestep007

Joined: 13 Jan 2015
Posts: 5

PostPosted: Thu 12 Mar 2015, 13:34    Post subject: Pencil2d
Subject description: missing dependencies.
 

Thanks Geoffry, I managed to install the aforementioned files, but then three or four more popped up, got some of them sorted, and now I have libselinux.so.1 and libdw.so.1 in the system , but not in the right search path according to the dependencies checker program.. I have copied them to everywhere I can think of... where are yours on your system?
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1816
Location: Queensland

PostPosted: Thu 12 Mar 2015, 15:39    Post subject:  

@pagestep007

I'm using TahrNOP which has /lib/libselinux.so.1

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 4949
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 30 Mar 2015, 13:00    Post subject: Pencil  

Pencil : i know this appli, it was included in Legacy OS.
Less interest than tintii or inscapelite, in my opinion. Nevertheless, all new apps are welcome, in my photo-sensitve world.

_________________
Root is the glass, Pelo wants the wine.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Graphics
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0821s ][ Queries: 13 (0.0091s) ][ GZIP on ]