Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 03:06
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
How to use Radeon All in Wonder 9200 TV tuner?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Smithy


Joined: 12 Dec 2011
Posts: 460

PostPosted: Tue 07 Aug 2012, 05:32    Post subject:  How to use Radeon All in Wonder 9200 TV tuner?
Subject description: Enable settings in Xorg.conf
 

This is the original xorg conf file after installing xorg high pet:

Code:
#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"     # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
#    Load        "type1"
#    Load        "freetype"

# This loads xtrap extension, used by xrandr
#   Load       "xtrap"

# This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
    Load    "glx" #LOADGLX

# This loads dri module (if present). 7.4 loads it by default, have to disable...
   Load       "dri" #LOADDRI
#    Disable "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath   "/usr/share/X11/fonts/misc/"
    FontPath   "/usr/share/X11/fonts/Type1/"
    FontPath   "/usr/share/X11/fonts/TTF/"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

# With this, Xorg won't talk to HAL to add evdev devices and you'll be back
# with the old Xorg behavior (pre-7.4)...

    Option "AutoAddDevices" "false"

# For no-Hal, kirk also suggests this...

#    Option "AllowMouseOpenFail" "true"

# Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...

    Option "DontZap" "false"

EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "gb" #xkeymap0
EndSection

#everything past here is auto-generated by Puppy's Xorg Wizard...


#PuppyHardwareProfile=ATI_RADEON_9200VA1916wSERIE

I then added these lines to the xorg conf file, and uncommented just one of the lines:
ENABLE PAGE FLIP and ENABLED IT. Then rebooted.

Code:
Section "Device"
    Identifier "Radeon"
    Driver "radeon"
#    Option   "AGPMode"               "8"   #not used when KMS is on
#   Option   "AGPFastWrite"          "off" #could cause instabilities enable it at your own risk
#   Option   "SWcursor"              "off" #software cursor might be necessary on some rare occasions, hence set off by default
   Option   "EnablePageFlip"        "on"  #supported on all R/RV/RS4xx and older hardware and set off by default
#   Option   "AccelMethod"           "EXA" #valid options are XAA and EXA. EXA is the newest acceleration method and it is the default.
#   Option   "RenderAccel"           "on"  #enabled by default on all radeon hardware
#   Option   "ColorTiling"           "on"  #enabled by default on RV300 and later radeon cards.
#   Option   "EXAVSync"              "off" #default is off, otherwise on
#   Option   "EXAPixmaps"            "on"  #when on icreases 2D performance, but may also cause artifacts on some old cards
#   Option   "AccelDFS"              "on"  #default is off, read the radeon manpage for more information
EndSection

On the reboot I checked GLX GEARS, and it had shot up by 3500 frames, and suddenly all this NEW information has appeared in "DEVICE SECTION" of xorg conf:

Code:
#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"     # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
#    Load        "type1"
#    Load        "freetype"

# This loads xtrap extension, used by xrandr
#   Load       "xtrap"

# This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
    Load    "glx" #LOADGLX

# This loads dri module (if present). 7.4 loads it by default, have to disable...
   Load       "dri" #LOADDRI
#    Disable "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath   "/usr/share/X11/fonts/misc/"
    FontPath   "/usr/share/X11/fonts/Type1/"
    FontPath   "/usr/share/X11/fonts/TTF/"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

# With this, Xorg won't talk to HAL to add evdev devices and you'll be back
# with the old Xorg behavior (pre-7.4)...

    Option "AutoAddDevices" "false"

# For no-Hal, kirk also suggests this...

#    Option "AllowMouseOpenFail" "true"

# Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...

    Option "DontZap" "false"

EndSection

#everything past here is auto-generated by Puppy's Xorg Wizard...


Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc102"
   Option      "XkbLayout" "us" #xkeymap0
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2" #mouse0protocol
   Option       "Device" "/dev/mouse"
   #Option      "Emulate3Buttons"
   #Option      "Emulate3Timeout" "50"
   Option      "ZAxisMapping" "4 5" #scrollwheel
EndSection

Section "Monitor"
   #DisplaySize     410   260   # mm
   Identifier   "Monitor0"
   VendorName   "VSC"
   ModelName    "VA1916wSERIES"
   Option       "DPMS"
   HorizSync    24.0-82.0
   VertRefresh  50.0-71.0
   #UseModes     "Modes0" #monitor0usemodes
   Option      "PreferredMode" "1440x900"
   EndSection
   
Section "Modes"
   Identifier "Modes0"
   #modes0modeline0
EndSection

Section "Device"
   ### Available Driver options are:-
   ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
   ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
   ### [arg]: arg optional
   #Option     "NoAccel"               # [<bool>]
   #Option     "SWcursor"              # [<bool>]
   #Option     "Dac6Bit"               # [<bool>]
   #Option     "Dac8Bit"               # [<bool>]
   #Option     "BusType"               # [<str>]
   #Option     "CPPIOMode"             # [<bool>]
   #Option     "CPusecTimeout"         # <i>
   #Option     "AGPMode"               "8"
   #Option     "AGPFastWrite"          # [<bool>]
   #Option     "AGPSize"               # <i>
   #Option     "GARTSize"              # <i>
   #Option     "RingSize"              # <i>
   #Option     "BufferSize"            # <i>
   #Option     "EnableDepthMoves"      # [<bool>]
    Option     "EnablePageFlip"        "on"
   #Option     "NoBackBuffer"          # [<bool>]
   #Option     "DMAForXv"              # [<bool>]
   #Option     "FBTexPercent"          # <i>
   #Option     "DepthBits"             # <i>
   #Option     "PCIAPERSize"           # <i>
   #Option     "AccelDFS"              # [<bool>]
   #Option     "IgnoreEDID"            # [<bool>]
   #Option     "CustomEDID"            # [<str>]
   #Option     "DisplayPriority"       # [<str>]
   #Option     "PanelSize"             # [<str>]
   #Option     "ForceMinDotClock"      # <freq>
   #Option     "ColorTiling"           # [<bool>]
   #Option     "VideoKey"              # <i>
   #Option     "RageTheatreCrystal"    # <i>
   #Option     "RageTheatreTunerPort"    # <i>
   #Option     "RageTheatreCompositePort"    # <i>
   #Option     "RageTheatreSVideoPort"    # <i>
   #Option     "TunerType"             # <i>
   #Option     "RageTheatreMicrocPath"    # <str>
   #Option     "RageTheatreMicrocType"    # <str>
   #Option     "ScalerWidth"           # <i>
   #Option     "RenderAccel"           "on"
   #Option     "SubPixelOrder"         # [<str>]
   #Option     "ShowCache"             # [<bool>]
   #Option     "ClockGating"           # [<bool>]
   #Option     "VGAAccess"             # [<bool>]
   #Option     "ReverseDDC"            # [<bool>]
   #Option     "LVDSProbePLL"          # [<bool>]
   #Option     "AccelMethod"           # <str>
   #Option     "DRI"                   # [<bool>]
   #Option     "ConnectorTable"        # <str>
   #Option     "DefaultConnectorTable"    # [<bool>]
   #Option     "DefaultTMDSPLL"        # [<bool>]
   #Option     "TVDACLoadDetect"       # [<bool>]
   #Option     "ForceTVOut"            # [<bool>]
   #Option     "TVStandard"            # <str>
   #Option     "IgnoreLidStatus"       # [<bool>]
   #Option     "DefaultTVDACAdj"       # [<bool>]
   #Option     "Int10"                 # [<bool>]
   #Option     "EXAVSync"              # [<bool>]
   #Option     "ATOMTVOut"             # [<bool>]
   #Option     "R4xxATOM"              # [<bool>]
   #Option     "ForceLowPowerMode"     # [<bool>]
   #Option     "DynamicPM"             # [<bool>]
   #Option     "NewPLL"                # [<bool>]
   #Option     "ZaphodHeads"           # <str>
   Identifier  "Card0"
   Driver      "radeon" #card0driver
   VendorName  "ATI Technologies Inc"
   BoardName   "RV280 [Radeon 9200]"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   #Option         "metamodes" "1440x900_60 +0+0" #METAMODES_0
   Subsection "Display"
      Depth       24
      Modes       "1440x900"
   EndSubsection
EndSection

#PuppyHardwareProfile=ATI_RADEON_9200VA1916wSERIE

How can I get the tuner portion functioning? Xine Player seems to think there is something going on now, but it is confused..
BTW it is an all in wonder 9200.
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Sun 12 Aug 2012, 13:21    Post subject:  

some people are recommending TvTime
http://tvtime.sourceforge.net/

are you using Music2go Puppy?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Smithy


Joined: 12 Dec 2011
Posts: 460

PostPosted: Sun 12 Aug 2012, 16:30    Post subject:  

darkcity wrote:
some people are recommending TvTime
http://tvtime.sourceforge.net/

are you using Music2go Puppy?


I am darkcity, incidentally, I tried out this game Lugaru as a test:

http://208.109.22.214/puppy/viewtopic.php?t=70817&sid=d5e82c162d71e7aeaeb9cb3d18947f37

and the frame rate is really good, didn't have to add any of the libs, so I guess opengl is working. Have to re X to 1024x768 tho', or it crawls, and then the screen goes a funny faded green look to it, don't know what that problem is, but the rabbit runs like the clappers and does some mean karate kicks!


So if i find a tv time pet, will it just work or do I have to do the nuclear scientist stuff with xorg and whatever else (modules?) it needs?
Actually I better answer that question by trying it..
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Sun 12 Aug 2012, 18:03    Post subject:  

this thread may be of interest
http://www.murga-linux.com/puppy/viewtopic.php?t=64096

Quote:
screen goes a funny faded green look to it

that could be because your using 16bit instead 24bit, on xorg wizard you can choose-

1024x768x16
or
1024x768x24


Quote:
rabbit runs like the clappers and does some mean karate kicks!

no need for tv then ; -)

might be worth trying on fresh install.

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Smithy


Joined: 12 Dec 2011
Posts: 460

PostPosted: Mon 13 Aug 2012, 06:02    Post subject:  

It is a fresh install every time, from a usb stick, no save file, just the xorghigh built in.
Then I try that code, notice video for linux then appears in modules loaded.
Yes, the faded green is because I set it to 16 bit, thanks for that.
Weird that it can't display correctly at 16 bit. Everything runs faster at this bit rate. The playback meters on qtractor+podium are going as fast as windows now as far as I can tell in this mode.
Is linux a resource pig?

TV Time after being installed appears after I put the code in and restart X.
It says no signal. No video device.
No such device or address.
Cannot open capture device /dev/video0.

Could be wrong, but I think I need to "fill in" the answers to these sections in the code below. Wonder what the heck Zaphodheads is, sounds like a band.




Code:
Section "Device"
   ### Available Driver options are:-
   ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
   ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
   ### [arg]: arg optional
   #Option     "NoAccel"               # [<bool>]
   #Option     "SWcursor"              # [<bool>]
   #Option     "Dac6Bit"               # [<bool>]
   #Option     "Dac8Bit"               # [<bool>]
   #Option     "BusType"               # [<str>]
   #Option     "CPPIOMode"             # [<bool>]
   #Option     "CPusecTimeout"         # <i>
   #Option     "AGPMode"               "8"
   #Option     "AGPFastWrite"          # [<bool>]
   #Option     "AGPSize"               # <i>
   #Option     "GARTSize"              # <i>
   #Option     "RingSize"              # <i>
   #Option     "BufferSize"            # <i>
   #Option     "EnableDepthMoves"      # [<bool>]
    Option     "EnablePageFlip"        "on"
   #Option     "NoBackBuffer"          # [<bool>]
   #Option     "DMAForXv"              # [<bool>]
   #Option     "FBTexPercent"          # <i>
   #Option     "DepthBits"             # <i>
   #Option     "PCIAPERSize"           # <i>
   #Option     "AccelDFS"              # [<bool>]
   #Option     "IgnoreEDID"            # [<bool>]
   #Option     "CustomEDID"            # [<str>]
   #Option     "DisplayPriority"       # [<str>]
   #Option     "PanelSize"             # [<str>]
   #Option     "ForceMinDotClock"      # <freq>
   #Option     "ColorTiling"           # [<bool>]
   #Option     "VideoKey"              # <i>
   #Option     "RageTheatreCrystal"    # <i>
   #Option     "RageTheatreTunerPort"    # <i>
   #Option     "RageTheatreCompositePort"    # <i>
   #Option     "RageTheatreSVideoPort"    # <i>
   #Option     "TunerType"             # <i>
   #Option     "RageTheatreMicrocPath"    # <str>
   #Option     "RageTheatreMicrocType"    # <str>
   #Option     "ScalerWidth"           # <i>
   #Option     "RenderAccel"           "on"
   #Option     "SubPixelOrder"         # [<str>]
   #Option     "ShowCache"             # [<bool>]
   #Option     "ClockGating"           # [<bool>]
   #Option     "VGAAccess"             # [<bool>]
   #Option     "ReverseDDC"            # [<bool>]
   #Option     "LVDSProbePLL"          # [<bool>]
   #Option     "AccelMethod"           # <str>
   #Option     "DRI"                   # [<bool>]
   #Option     "ConnectorTable"        # <str>
   #Option     "DefaultConnectorTable"    # [<bool>]
   #Option     "DefaultTMDSPLL"        # [<bool>]
   #Option     "TVDACLoadDetect"       # [<bool>]
   #Option     "ForceTVOut"            # [<bool>]
   #Option     "TVStandard"            # <str>
   #Option     "IgnoreLidStatus"       # [<bool>]
   #Option     "DefaultTVDACAdj"       # [<bool>]
   #Option     "Int10"                 # [<bool>]
   #Option     "EXAVSync"              # [<bool>]
   #Option     "ATOMTVOut"             # [<bool>]
   #Option     "R4xxATOM"              # [<bool>]
   #Option     "ForceLowPowerMode"     # [<bool>]
   #Option     "DynamicPM"             # [<bool>]
   #Option     "NewPLL"                # [<bool>]
   #Option     "ZaphodHeads"           # <str>
   Identifier  "Card0"
   Driver      "radeon" #card0driver
   VendorName  "ATI Technologies Inc"
   BoardName   "RV280 [Radeon 9200]"
   BusID       "PCI:1:0:0"
EndSection
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Mon 13 Aug 2012, 12:57    Post subject:  

according to

http://www.murga-linux.com/puppy/viewtopic.php?p=490026#490026

a channels.conf file needs setting up?

---

Good point about "16bit mode not working"
http://bkhome.org/blog/?viewDetailed=01503
---

Zaphodheads could be an alien race?

Smile

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Mon 13 Aug 2012, 13:17    Post subject:  

Confirmed error with

X Org 1.7.6
ATI Technologies Radeon RV100 QY [Radeon 7000/VE]

set via ALSA wizard
(havent tried manual edit yet)

Arrow

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Smithy


Joined: 12 Dec 2011
Posts: 460

PostPosted: Mon 13 Aug 2012, 17:14    Post subject:  

You're a gold mine of old threads darkcity, that project by Synth that never materialised had a link by Lobster to a great little on the fly mp3 editor.

Checked the Barry K vs Playdayz 16 bit greenish screen post. Will attempt that tip shortly.

Could do with a Zaphodhead to give me a hand with the videocard Razz

Edit: Strange, I went into Xorg through the screen that looks like old msdos screen without adding any of that new "device section" code, and now I can see all those options already there.
And yet if I look at the xorg.conf in Geany they are not there.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1413s ][ Queries: 12 (0.0046s) ][ GZIP on ]