Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 07:45
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Problema con OpenGL con tarjeta gráfica Intel
Moderators: rarsa
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
kaeza


Joined: 30 Nov 2011
Posts: 51
Location: Montevideo, Uruguay

PostPosted: Sun 19 Aug 2012, 13:48    Post subject:  Problema con OpenGL con tarjeta gráfica Intel  

Disculpas por cross-postear aquí, pero en el foro en inglés no he podido recibir ayuda.

Mi problema es que las aplicaciones OpenGL pesadas como Blender, e incluso algunas no tanto como Vavoom, Prboom, Quake y otras tantas andan demasiado lentas.

El problema es que Mesa está usando el rasterizador por software, porque no puede encontrar el driver para mi tarjeta gráfica.

Mi tarjeta gráfica según HardInfo es "Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)".

Alguien puede proveer un link al driver?

_________________
"Courage is not the absence of fear, but rather the judgement that something else is more important than fear." -- Ambrose Redmoon
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 982
Location: Peru

PostPosted: Tue 21 Aug 2012, 01:20    Post subject:  

¿Version de Puppy? en teoria necesitas instalar cosas como: mesa-lib, mesa-dri, mesa-glut, libdrm, algun otro software, cargar los modulos de kernel adecuados, verificar en el BIOS que la memoria compartida para video sea mayor a 64MB, etc. En algunas versiones de puppy existe el .pet xorg-full (o algun nombre similar) que contiene todo lo necesario, busca algo asi en PuppyPackageManager.

Lee los mensajes de error de Xorg para identificar que es lo que falta ejecutando:
Code:
grep -i "(EE)" /var/log/Xorg.0.log

Quiza obtengas más informacion del hardware de video ejecutando:
Code:
grep -i chipset /var/log/Xorg.0.log

_________________

Back to top
View user's profile Send private message 
kaeza


Joined: 30 Nov 2011
Posts: 51
Location: Montevideo, Uruguay

PostPosted: Tue 21 Aug 2012, 02:24    Post subject:  

Estoy ejecutando Lucid Puppy 525, Instalación Frugal.

Mi computadora es una Intel E5700 Dual Core @3.0GHz (x2), con 4GB de RAM. La tarjeta gráfica es la que dije anteriormente, es on-board y tiene aparentemente 128MB de video (no es mucho para los estándares actuales, pero debería ser suficiente para lo que la quiero, al menos hasta poder conseguir una tarjeta mejor).

He descargado un paquete llamado "xorg-high" que me permite ejecutar OpenGL (antes de ésto no podía), pero juegos bastante viejos como el Age of Empires 2 corren a 4 o 5 cuadros por MINUTO (calculado más o menos, la pantalla demora unos 10 o 15 segundos en actualizarse).

¿Dónde puedo encontrar las bibliotecas que has dicho?
¿Existe algún paquete prefabricado para Puppy?

_________________
"Courage is not the absence of fear, but rather the judgement that something else is more important than fear." -- Ambrose Redmoon
Back to top
View user's profile Send private message 
kaeza


Joined: 30 Nov 2011
Posts: 51
Location: Montevideo, Uruguay

PostPosted: Tue 21 Aug 2012, 02:33    Post subject:  

Bueno logré encontrar el manual de mi placa madre, y la tarjeta gráfica es aparentemente "Intel Graphics Media Accelerator X4500".

Edit:
Dice también soporte para Pixel Shader 4.0 y DirectX 10.
Memoria compartida máxima de 1759MB.
Soporte para D-Sub(?) con una resolución máxima de 2048x1536 @75Hz.

_________________
"Courage is not the absence of fear, but rather the judgement that something else is more important than fear." -- Ambrose Redmoon
Back to top
View user's profile Send private message 
wow

Joined: 29 Jun 2006
Posts: 982
Location: Peru

PostPosted: Tue 21 Aug 2012, 14:52    Post subject:  

Aparentemente solo tienes aceleracion 3D por software, ejecuta:
Quote:
grep -i "(EE)" /var/log/Xorg.0.log

Y pega el resultado aqui. Entre los errores deberia mostrar cosas como esta que ayudan a identificar el problema:
Code:
(EE) AIGLX error: dlopen of /usr/lib/xorg/modules/dri/i965_dri.so failed (/usr/lib/xorg/modules/dri/i965_dri.so: undefined symbol: _ZN23ir_hierarchical_visitor5visitEP9ir_rvalue)
[    16.057] (EE) AIGLX: reverting to software rendering


Prueba a instalar los drivers con el icono Quickpet en el escritorio, busca algun boton u opcion que indique video drivers o DRI.

No uso(o usare) puppy 5.x y uso video nVidia, asi que no conozco paquetes .pet que te sean de utilidad.

_________________

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Usuarios de habla Hispana
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0522s ][ Queries: 12 (0.0059s) ][ GZIP on ]