Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 17:06
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
geany fait la tête
Moderators: Béèm, darkerror05
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
musher0


Joined: 04 Jan 2009
Posts: 4465
Location: Gatineau (Qc), Canada

PostPosted: Thu 06 Sep 2012, 20:49    Post_subject:  geany fait la tête
Sub_title: et refuse tout à coup de se lancer
 

Bonsoir, M'sieurs/dames !

Hier, j'ai voulu lancer geany comme je l'ai des centaines de fois avant et... patate ! urxvt m'envoie le message :

Code:
geany: symbol lookup error: /usr/lib/libvte.so.9: undefined symbol: g_mutex_lock


J'ai vérifié, et la biblio en question est installée.

Ce n'est pas une urgence, j'ai deux autres éditeurs, joe et leafpad, mais pour retravailler certaines configurations par groupes, je préfère geany.

Si jamais quelqu'un peut m'expliquer le sens de ce message... et quoi faire pour que geany se lance à nouveau...

Merci d'avance.

PS. L'ordi sur lequel c'est arrivé est un vieil Intel 1,8 MHz avec 1,25 Go de MEV et carte graphique GForce 440MMX. Je communique cette information à tout hasard, car j'ai l'impression que le probl. est logiciel plutôt que matériel.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Thu 06 Sep 2012, 23:13    Post_subject:  

Bonjour Musher,

la libvte est un composant d'émulateur graphique de teminal pour GTK.

N'aurais-tu pas installé un autre paquet de Terminal (vte, lxterminal, sakura, etc.) qui aurait en même temps changé la version de la libvte ? Ou fait des modif. dans GTK ?
Il y a manifestement une incompatibilité de versions dans le système et de fortes chances que geany, si inchangé, ne soit pas directement en cause !

(Pour l'anecdote, sur Lucid en désinstallant le paquet intégré lxterminal la libvte disparait...).

Cordialement,
Médor.
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4465
Location: Gatineau (Qc), Canada

PostPosted: Thu 06 Sep 2012, 23:41    Post_subject:  

Salut, Médor.

Hum... en effet j'ai installé le plus récent ytree l'autre jour... (Très bel outil pour gérer des fichiers autrement, d'ailleurs.) Merci pour le tuyau.

Tu me suggères quoi pour ravoir geany tout en conservant le nouveau ytree ? Installer un geany plus récent par-dessus l'ancien ? Une autre version peut-être ? Merci d'avance.

A+

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Fri 07 Sep 2012, 00:28    Post_subject:  

Je ne pense pas que l'installation d'ytree modifie à ce point le système !
Mais ça fait un bail que je ne l'ai pas utilisé sur Puppy, et bien plus encore sont ancêtre xtree sous dos mais j'ai toujours préféré nc et ses cousins.

Si tu es en frugale, la libvte d'origine se trouve toujours dans /initrd/pup_ro2/...
À mon avis il y a eu un autre programme d'installé qui a modifié une lib majeure du système reste à le connaitre avant de vouloir remplacer geany.

Il y a sur le forum une version de Geany 0.21 assez complet avec entre autres le correcteur d'orthographe, pour l'instant j'utilise la version 0.20, mais la plus part du temps je me sers simplement de leafpad et de gedit au besoin.

Je vais vérifier ce que contient exactement ytree...

Cordialement,
Médor.
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1838

PostPosted: Fri 07 Sep 2012, 01:09    Post_subject:  

Je viens de vérifier ytree-1.84.pet

Il fonctionne sur Lucid-528 directement et sans installer de dépendance
Code:
# ldd ./ytree
   linux-gate.so.1 =>  (0xffffe000)
   libncurses.so.5 => /lib/libncurses.so.5 (0xb772f000)
   libc.so.6 => /lib/libc.so.6 (0xb75d5000)
   libdl.so.2 => /lib/libdl.so.2 (0xb75d1000)
   /lib/ld-linux.so.2 (0xb7769000)


Il fonctionne directement dans l'écran noir, sans X !

Voir ce lien pour geany-0.21

Cordialement,
Médor.
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4465
Location: Gatineau (Qc), Canada

PostPosted: Fri 07 Sep 2012, 16:53    Post_subject:  

Merci, Médor, je vais aller voir ça tantôt.

A+

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0522s ][ Queries: 12 (0.0039s) ][ GZIP on ]