Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 16:33
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Gramps: genealogical research program
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4 Next
Author Message
tallboy


Joined: 21 Sep 2010
Posts: 444
Location: Oslo, Norway

PostPosted: Tue 26 Jun 2012, 03:16    Post_subject:  

Which puppy was this made for? Here is the result from trying to install it in dpup4.84-beta4_2.6.30. All earlier gramps pets have run normal. And suddenly all the borders around the buttons in my JWM are gone! Did you include your own setup in the .pet?

4189: WARNING: Spell.py: line 60: Spelling checker is not installed
7985: ERROR: grampsgui.py: line 316: Gramps failed to start.
Traceback (most recent call last):
File "/usr/local/share/gramps/gui/grampsgui.py", line 292, in __startgramps
Gramps(argparser)
File "/usr/local/share/gramps/gui/grampsgui.py", line 213, in __init__
register_stock_icons()
File "/usr/local/share/gramps/gui/grampsgui.py", line 165, in register_stock_icons
base_reg_stock_icons(iconpaths, extraiconsize, items+items_legacy)
File "/usr/local/share/gramps/gui/pluginmanager.py", line 90, in base_reg_stock_icons
pixbuf = gtk.gdk.pixbuf_new_from_file (icon_file)
GError: Couldn't recognize the image file format for file '/usr/local/share/gramps/images/gramps.png'

** (gramps.py:14136): WARNING **: Pixbuf theme: Cannot load pixmap file /usr/share/themes/Chrome-Like/gtk-2.0/focus.png: Couldn't recognize the image file format for file '/usr/share/themes/Chrome-Like/gtk-2.0/focus.png'

/usr/local/share/gramps/GrampsLogger/_ErrorView.py:68: GtkWarning: gdk_pixbuf_get_width: assertion `GDK_IS_PIXBUF (pixbuf)' failed
response = self.top.run()
/usr/local/share/gramps/GrampsLogger/_ErrorView.py:68: GtkWarning: gdk_pixbuf_get_height: assertion `GDK_IS_PIXBUF (pixbuf)' failed
response = self.top.run()

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image
/usr/local/share/gramps/GrampsLogger/_ErrorView.py:68: GtkWarning: gdk_pixbuf_get_n_channels: assertion `GDK_IS_PIXBUF (pixbuf)' failed
response = self.top.run()
/usr/local/share/gramps/GrampsLogger/_ErrorView.py:68: GtkWarning: gdk_pixbuf_get_pixels: assertion `GDK_IS_PIXBUF (pixbuf)' failed
response = self.top.run()
/usr/local/share/gramps/GrampsLogger/_ErrorView.py:68: GtkWarning: gdk_pixbuf_get_rowstride: assertion `GDK_IS_PIXBUF (pixbuf)' failed
response = self.top.run()

** (gramps.py:14136): WARNING **: Pixbuf theme: Cannot load pixmap file /usr/share/themes/Chrome-Like/gtk-2.0/button-normal.png: Couldn't recognize the image file format for file '/usr/share/themes/Chrome-Like/gtk-2.0/button-normal.png'


** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/button-normal.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/button-normal.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/button-normal.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image

** (gramps.py:14136): WARNING **: Invalid borders specified for theme pixmap:
/usr/share/themes/Chrome-Like/gtk-2.0/focus.png,
borders don't fit within the image

tallboy
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Tue 26 Jun 2012, 04:38    Post_subject:  

Tallboy,

are you referring to Autofyrsto's pet, or mine?

If the first, which Python package have you installed? I had a cursory look at Autofyrsto's package, and it seems to run, with lupu525, with only the following errors:

Code:
./gramps
2892: WARNING: Spell.py: line 60: Spelling checker is not installed
WARNING: osmgpsmap module not loaded. Geography functionality will not be available.
WARNING: pyexiv2 module not loaded.  Image metadata functionality will not be available.


Edit: I wonder if you didn''t uninstall, your previous version of gramps, whether there could be any conflict?
Back to top
View user's profile Send_private_message 
tallboy


Joined: 21 Sep 2010
Posts: 444
Location: Oslo, Norway

PostPosted: Tue 26 Jun 2012, 06:06    Post_subject:  

Your Gramps 2.6 and 3.3 pets run just fine, muggins, I was referring to the autofyrsto's 3.4 version in the post above.

I run the Python+2.6.4-i486.pet package.

I have Python, libgd2, libdb-4, graphwiz-2.2 and gramps in a directory on a USB HD (with my dpup485 on a DVD multisession-'partition'), and install when I need them.

BTW, I just installed the gramps 3.3 with the same additional applications in my dpup4.84-beta4, and it runs just like it should.

tallboy
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Thu 28 Jun 2012, 06:52    Post_subject:  

Well I downloaded dpup485, booted it, then installed autofyrsto's package. Whilst I didn't get the pixmap probs that tallboy reported, it still wouldn't run.

Being a python dunderhead, I didn't want to try & unravel why, so instead made a .pet of the 3.4.0 debian package & it seems OK.

If you want to try, see first post.
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Fri 29 Jun 2012, 03:49    Post_subject:  

Has anyone tried java-based Ancestris?
Back to top
View user's profile Send_private_message 
tallboy


Joined: 21 Sep 2010
Posts: 444
Location: Oslo, Norway

PostPosted: Sat 07 Jul 2012, 19:28    Post_subject:  

Thank you, muggins.

tallboy
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Sat 08 Sep 2012, 11:30    Post_subject:  

Uploaded gramps-3.4.1-1.pet.
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Sat 08 Sep 2012, 11:52    Post_subject:  

Hi.

I have made an SFS of all files ---> result: 13MB SFS File that runs in LazY Puppy.



Here is the SFS

RSH

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
tallboy


Joined: 21 Sep 2010
Posts: 444
Location: Oslo, Norway

PostPosted: Sat 15 Sep 2012, 21:14    Post_subject:  

Hi RSH
It would be an extra bonus if you cold add Graphwiz to your SFS, and maybe even ttf-freefont.

These are all the additions I have used to run all Gramps 3.2.6, 3.3.1, 3.4.0 and now finally 3.4.1.1. in my dpup-484/485s, and all other puppies I have tried that are accepting .deb packages, I am sure they exist as non-debs too. I believe the python-pet I use is adapted for puppies, and is maybe not a full python installation. It all works perfectly.

tallboy

Oh forgot; BTW - good work!
grampsdir.png
 Description   
 Filesize   10.81 KB
 Viewed   1043 Time(s)

grampsdir.png

Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Sat 15 Sep 2012, 21:53    Post_subject:  

If i would know, where to find the exactly needed files, i would do this with pleasure.

But I don't know. Found this one: Ubuntu which is a lot of files.

Too much for me to figure out what is needed and what is not needed.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
davids45


Joined: 26 Nov 2006
Posts: 652
Location: Chatswood, NSW

PostPosted: Sun 16 Sep 2012, 02:23    Post_subject: Ancestris
Sub_title: java-based genealogy
 

G'day muggins in Merimbula,

You asked earlier:
Quote:
Has anyone tried java-based Ancestris?


I did (albeit briefly after your post) and found it quite good, once I got it and java set up together. I threw a 70,000+ person genealogy data-base gedcom at it and it looked unfazed. It told me I was still the person I think I am.

I'm pretty much locked into the Windows-based "Legacy" program for my family dabblings (even paid them money!) but do keep some other like-programs (well, free ones) around just in case.

I would just need to get Ancestris into an sfs and pet form to add this to my collection of "add-ons" for each new Pup. I don't know how the continual java updates would affect it however.

So thanks for finding and mentioning it.

David S.
Back to top
View user's profile Send_private_message 
tallboy


Joined: 21 Sep 2010
Posts: 444
Location: Oslo, Norway

PostPosted: Sun 16 Sep 2012, 23:05    Post_subject:  

RSH wrote:
If i would know, where to find the exactly needed files, i would do this with pleasure.


Thank you, RSH. Except for the .pet files, I cannot remember where I got the .deb files. I may have gotten them from debian.org, one was maybe in the old stable debian release 'lenny', but the graphviz? Sorry, I don't remember, but the dpups I use are based on debian, not on ubuntu.

tallboy
Back to top
View user's profile Send_private_message 
TJK

Joined: 19 Feb 2008
Posts: 31
Location: near Victoria, BC, Canada

PostPosted: Thu 18 Oct 2012, 16:32    Post_subject: gramp error - cannot add event  

I have been using Gramps under Kubuntu 11.04 until recently... and I don't recall ever having any problems. But recently I've tried to use Gramps on my laptop, under Puppy Linux 5.25 -- and I've been getting many problems and errors... which has been very frustrating.

I have tried various versions, including the pet posted on this topic -- all instalations ended in getting error messages. I've followed suggestions in backing up and reimporting, running repairs, etc -- all did not help the situation. Currently I'm using the SFS file. And only a few days after installing it, I'm getting an error message when trying to add an event. This is what the terminal readout is saying:
Quote:
# gramps
632: WARNING: Spell.py: line 60: Spelling checker is not installed
1730: WARNING: geography.gpr.py: line 42: WARNING: osmgpsmap module not loaded. Geography functionality will not be available.
1803: WARNING: bottombar.gpr.py: line 90: WARNING: pyexiv2 module not loaded. Image metadata functionality will not be available.
84740: ERROR: gramps.py: line 105: Unhandled exception
Traceback (most recent call last):
File "/usr/share/gramps/gui/editors/displaytabs/eventembedlist.py", line 224, in add_button_clicked
event, ref, self.object_added)
File "/usr/share/gramps/gui/editors/editeventref.py", line 58, in __init__
update)
File "/usr/share/gramps/gui/editors/editreference.py", line 111, in __init__
self._post_init()
File "/usr/share/gramps/gui/editors/editeventref.py", line 89, in _post_init
if not date.get_text_length():
AttributeError: 'ValidatableMaskedEntry' object has no attribute 'get_text_length'

I would really appreciate any help regarding these problems...
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Fri 19 Oct 2012, 17:34    Post_subject:  

That's very strange.

That's all python error messages, but the python is inside the sfs.

I'm not comfortable with python, so I can't help here.

Sorry.

RSH

---

Did you remove some stuff or install any other python or python included software?

EDIT:

A few days ago I did read about some missing python stuff in the devx of lucid 528. Seems like the puppy python stuff isn't pretty well configured. Maybe this is generally a puppy/python problem?

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
ramberler1939

Joined: 04 Dec 2012
Posts: 1

PostPosted: Tue 04 Dec 2012, 18:00    Post_subject:  

hello, thank you for the Gramps PET any chance of an update to Gramp 3.4.2 http://gramps-project.org/2012/10/gramps-3-4-2-released-were-all-individuals/
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1050s ][ Queries: 13 (0.0200s) ][ GZIP on ]