Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 28 Jul 2014, 19:09
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Slacko 5.3.1 only wireless
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Pelo


Joined: 10 Sep 2011
Posts: 2902
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 08 Sep 2012, 06:24    Post subject:  Slacko 5.3.1 only wireless
Subject description: no ethernet connection
 

i dont find the module to load
Could you help me, please
PCI devices.png
Description 
png

 Download 
Filename  PCI devices.png 
Filesize  185.21 KB 
Downloaded  153 Time(s) 
Back to top
View user's profile Send private message Yahoo Messenger 
Karl Godt


Joined: 20 Jun 2010
Posts: 3956
Location: Kiel,Germany

PostPosted: Sat 08 Sep 2012, 08:49    Post subject:  

For the wireless there is :
http://wireless.kernel.org/en/users/Drivers/Atheros
PCI / PCI-E / AHB Drivers

Technology Upstream driver

802.11abg ath5k

802.11abgn ath9k

802.11ad wil6210
#

which i have :

/lib/modules/2.6.30.9-i586-dpup005-Celeron2G/kernel/drivers/net/wireless/ath5k/ath5k.ko.gz
/lib/modules/2.6.30.9-i586-dpup005-Celeron2G/kernel/drivers/net/wireless/ath9k/ath9k.ko.gz

*
But for http://www.pcidatabase.com/vendor_details.php?id=1659
0x1083
Chip Number: 1083
Chip Description: 1083
Notes: Atheros AR8151 Ethernet Driver (If Link Dies Look Under Acer Aspire 5253 LAN) - http://goo.gl/IsI1M

I don't have , just

bash-3.00# modinfo atl1c
filename: /lib/modules/2.6.30.9-i586-dpup005-Celeron2G/kernel/drivers/net/atl1c/atl1c.ko.gz
version: 1.0.0.1-NAPI
license: GPL
description: Atheros 1000M Ethernet Network Driver
author: Jie Yang <jie.yang@atheros.com>
srcversion: 8743914A750A08E3FAC80C7
alias: pci:v00001969d00001062sv*sd*bc*sc*i*
alias: pci:v00001969d00001063sv*sd*bc*sc*i*

So i would do a
Code:
modprobe -l | grep atl

to check if atheros ?lan? drivers are available .
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Sat 08 Sep 2012, 10:15    Post subject:  

First of all, run the command "lspci -nn" and determine the [vendor:product] ID codes for this device. Is it [1969:1083]?

I don't have a copy of Slacko 531. But I checked in 533 and it appears to support this device using the atl1c module.
Back to top
View user's profile Send private message 
Pelo


Joined: 10 Sep 2011
Posts: 2902
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 09 Sep 2012, 08:24    Post subject: ethernet connection with Slacko 5.3.1
Subject description: atl1c is well the module to load
 

Here are the info (Slacko 5.3.2.9)
=== NETWORK ===

Network controller: Intel Corporation Centrino Wireless-N 1030
KERNEL MODULE: iwlagn
KERNEL MODULE: iwlagn
Ethernet controller: Atheros Communications Device
KERNEL MODULE: atl1c
KERNEL MODULE: atl1c

All distros have the cable connection, Slacko 5.3.3 and its puplets, Lucids 5xxx and their puplets, Dpup exprimo, even the older ones. I think there is a module to load.
I was using and enjoying Slacko 5.3.2.9 since yesterday, safest than 5.3.3.

I dont understand 5.3.1 was also working well until now. It is incredible. Perhaps due to the USB trade mark ? but I was running Slacko 5.3 previously on this material. I Dont know.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 2902
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 09 Sep 2012, 08:27    Post subject: lspci -nn
Subject description: Dont worry to much about that/ save files are now transfered to 5.3.2.9
 

00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0104] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port [8086:0101] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
00:1a.0 USB Controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 [8086:1c10] (rev b5)
00:1c.1 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 [8086:1c12] (rev b5)
00:1c.3 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 [8086:1c16] (rev b5)
00:1c.4 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 [8086:1c18] (rev b5)
00:1d.0 USB Controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 [8086:1c26] (rev 05)
00:1f.0 ISA bridge [0601]: Intel Corporation HM65 Express Chipset Family LPC Controller [8086:1c49] (rev 05)
00:1f.2 SATA controller [0106]: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller [8086:1c03] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller [8086:1c22] (rev 05)
01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0de9] (rev a1)
03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [8086:008a] (rev 34)
04:00.0 Ethernet controller [0200]: Atheros Communications AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
05:00.0 USB Controller [0c03]: Texas Instruments Device [104c:8241] (rev 02)
sh-4.1#
Back to top
View user's profile Send private message Yahoo Messenger 
rcrsn51


Joined: 05 Sep 2006
Posts: 8917
Location: Stratford, Ontario

PostPosted: Sun 09 Sep 2012, 09:21    Post subject: Re: ethernet connection with Slacko 5.3.1
Subject description: atl1c is well the module to load
 

Pelo wrote:
All distros have the cable connection, Slacko 5.3.3 and its puplets, Lucids 5xxx and their puplets, Dpup exprimo, even the older ones. I think there is a module to load.

In Lucid 528, your [1969:1083] device is handled by the atl1e module. In newer Puppies, it has changed to the atl1c module. It looks like a few Puppies in between, such as Slacko 531, don't support it at all.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0586s ][ Queries: 13 (0.0039s) ][ GZIP on ]