Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 15:20
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Umplayer Youtube no longer working ?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
backi

Joined: 27 Feb 2011
Posts: 448
Location: GERMANY

PostPosted: Sun 16 Sep 2012, 04:29    Post_subject:  Umplayer Youtube no longer working ?  

Hi everybody !
Did anybody observe ? Umplayer no longer Youtube playing ?
Back to top
View user's profile Send_private_message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Sun 16 Sep 2012, 05:54    Post_subject:  

Dear backi,

thanks...you're right!

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Sun 16 Sep 2012, 06:01    Post_subject:  

Confirmed Sad

Umplayer has been at 0.97 for about a year now so don't hold your breath for an update.

Actually, lucky it works with the latest mplayer, it still expects 1.0rc3

8 months .. http://umplayer.svn.sourceforge.net/viewvc/umplayer/ svn

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Sun 16 Sep 2012, 06:45    Post_subject:  

i noticed this also, makes me sad.
Back to top
View user's profile Send_private_message AIM YIM 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 16 Sep 2012, 13:25    Post_subject:  

8 months ago umplayer source code had youtube fix update. That is the last update.

http://umplayer.svn.sourceforge.net/viewvc/umplayer/umplayer/trunk/

Use find in browser for youtube fix and you will find the files which were changed. I hope that the source will be fixed again.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 16 Sep 2012, 13:57    Post_subject:  

2 days ago smplayer-smtube svn has got fix for youtube.
Smtube-Smplayer compo plays youtube.

svn co https://smplayer.svn.sourceforge.net/svnroot/smplayer smplayer

For smtube run in its folder:
./get_svn_revision.sh
Back to top
View user's profile Send_private_message 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Sun 16 Sep 2012, 14:51    Post_subject:  

thanks for the info i am on it now cuzz my mom needs it for her old pc to view youtube.
Back to top
View user's profile Send_private_message AIM YIM 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Sun 16 Sep 2012, 16:44    Post_subject:  

smplayer-r4415 and smtube-r4415 are in my repo, compiled in precise beta5 against qt 4.8.2 http://www.mediafire.com/?mpv88jj3bp0m3
Back to top
View user's profile Send_private_message AIM YIM 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 16 Sep 2012, 17:09    Post_subject:  

Heh. Qmplay2 has fixed the youtube playing also. Qmplay2 needs a bit more work to get compile.
I have now dpup fixed source, it might work for others also. Qmplay2 needs opengl included Qt4 libs ---> libQtOpenGL and it uses ffmpeg as backend. I disabled pulseaudio dependency from source and I had to remove calls to libass flushevents, becauce my libass dev didnt like them. I can upload the qmplay2 hacked source and some tips if someone else wants to give it a go.
qmplay2-plays-youtube-also.jpg
 Description   
 Filesize   45.09 KB
 Viewed   1231 Time(s)

qmplay2-plays-youtube-also.jpg

Back to top
View user's profile Send_private_message 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Sun 16 Sep 2012, 17:47    Post_subject:  

pemasu post a link to your source, i will give it a try.
Back to top
View user's profile Send_private_message AIM YIM 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 16 Sep 2012, 17:54    Post_subject:  

I will open tomorrow thread in Compiling section...later...for Qmplay2.
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Sun 16 Sep 2012, 19:32    Post_subject:  

Hah!

You have just got to love open source! Cool
Code:
diff -rupN trunk/src/retrievevideourl.cpp umplayer-0.97-patched/src/retrievevideourl.cpp
--- trunk/src/retrievevideourl.cpp   2011-12-31 01:00:29.000000000 +1000
+++ umplayer-0.97-patched/src/retrievevideourl.cpp   2012-09-17 09:15:02.613611654 +1000
@@ -64,9 +64,13 @@ void RetrieveVideoUrl::gotVideoPage(QNet
     QStringList::iterator stIt = codeList.begin();
     foreach(QString code, codeList)
     {
-        code.remove(0, 4);
         QUrl url(code);
-        urlMap[url.queryItemValue("itag").toInt()] = code.remove(QRegExp("&itag=\\d+$"));
+        int itag = url.queryItemValue("itag").toInt();
+        //qDebug("itag: %d", itag);
+        code.remove(QRegExp("itag=(\\d+)&url="));
+        code.replace("&sig=", "&signature=");
+        urlMap[itag] = code;
+        //qDebug("code: '%s'", code.toUtf8().constData());
     }
     /*regex.setPattern("\\\"t\\\"\\s*:\\s*\\\"([^\\\"]*)");
     regex.indexIn(replyString);


Only 1 simple block, stole it directly out of smplayer. I just like that umplayer has it integrated.
umplayer_youtube_120917.patch.gz
Description 
gz

 Download 
Filename  umplayer_youtube_120917.patch.gz 
Filesize  528 Bytes 
Downloaded  399 Time(s) 
um_it_works.png
 Description   umplayer can now play youtube again
 Filesize   223.79 KB
 Viewed   1151 Time(s)

um_it_works.png


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 17 Sep 2012, 01:00    Post_subject:  

Thanks 01micko. Youtube works now in Umplayer....with your patch.
Back to top
View user's profile Send_private_message 
vovchik


Joined: 23 Oct 2006
Posts: 1285
Location: Ukraine

PostPosted: Mon 17 Sep 2012, 03:48    Post_subject:  

@ 01micko

Brilliant!

@ pemasu

Could you post an updated binary here? OR elsewhere?

Many thanks, guys.

With kind regards,
vovchik
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Mon 17 Sep 2012, 07:35    Post_subject:  

Umplayer Slacko bins posted for slacko-530-533 and slacko-535+BETA

~

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0684s ][ Queries: 13 (0.0043s) ][ GZIP on ]