Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 15:57
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[Résolu] Toutou: problème avec carte PCMCIA Netgear GA511
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
RIKIKI

Joined: 25 Sep 2012
Posts: 6

PostPosted: Tue 25 Sep 2012, 11:05    Post subject:  [Résolu] Toutou: problème avec carte PCMCIA Netgear GA511
Subject description: Quel Driver pour ma config ?
 

Bonjour,

J'ai installé Toutou 4.3.1 sur un portable Toshiba Satellite 2140cds avec une carte PCMCIA Netgear GA511. D'après mes recherches, le chipset est un rtl8169/8110.
Les diodes de la carte ne s'allument pas car le driver ne doit pas être le bon. L'assistant réseau indique: "Toutou ne voit aucune interface éthernet active" et lorsque je vais voir la liste des modules, il existe un r8169 mais de type PCI.
Comment puis-je faire pour faire fonctionner mon matériel?

Je suis un utilisateur Linux débutant.

Last edited by RIKIKI on Wed 03 Oct 2012, 03:02; edited 1 time in total
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1676

PostPosted: Thu 27 Sep 2012, 08:50    Post subject:  

Bonjour RIKIKI,

Quote:
il existe un r8169 mais de type PCI.


Bien que ce soit un driver PCI il devrait fonctionner en pcmcia, j'ai fait fonctionner plusieurs cartes pcmcia comme ça !

(Par contre ce n'est pas valable avec un driver USB !).

Cordialement,
Médor.
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 27 Sep 2012, 11:37    Post subject:  

Hello,
En dernier recours, si tu ne parviens pas à trouver le pilote LINUX, il y a toujours la possibilité d'utiliser le pilote windows avec "ndiswrapper". La carte PCMCIA branchée sur mon vieux portable Medion MID 2020 n'a jamais fonctionné autrement car je ne suis pas parvenu à trouver le pilote LINUX: celui que m'installe Puppy, dont le nom pourrait laisser entendre que c'est le bon, ne fonctionne pas! Il faut donc le "blacklister" avant d'installer le pilote windows. Il y a déjà des fils sur le Forum, qui détaillent pas à pas la marche à suivre.

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
RIKIKI

Joined: 25 Sep 2012
Posts: 6

PostPosted: Sat 29 Sep 2012, 13:47    Post subject:  

Merci pour la piste.
J'ai fait une recherche et l'on parle de "blacklister" via le bootmanager. Le problème est que je ne le trouve pas dans les menus cités.
Comment le lancer SVP?
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sun 30 Sep 2012, 05:56    Post subject:  

Hello,
Quote:
"Toutou ne voit aucune interface Ethernet active"
C'est normal! Ta machine est sans doute équipée d'une interface pour une connexion filaire mais qui n'est actuellement pas reliée au réseau: Pour Toutou elle est bien présente mais pas "active". Maintenant, lorsque tu cliques sur l’icône "Connexion", dans la liste des interfaces détectés, est-ce que la connexion sans fil wlan est présente? Si c'est le cas, Toutou l'a identifiée mais a chargé un pilote qui ne fonctionne pas. Il faut donc, dans un premier temps, le "blacklister". Avec bootmanager il y a moyen de le faire facilement. Ensuite, tu ouvres l'assistant réseau et tu cliques sur "Charger module" puis sur l'onglet ndiswrapper, etc... Trouve un pilote XP mais pas Vista ou W7, car ndiswrapper ne fonctionne pas avec... En général ce pilote se trouve sur le CD livré avec la carte.
Même processus si ta carte n'est pas listée. Après redémarrage de X, elle devrait figurer dans la liste... et être fonctionnelle.

Cordialement.
112708_502x370_easyshot.png
 Description   
 Filesize   27.36 KB
 Viewed   447 Time(s)

112708_502x370_easyshot.png

112421_429x664_easyshot.png
 Description   
 Filesize   44.54 KB
 Viewed   448 Time(s)

112421_429x664_easyshot.png


_________________

Back to top
View user's profile Send private message Visit poster's website 
RIKIKI

Joined: 25 Sep 2012
Posts: 6

PostPosted: Mon 01 Oct 2012, 15:23    Post subject:  

Quote:
Maintenant, lorsque tu cliques sur l’icône "Connexion", dans la liste des interfaces détectés, est-ce que la connexion sans fil wlan est présente?

Non: "Aucune interface réseau détectée" (au passage, il s'agit d'une connexion filaire).

J'ai mis les modules en liste noire les uns après les autres jusqu'à les avoir tous ajoutés et redémarré sans succès. Testé les pilotes de Windows : celui de XP semble valide mais ça ne fonctionne pas.

Je suis sûr que la carte fonctionne car je l'ai déjà utilisée sous Windows 98.

Sur le site Realtek j'ai récupéré le pilote Linux:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PFid=4&Level=5&Conn=4&ProdID=8&DownTypeID=3&GetDown=false&Downloads=true
Il faut le compiler. En suivant le README :

make clean modules

je bute sur l'erreur:

make: *** /lib/modules/2.6.30.5/build: Aucun fichier ou répertoire de ce type

Quelle en est la raison?
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 02 Oct 2012, 06:58    Post subject:  

Hello,
Quote:
(au passage, il s'agit d'une connexion filaire).
Désolé, la mienne est une carte wifi et que je ne savais pas qu'il existait aussi des cartes PCMIA rj45 Ethernet: Le problème reste le même!
Quote:
J'ai mis les modules en liste noire les uns après les autres jusqu'à les avoir tous ajoutés
Shocked Shocked Quels modules? Ajoutés où?

Pour pouvoir compiler il faut que tu télécharges/installes un fichier sfs de travail appelé => "devx_431.sfs". La compilation n'est pas si compliquée que ça mais ce n'est pas aisé non plus...
Fais des essais et reviens nous dire...

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
RIKIKI

Joined: 25 Sep 2012
Posts: 6

PostPosted: Tue 02 Oct 2012, 09:10    Post subject:  

Quote:
Quote:
J'ai mis les modules en liste noire les uns après les autres jusqu'à les avoir tous ajoutés
Shocked Shocked Quels modules? Ajoutés où?
Comme tu m'as dis plus haut:
Quote:
... celui que m'installe Puppy, dont le nom pourrait laisser entendre que c'est le bon, ne fonctionne pas! Il faut donc le "blacklister" avant d'installer le pilote windows.
puis comme sur l'image: "Cliquer ici pour mettre un module en liste noire". Les passer de la colonne de gauche à la colonne de droite. C'était pas ça?
Quote:
Pour pouvoir compiler il faut que tu télécharges/installes un fichier sfs de travail appelé => "devx_431.sfs".
C'est déjà fait. Avant il ne connaissait pas la commande "make" mais maintenant c'est l'erreur qui me bloque.

Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1676

PostPosted: Tue 02 Oct 2012, 09:47    Post subject:  

Bonjour,

Argolance wrote:
... un fichier sfs de travail appelé => "devx_431.sfs"

Puisque c'est un module du kernel il faut aussi le SFS des sources du kernel !

Curieux que le module existant ne fonctionne pas !

Ci-joint le nouveau module compilé pour Toutou-431, Lucid-528Retro : K2.6.30.5
ainsi que celui pour Lucid-528 K2.6.33.2

Ce module remplace et donc écrase le module r8169.ko existant !

Vu le nombre de bidouilles, refaire en premier un nouveau "pupsave" en démarrant en pfix=ram depuis le LiveCD, ne pas connecter la carte pcmcia installer le pet, rebooter en chargeant bien le nouveau "pupsave" avec la carte pcmcia connectée.


Cordialement,
Médor.
r8169-6.017.00-k2.6.30.5.pet
Description 
pet

 Download 
Filename  r8169-6.017.00-k2.6.30.5.pet 
Filesize  17.98 KB 
Downloaded  126 Time(s) 
r8169-6.017.00-k2.6.33.2.pet
Description 
pet

 Download 
Filename  r8169-6.017.00-k2.6.33.2.pet 
Filesize  16.44 KB 
Downloaded  122 Time(s) 
Back to top
View user's profile Send private message 
RIKIKI

Joined: 25 Sep 2012
Posts: 6

PostPosted: Tue 02 Oct 2012, 15:30    Post subject:  

Merci Médor de m'avoir compilé le module mais pas de pot... ça ne fonctionne toujours pas.
Je sais plus quoi faire...
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1676

PostPosted: Tue 02 Oct 2012, 17:11    Post subject:  

Bonsoir RIKIKI,

Voir ce fil : http://www.murga-linux.com/puppy/viewtopic.php?p=185302#185302

A priori ce n'est pas le module, mais il doit s'agir d'un problème d'IRQ et du choix au niveau du bios pour le support PCMCIA en cardbus 16 Bits non pas en pc card...

Cordialement,
Médor.
Back to top
View user's profile Send private message 
RIKIKI

Joined: 25 Sep 2012
Posts: 6

PostPosted: Wed 03 Oct 2012, 02:51    Post subject:  

Total respect, Médor !

Je n'aurais jamais pensé à cette option dans le BIOS surtout que par défaut elle est sur auto-détect. Il faut effectivement choisir "16 bits" et la carte s'allume avant même le chargement du système.
De mémoire, il me semble qu'elle s'allumait lors d'un essai en live avec Kaella, mais sans obtenir de connexion. Je n'avais pu aller plus loin car la machine ramait dans le potage...

Tu as quand même eu un bon réflexe en faisant une recherche dans ce forum avec le modèle précis. J'en ai passé des heures à chercher et un peu plus je réinstallais Windows...

Un grand merci ainsi qu'à Argolance pour votre aide et à tous ceux qui ont bossé sur Toutou !
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1825
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Wed 03 Oct 2012, 05:55    Post subject:  

Hello,
Quote:
Un grand merci ainsi qu'à Argolance pour votre aide et à tous ceux qui ont bossé sur Toutou !
Bravo Médor... Et bon Toutou à RIKIKI!
_________________

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0810s ][ Queries: 13 (0.0043s) ][ GZIP on ]