Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 29 Nov 2014, 05:00
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
MPlayer_gui compiling problems - Solved
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Sun 30 Sep 2012, 19:12    Post subject:  MPlayer_gui compiling problems - Solved
Subject description: Xshape not found
 

Hi,

I was trying to compile mplayer from svn with the following options:
Code:

   ./configure --prefix=/usr \
               --confdir=/etc/mplayer \
               --enable-gui \
               --enable-runtime-cpudetection \
               --enable-menu \
               --enable-xmms \
               --disable-mencoder \
               --disable-ossaudio \
               --disable-arts \
               --disable-esd \
               --disable-pulse \
               --disable-jack \
               --disable-openal \
               --disable-hardcoded-tables \
               --disable-profile \
               --disable-sighandler \
               --disable-crash-debug \
               --enable-xinerama \
               --disable-ffmpeg_a


but I get the following error message from the terminal
Code:
Error: The GUI requires the X11 extension XShape (which was not found).


If I use --disable-menu and --disable-gui, then mplayer will compile, but
it won't have a frontend.

Pfind finds shape.h, and I don't know why the compiler can't seem to find it. Sad

Last edited by Tman on Wed 03 Oct 2012, 17:08; edited 1 time in total
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1885
Location: wales

PostPosted: Tue 02 Oct 2012, 12:57    Post subject:  

hi Tman

i found this on an ubuntu post
Quote:
Add --enable-xshape for compiling. Not a clue why but it works.

thanks a lot. worked like a charm.


worth a try

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Tue 02 Oct 2012, 22:25    Post subject:  

666philb,

thanks for the tip. Strange...in the configure options, it says that xshape is autodetected, I guess that function wasn't working too well. I added --enable-xshape,
and it gave me an error message saying it needs zlib. So I installed zlib from the wary repository, along with the DEV files. Mplayer compiled, but I still get no gui...something else is wrong.

Well ... at least I'm getting closer. I will add more specific ./configure options, now that I realize that autodetect doesn't always work.
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Wed 03 Oct 2012, 17:08    Post subject:  

Okay, I found the problem.

I compiled the pet using a modified buildpet script.
Buildpet optimizes the .png files through optipng ..this is usually a good thing.
But with Mplayer, it seems that using optipng (and maybe advancecomp also)
damages the theme, and the gui does not work.

Luckily, I have backups of the Mplayer themes. I injected the original theme back into the malfunctioning pet, and
the gui appears ..yeeessss! Smile

So it seems that 666philb's advice for the configure otions was correct.

Thanks, 666philb!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Compiling
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0486s ][ Queries: 12 (0.0039s) ][ GZIP on ]