Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 10:29
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to configure psip for diamondcard?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
treeplanter

Joined: 09 Sep 2008
Posts: 21

PostPosted: Sat 29 May 2010, 07:22    Post_subject:  How to configure psip for diamondcard?  

anyone have luck getting psip going using diamondcard ..I dont see a line to enter the pin for diamond card in the config file.And I'm not sure that psip is working with the sound card ...Micron transport zx....128mb mem. I've got Twinkle installed and it works ...but the echo is driving my friends crazy.I can't hear it on my end, but on the other end of a land line call is apparently very bad....... any other VOIP suggestions??
Back to top
View user's profile Send_private_message 
gazb

Joined: 09 Jul 2008
Posts: 25
Location: Australia Sydney

PostPosted: Sun 06 Jun 2010, 00:25    Post_subject: microphone  

If you get echo then your microphone is set too loud, you need to make it as quiet as possible then bring it up until you can hear OK without echo.
Back to top
View user's profile Send_private_message Visit_website 
watchdog

Joined: 28 Sep 2012
Posts: 586

PostPosted: Fri 28 Sep 2012, 14:25    Post_subject: psip configure  

Excuse me my bad english. Just yesterday I get working psip32 with Ekiga Call out or Diamond Card in wary 5.3 and slacko 5.3.3. I post my /root/.psip.conf:

{
"account": {
"sip-url": "sip:ID@sip.diamondcard.us",
"registrar": "sip:sip.diamondcard.us",
"realm": "*",
"user": "ID",
"password": "PIN",
"use-srtp": 0,
"proxy": "sip:sip.diamondcard.us"
},
"settings": {
"ring-command": "",
"loglevel": 1,
"help-command": "",
"call-timeout": "15",
"minimise-tray": 0,
"auto-register": 0,
"ringtone-file": "/usr/share/audio/beep_high.wav",
"im-beep": 0,
"im-command": "",
"activity-log": 1,
"sampling-rate": -1,
"max-calls": "2",
"sip-port": "5060",
"public-ip": "",
"stun-server": "",
"disable-vad": 0,
"enable-ice": 0,
"turn-server": "",
"turn-user": "",
"turn-password": "",
"turn-realm": "",
"turn-use-tcp": 0,
"disable-tcp": 1,
"disable-optional-srtp": 0,
"audio-in": "default",
"audio-out": "default"
},
"buddy-categories": []
}

Substitute ID and PIN with the real your ID and PIN of your account with Diamond Card. With some routers you have to substitute the line:

"proxy": "sip:sip.diamondcard.us"

with

"proxy": ""

Dial and add buddies in the way:

sip:0039nationalnumber@sip.diamondcard.us

Substitute 0039 with your desired international prefix (0039 for Italy...).

Best Regards
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 586

PostPosted: Wed 03 Oct 2012, 01:54    Post_subject: How to configure psip for diamondcard?  

For NAT-traversal I experimented another way to do the job with dummy connections. New /root/.psip.conf:

{
"account": {
"sip-url": "sip:ID@sip.diamondcard.us",
"registrar": "sip:sip.diamondcard.us",
"realm": "*",
"user": "ID",
"password": "PIN",
"use-srtp": 0,
"proxy": "sip:sip.diamondcard.us"
},
"settings": {
"ring-command": "",
"loglevel": 1,
"help-command": "",
"call-timeout": "15",
"minimise-tray": 0,
"auto-register": 0,
"ringtone-file": "/usr/share/audio/beep_high.wav",
"im-beep": 0,
"im-command": "",
"activity-log": 1,
"sampling-rate": -1,
"max-calls": "2",
"sip-port": "5060",
"public-ip": "IP",
"stun-server": "stunserver.org",
"disable-vad": 0,
"enable-ice": 0,
"turn-server": "",
"turn-user": "",
"turn-password": "",
"turn-realm": "",
"turn-use-tcp": 0,
"disable-tcp": 1,
"disable-optional-srtp": 0,
"audio-in": "default",
"audio-out": "default"
},
"buddy-categories": []
}

Replace ID and PIN with ID and PIN of your account at Diamondcard. IP is the external IP of the NAT gateway: you can read it by clicking over the monitor of connection low-ritght of the desktop. Enjoy.
Back to top
View user's profile Send_private_message 
Sylvander

Joined: 15 Dec 2008
Posts: 3447
Location: West Lothian, Scotland, UK

PostPosted: Wed 03 Oct 2012, 05:04    Post_subject: Re: How to configure psip for diamondcard?  

1.
treeplanter wrote:
any other VOIP suggestions??

(a) I bought this Cisco Phone Adapter with 2 Ports for Voice-over-IP (UK)
Then...

(b) I registered with sipgate.
Chose a phone area code [the same as my local code].
Or could have chosen 0845, or 1 other [forget which].
SIPgate allocated me the rest of my number.
[So far] I haven't charged my account by making a payment, so my account is only passive [only receive calls] at this time.
I have a couple of DECT [wireless] phones connected to this setup.
The PhoneAdapter->router->modem must all be [connected and] powered-on for me to receive calls.
Only my family members know this number, so if this phone rings I KNOW it's a family member calling.

(c) If I charge the SIPgate account I'd [for example] be able to make low-cost international calls.

(d) The quality of the internet calls is not as clear/crisp->[too much bass, little treble] as my Virgin landline, but otherwise it's OK.
Tried swapping the BT wired phones with the wireless, but still wasn't as good as the Virgin landline.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0637s ][ Queries: 12 (0.0114s) ][ GZIP on ]