Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Oct 2014, 07:03
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
taper caractères spéciaux esperanto
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
gilloraymondo

Joined: 03 Dec 2011
Posts: 255

PostPosted: Wed 03 Oct 2012, 12:21    Post subject:  taper caractères spéciaux esperanto  

Bonjour,
J'avais pu trouver comment taper les caractères spéciaux espagnols sur toutou linux et lucid puppy, simplement en tapant simultanément sur alt gr et
~ pour obtenir le ñ
? pour l'obtenir à l'envers
! pour l'obtenir à l'envers
^ puis la voyelle concernée pour l'avoir avec un accent aigu.
pour mémoire, il fallait aller dans fichiers sur etc/X11/xkb/symbols/pc/fr et changer les touches AE2, AD11, AB07 et AB10. Et le tour était joué.

je pensais pouvoir faire pareil pour taper les caractères spéciaux en esperanto. Eh bien non !!!
Là, il me faut les c, g, h, j, et s avec accent circonflexe tant en minuscule qu'en majuscule, et le u avec un accent comme un trait mais arrondi vers le bas au milieu.
Si on appuie sur l'accent circonflexe et les lettres voulues, on n'obtient pas les lettres en cause avec l'accent circonflexe.
Donc, je suis allé voir dans fichiers sur etc/X11/xkb/symbols/pc/fr, pour voir si je pouvais rectifier les touches voulues : AB03, AC02, AC05, AC06, AC07, et AD07.
J'avais pensé utiliser la 3ème dénomination (touche alt gr) pour les minuscules accentuées, et la 4ème dénomination (touche alt gr + maj) pour les majuscules accentuées.
Sur le 1er tableau sur lequel il n'y a pas de problème pour rectifier les touches pour l'espagnol, les touches voulues sont absentes.
Si je les ajoute, ça ne fait rien.
Au dessous, je trouve un autre tableau "alternative", ou je trouve les touches, mais si je change quelque chose, ça ne fait rien.
Quelqu'un a une idée ?
Cordialement
Back to top
View user's profile Send private message 
Burunduk

Joined: 21 Aug 2011
Posts: 62

PostPosted: Fri 05 Oct 2012, 00:22    Post subject:  

Saluton! Mi ne parolas france, sed povas esti vi komprenos.

Wikipedia wrote:

La klavarofasono Kanada plurlingva norma estas klavarofasono, kiu ebligas relative facile aperigi (per kombinoj de unu ĝis tri aliaj klavoj) ankaŭ la supersignajn literojn de Esperanto. Oni povas premi la unuan klavon dekstre de P kaj poste premu c/g/h/j/s por ĉ/ĝ/ĥ/ĵ/ŝ. Oni povas premi, samtempe kun DEKSTRA-REG kaj DEKSTRA-MAJ, la trian klavon dekstre de L kaj poste premu u por ŭ.[¹]


Ĉi tio koncernas ankaŭ la norman AZERTY klavaron kun la fr(basic) aranĝo:

^ c -> ĉ
^ Shift+c -> Ĉ
AltGr+ù c -> ĉ
AltGr+Shift+* u -> ŭ

(En la tabelo: dead_circumflex por ĉ... kaj dead_breve por ŭ.)

En Lucid Puppy, se vi ŝanĝis ion en la tabelo, vi devus forigi la plej nova(j)n dosiero(j)n en /var/lib/xkb antaŭ vi aldonos la ŝanĝitan aranĝon en la Xkb Configuration Manager. Tiu dosiero (.xkm) estas uzata anstataŭ la fonta tabelo kaj estas rekreata el la fonto nur se la malnova forestas. (Ne necesas tio en Slacko.)
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 255

PostPosted: Wed 10 Oct 2012, 08:01    Post subject:  

Bonjour,
Bon, pour que tout le monde comprenne, je traduis ci dessous.
Mais je ne comprends rien à ces explications et ne sais toujours pas comment faire !!!!
Si quelqu'un peut m'aider ....

Merci d'avance

"Bonjour! Je ne parle pas français, mais peut être que vous comprendrez.

Wikipedia écrit:

La norme canadienne klavarofasono multilingue est klavarofasono, ce qui permet relativement facilement d'écrire (avec des combinaisons de une à trois autres touches) aussi les lettres accentuées en anglais. Vous pouvez appuyer sur la première touche à droite de P, puis appuyez sur c / g / h / j / s à environ / G / H / J / S. Vous pouvez appuyer en même temps avec une Reg droite et vers la droite Maj, la troisième touche à droite de L et appuyez sur u pour u. [¹]


Cela concerne également le clavier AZERTY standard avec le fr (de base) Format:

^ c -> ĉ
^ Shift+c -> Ĉ
AltGr+ù c -> ĉ
AltGr+Shift+* u -> ŭ

(Dans le tableau: dead_circumflex environ ... et dead_breve pour u.)

Dans Puppy Lucid, si vous avez changé quelque chose dans le tableau, vous devez supprimer le plus récent fichier dans / var / lib / xkb avant d'ajouter la disposition modifié dans le Gestionnaire de configuration xkb. Ce fichier (. XKM) est utilisé à la place de la table source et n' est recrée à la source que si les premiers sont pas. (Vous n'avez pas besoin de Slacko.)"

Wouaaahoouuu. Tout ça pour moi ce n'est ni français ni esperanto, c'et du chinois !!!!! Quelqu'un comprend ?
Back to top
View user's profile Send private message 
Burunduk

Joined: 21 Aug 2011
Posts: 62

PostPosted: Wed 10 Oct 2012, 23:57    Post subject:  

Well, I happened upon your post with the familiar word in the title and responded in this "foreign" subforum only because no one else did, and I supposed that you might know Esperanto. It seems you have made your translation with the Google Translate — I tried this tool to translate my post into French with the same result. Then I had it translated into English. Apparently the distro name alone survived the procedure. If you don't mind talking with strangers, I'll try to write in English this time. Maybe the Google robot can translate better in this direction, it can make your posts readable for me after all. Sure, you can wait for someone else to respond to you.

Assuming you are using Lucid Puppy and the standard French keyboard (AZERTY) you should be able to type the special Esperanto characters. You shouldn't modify the /etc/X11/xkb/symbols/pc/fr file. The basic layout already has everything you need.
So, if you can type "^" following by "e" and you receive "ê", then you should be able to type "^" following by "c" to get "ĉ". If the letter "ĉ" doesn't appear this way then you probably don't have a Unicode font installed (or you haven't it selected in your text editor). Try to use the Liberation font.
It is also possible that your system locale is fr_FR. You may want to change it to fr_FR.utf8 (Menu -> Desktop -> Country settings -> Chooselocale country localization -> [v] UTF-8 encoding).

If you have modified the symbol file nevertheless and you can't make it work, try to delete the most recent file or several files in the /var/lib/xkb directory. These are the compiled keymaps used instead of your modified source file. In other Puppy variants (e.g. Slacko) this directory is empty. It is also necessary to remove and re-add the modified layout for changes to take effect.
To test your new layout you can use the setxkbmap command, but this setting will last till the next X restart only. (Try setxkbmap -help for more info.)

the Google Translate wrote:
Eh bien, je suis tombé sur votre post avec le mot familier dans le titre et a répondu à cet «étranger» subforum seulement parce que personne d'autre ne fait, et je suppose que vous savez peut-être l'espéranto. Il semble que vous avez fait votre traduction avec le Google Translate - J'ai essayé cet outil pour traduire mon message en français avec le même résultat. Ensuite, j'ai fait traduire en anglais. Apparemment, le nom seul a survécu distro la procédure. Si vous ne me dérange pas de parler avec des inconnus, je vais essayer d'écrire en anglais cette fois. Peut-être que le robot Google ne peut mieux traduire dans cette direction, il peut rendre vos messages lisibles pour moi après tout. Bien sûr, vous pouvez attendre que quelqu'un d'autre s'en charge pour vous.

En supposant que vous utilisez Puppy Lucid et le clavier standard français (AZERTY), vous devriez être capable de taper les caractères spéciaux espéranto. Vous ne devez pas modifier le fichier / etc/X11/xkb/symbols/pc/fr. La structure de base a déjà tout ce dont vous avez besoin.

Donc, si vous pouvez taper "^" ci-dessous par "e" et vous recevez "ê", alors vous devriez être capable de taper "^" suivante "c" pour obtenir "ĉ". Si la lettre "ĉ" ne s'affiche pas de cette façon, alors vous n'avez probablement pas une police Unicode installé (ou que vous ne l'avez pas sélectionné dans votre éditeur de texte). Essayez d'utiliser la police Liberation.
Il est également possible que vos paramètres régionaux système est fr_FR. Vous pouvez le changer à fr_FR.utf8 (Menu -> Bureau -> Paramètres de pays -> pays de localisation Chooselocale -> [v] encodage UTF-8 ).

Si vous avez modifié le fichier de symboles et pourtant vous ne pouvez pas le faire fonctionner, essayez de supprimer le fichier le plus récent ou plusieurs fichiers dans le répertoire / var / lib / xkb. Ce sont les keymaps compilées utilisées à la place de votre fichier source modifié. Dans des variantes de Puppy (par exemple Slacko), ce répertoire est vide. Il est également nécessaire de supprimer et rajouter la disposition modifiée pour que les modifications prennent effet.
Pour tester votre nouvelle mise en page, vous pouvez utiliser la commande setxkbmap, mais ce paramètre durera jusqu'à la prochaine redémarrer X seulement. (Essayez setxkbmap -help pour plus d'info.)
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 255

PostPosted: Thu 11 Oct 2012, 13:27    Post subject:  

Bonjour Burunduk,
Et merci
Je ne sais pas quelle est ta langue, moi je parle français, anglais et espagnol. Mais ici c'est en français, donc pour que tout le monde comprenne, j'écris en français
Sur toutou linux, ça ne fonctionne pas.
Mais sur Lucid Puppy, tout fonctionne très bien.
- touche ^ puis le c ou le g ou le h ou le j ou le s.
Très simple !!!
Pour l'accent breve sur le u : simultanément touche alt gr + shift+ *, puis u.
Amicalement et merci encore

Hi Burunduk
And thank you very much
I don't know what is your language, but me, I speak french, english and spanish.
But here it's in french, so, to get everyone understanding, I write in french.
With toutou linux (the puppy linux french version) it doesn't work
But with Lucid Puppy, everything works very well.
^ and then c or g or h or j or s
Very simple !!!
For the breve accent on the u : at the same time alt gr + shift + *, and then u
Friendly yours and thank you again
Back to top
View user's profile Send private message 
Burunduk

Joined: 21 Aug 2011
Posts: 62

PostPosted: Fri 12 Oct 2012, 03:51    Post subject:  

Once again English proved to be a better choice for the international communication. I should have made my first post less cryptic.

I don't know why there is a problem in Toutou. If it is based on Puppy 4.3.1, it should work. Puppy 4.3.1 has exactly the same /etc/X11/xkb/symbols/pc/fr file. It could be a wrong layout variant. The basic layout is not on the list in the Xkb configuration manager. To select it, it is necessary to remove the variant in use.

Translated by Google Translate:

Une fois de plus anglais s'est avéré être un meilleur choix pour la communication internationale. J'aurais dû faire mon premier post moins cryptique.

Je ne sais pas pourquoi il ya un problème dans Toutou. Si elle est basée sur Puppy 4.3.1, cela devrait fonctionner. Puppy 4.3.1 est exactement le même fichier /etc/X11/xkb/symbols/pc/fr. Il pourrait s'agir d'une variante de mise en page tort. La structure de base n'est pas sur la liste dans le gestionnaire de configuration Xkb. Pour le sélectionner, il est nécessaire de retirer la variante utilisée.
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 255

PostPosted: Fri 12 Oct 2012, 11:03    Post subject:  

Bonjour,
OK, je vais essayer de nouveau, mais j'ai aussi besoin des caractères spéciaux espagnols !!!
Hi
OK, I'm going to try again, but I need too, the specials letters in spanish !!!!
Merci encore
Thank you again
Back to top
View user's profile Send private message 
gilloraymondo

Joined: 03 Dec 2011
Posts: 255

PostPosted: Fri 12 Oct 2012, 11:32    Post subject:  

Rebonjour,
Je confirme : aucun des caractères spéciaux esperanto ne fonctionne avec toutou linux 431 clavier azerty fr
Nous verrons avec le nouveau toutou linux qui devrait sortir le mois prochain
Amicalement
Hi
I confirm : none of the specials esperanto letters work with toutou linux 431, french azery fr keybord
We'll see next month with the brand new toutou linux version
Friendly yours
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0817s ][ Queries: 12 (0.0082s) ][ GZIP on ]