Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 03:46
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Laptop's keyboard is unusable: NumLock is always ON.
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
zeiz

Joined: 03 Oct 2012
Posts: 18

PostPosted: Thu 11 Oct 2012, 11:33    Post subject:  Laptop's keyboard is unusable: NumLock is always ON.  

I finally got Classic Puppy (2.14xTop10) running fine in ext2 partition on my ThinkPad 560E in dual boot with win98.
I still need some adjusting: no internet connection (though eth0 is up), using swap, some other minor things... but I got very weird and very serious problem I've never heard about: my keyboard is not functioning properly. Trying to narrow the issue I found that the problem is NumLock which always turns ON when X is running so I have numbers instead of letters using certain buttons. Pressing Shift-NumLk does nothing.
I tried to find a solution online but found only a couple and those don't work on my system.
The solution is likely connected with X configuring since the problem exists only when X is running. So it's software related. I tried to find file "numlock", program "numlockx" but nothing like that exists in Puppy.
I believe many people are running Puppy on laptops and I couldn't find a solution. This could mean that I'm missing something very obvious but I cannot guess what exactly.
How to permanently disable (always OFF) NumLock on my system?
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2539
Location: Everybody knows this is nowhere...

PostPosted: Thu 11 Oct 2012, 12:26    Post subject:  

Apologies for being away from Puppy at the moment.

Somewhere in the Menu there is a "Personalize Settings" entry. It may also be called "First Boot Wizard" or "Firstrun". Run it. You'll see a little "Welcome to Puppy" splash screen and then some useful configuration options should pop up.

Look for the drop-down menu for keyboard layout or somesuch (it's usually on the left side with the timezone and language settings), and you will find the NumLock checkbox directly underneath. Uncheck that box, and OK out of the wizard, and you should be good to go.

Let us know how it goes!

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
zeiz

Joined: 03 Oct 2012
Posts: 18

PostPosted: Thu 11 Oct 2012, 18:11    Post subject:  

Thanks a lot. Actually I didn't find the Personalize settings and the checkbox but I started over and found the following:
Menu>Setup>Setup Wizards>Mouse/Keyboard Wizard>Key4Button>OK>Options(tab)>Use keyboard LED to show alternative group.
There is a variable grp_led:num and I changed it to grp_led_scroll just to try. After activating I tried to press Shift-NumLck again but led was still on. However after X restarting the led was off and the keyboard typed properly!
Perhaps it's not the right way to do that but it works so far.
Many thanks again!
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2539
Location: Everybody knows this is nowhere...

PostPosted: Thu 11 Oct 2012, 18:18    Post subject:  

Welcome. Glad to be of assistance Very Happy
_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
maik.murks


Joined: 28 Mar 2011
Posts: 331
Location: at home, at work or on holidays

PostPosted: Fri 12 Oct 2012, 03:56    Post subject: Re: Laptop's keyboard is unusable: NumLock is always ON.  

zeiz wrote:
Pressing Shift-NumLk does nothing.

You are pretty well right - pressing <shift><numlock> does usually nothing.
If you want to manually switch the state of numlock then <fn><numlock> does usually the trick.
Hope that helps.

Cheers Wink

Maik.Murks
Back to top
View user's profile Send private message 
zeiz

Joined: 03 Oct 2012
Posts: 18

PostPosted: Fri 12 Oct 2012, 22:12    Post subject:  

Thanks. Of course I tried fn-NumLck too and many other combinations and nothing changed.
I feel it's a kind of magic that finally I got numlock off, I don't realize why it works but as long as it works I don't want to press anything anymore. Laughing
Back to top
View user's profile Send private message 
tallboy


Joined: 21 Sep 2010
Posts: 409
Location: Oslo, Norway

PostPosted: Sat 13 Oct 2012, 20:09    Post subject:  

Shift-NumLock actually activates Mouse_Keys, a builtin function in X that let the keys in the numeric keypad move the cursor and act as a mouse.

tallboy

_________________
True freedom is a live Puppy on a multisession CD/DVD.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0532s ][ Queries: 12 (0.0095s) ][ GZIP on ]