Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 17:38
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Polarpup-005 with Qt4-4.8.0 and Gstreamer libs inbuild
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 33 of 34 [499 Posts]   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34 Next
Author Message
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Sat 14 Apr 2012, 18:57    Post subject:  

I have now discovered that not all embedded audios will play in LO Impress. The one I initially wanted to send you for one or other reasons does not play. I run the one I already send and noted this one played. So, it seems it is OK now. However, is there any other gstreamer packages that you think could be installed yet? I cannot see which packages are already per-installed. From my experience with other distros I know that the bad, good, ugly, base, and alsa gstreamer packages are needed for Libre Office Impress to function well. Is any of these not pre-installed?Type name of new folder
Thanks!
Edited later:
When I was configuring "qtconfig" in consol, I got some warnings about the gstreamer. I have attached a text file listing these warnings. Perhaps this will provide a clue to what is wrong with the installed gstreamer packages.
warning.tar.gz
Description 
gz

 Download 
Filename  warning.tar.gz 
Filesize  1.1 KB 
Downloaded  256 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 15 Apr 2012, 03:10    Post subject:  

Okay. Firstly. You have messed your system with some libs which has broken the libs dependency. Maybe some Qt apps which has dragged incompatible Qt4 libs with it or incompatible gstreamer libs. Those warnings does not come from my installed stuff. They are surely compatible.

Next...the plugin scanner does not work right. I traced the problem. The plugin scanner is in /usr/lib/gstreamer-0.10 folder but....gstreamer expects to find it also from /usr/lib/gstreamer01.0/gstreamer-0.10 folder. Just creating that folder and placing symlink pointing to the existing location fixes the gstreamer stuff finding. the pet which creates that other location is in attached pet.

About my gstreamer and needed dependencies to other libs which gstreamer uses.

I did very exhaustive process by tracking every needed gstreamer plugin and dependent other audio-video libs. I launched clementine at early developing stage and I did add every missing reported dependency. Clementine is very good indicator. It needs and wants most extensive support of gstreamer plugins and other libs without complaining. After my hunting process....I created 2 pets which have all the needed stuff. Doing the same thing with woof specs adding would have been too long process so I created 2 ready pets for them.

I do have good, bad, ugly, alsa, http streaming, etc gstreamer plugins installed. I have in /usr/lib/gstreamer-0.10 folder 190 gstreamer plugins preinstalled. And all the dependent libs and in /usr/lib all the gstreamer base libs which I found needed. Of course for some audio-video formats something might be missing but I didnt find with my tests them.

gstreamer-phono-deps was one of those combined pets. I think I had another one also.
gstreamer-plugin-scanner-fix-0.0.1.pet
Description 
pet

 Download 
Filename  gstreamer-plugin-scanner-fix-0.0.1.pet 
Filesize  414 Bytes 
Downloaded  275 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 15 Apr 2012, 04:02    Post subject:  

marco07.
When you have Polarpup with above gst helper plugin fix and with installation which does not complain about undefined symbols...and you cant get the LO embedded audio working....could you upload that file here or in free uploading service somewhere if it is over 2 Mb and I could try to trace the problem by trying to debug the process.
Back to top
View user's profile Send private message 
marco07

Joined: 18 Jan 2011
Posts: 176
Location: Lincoln , NE, USA

PostPosted: Mon 16 Apr 2012, 08:57    Post subject:  

pemasu wrote:
marco07.
When you have Polarpup with above gst helper plugin fix and with installation which does not complain about undefined symbols...and you cant get the LO embedded audio working....could you upload that file here or in free uploading service somewhere if it is over 2 Mb and I could try to trace the problem by trying to debug the process.


Hi Pemasu:
I think I have found the culprit for messing up with my installed polarpup005. It is either Skype or the gnome-games-lite-2.26.1i486 packages. It seems when I run either of these, then the LO Impress loses its audio. I discovered this by spending quite some times yesterday going through a number of fresh clean manual frugal install polar005. After each install I started adding my desiered application packages one by one, testing the audio in LO Impress, saving the savefile by rebooting, backing up the savefile and repeating the process again with another application package. Right now without skype and gnome-games-lite packages all is OK.
About the file with audio, it now plays in LO IMpress. It is a 2.7 MB tar zipped file.
If you are still interested to test it I can post it somewhere for download. But you would have to tell me where. Because I really do not know of anyplace. Have never done that before. Perhaps I can email it to you if you pm me an email address. I will continue with testing to see how it works out. Will let you know if anything else pops up.
Thanks!
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 16 Apr 2012, 11:03    Post subject:  

Okay. I suppose those apps overwrites stuff or installs incompatible libs.
If you face the problems which you think is because of missing gstreamer plugin or dependent libs...then I am interested. I have sometimes uploaded to some free upload site...but it has been well over one year when I have done it last. So..I cant recommend you any good nowadays place. Maybe someone else could recommend.

But install that plugin scanner fix still.....
Back to top
View user's profile Send private message 
umair

Joined: 25 Dec 2010
Posts: 205
Location: KUST Kohat, Pakistan

PostPosted: Sun 14 Oct 2012, 02:52    Post subject:  

Hi Guys:
I have a question, it is not related to Polar pup but this error i often seen in different puppies. I always use FRUGAL install. The problem is:
when I want to delete previous directory of any frugal installation, it gave me the following Error, then will not able to delete this:
Any Idea? Thnx in Advance:
UMAIR
image-1.png
Description  unable to delete a folder
png

 Download 
Filename  image-1.png 
Filesize  429.95 KB 
Downloaded  474 Time(s) 
Back to top
View user's profile Send private message Yahoo Messenger 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Sun 14 Oct 2012, 03:07    Post subject:  

umair wrote:
Hi Guys:
I have a question, it is not related to Polar pup but this error i often seen in different puppies. I always use FRUGAL install. The problem is:
when I want to delete previous directory of any frugal installation, it gave me the following Error, then will not able to delete this:
Any Idea? Thnx in Advance:
UMAIR


Use logic, my friend, logic !!! Twisted Evil

I see in your picture that you are in /mnt/home/polar.

"Polar pup" (and all Puppy's) has survival instinct!
You cannot ask polar pup to commit suicide, it will not do it. (It is a living thing, you know!) Very Happy
Kill it from another puppy, oh cruel person !!! Razz

Seriously:
from the polar pup CD, type
Code:
puppy pfix=ram
at the first prompt.
locate your "polar" directory and remove the files or folders you wish to remove.

(Please forgive the joke.) Smile

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
umair

Joined: 25 Dec 2010
Posts: 205
Location: KUST Kohat, Pakistan

PostPosted: Sun 14 Oct 2012, 07:11    Post subject:  

musher0 wrote:


Use logic, my friend, logic !!! Twisted Evil

I see in your picture that you are in /mnt/home/polar.

"Polar pup" (and all Puppy's) has survival instinct!
You cannot ask polar pup to commit suicide, it will not do it. (It is a living thing, you know!) Very Happy
Kill it from another puppy, oh cruel person !!! Razz

Seriously:
from the polar pup CD, type
Code:
puppy pfix=ram
at the first prompt.
locate your "polar" directory and remove the files or folders you wish to remove.

(Please forgive the joke.) Smile


Musher0:
Well in that Case I was booted from the directory polar2 instead of polar (You can see in my previous post), also I thought that being a ROOT U can do everything Wink.
Anyways I booted from live USB and this time I deleted the directory without any error.
Thnx for the info:
UMAIR
Back to top
View user's profile Send private message Yahoo Messenger 
musher0


Joined: 04 Jan 2009
Posts: 4231
Location: Gatineau (Qc), Canada

PostPosted: Sun 14 Oct 2012, 08:17    Post subject:  

Hi, UMAIR.

Glad that you have a sense of humour! Smile

To sum up, you cannot delete any file or component of a running Linux while it is using these files or components.

BFN.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
umair

Joined: 25 Dec 2010
Posts: 205
Location: KUST Kohat, Pakistan

PostPosted: Thu 20 Dec 2012, 03:21    Post subject:  

hi pemasu:
Just a quick question.
How to disable auto eth0 setting in polar pup?
Actually I m using polar pup on a system where we use net through proxy server. Every time when I boot the polar pup I have to configure it manually as the polar pup auto eth0 search deletes the previous entries of gateway etc.
Thnx in Advance.
UMAIR
Back to top
View user's profile Send private message Yahoo Messenger 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 20 Dec 2012, 11:43    Post subject:  

Are you using Frisbee and you need manual static ip - gw configuration ?
If I understood right, there is inside Frisbee panel to setup manual static ip address - default gateway etc...

Click Frisbee - choose Configure Network Interfaces and untick Auto DHCP and type in your static parameters.
Back to top
View user's profile Send private message 
umair

Joined: 25 Dec 2010
Posts: 205
Location: KUST Kohat, Pakistan

PostPosted: Fri 21 Dec 2012, 00:04    Post subject:  

pemasu wrote:
Are you using Frisbee and you need manual static ip - gw configuration ?
If I understood right, there is inside Frisbee panel to setup manual static ip address - default gateway etc...

Click Frisbee - choose Configure Network Interfaces and untick Auto DHCP and type in your static parameters.

Thnx for the reply pemasu:
I did as per ur instructions, worked nicely.
I was setting the ip using default network interface Smile
Regards
UMAIR
Back to top
View user's profile Send private message Yahoo Messenger 
umair

Joined: 25 Dec 2010
Posts: 205
Location: KUST Kohat, Pakistan

PostPosted: Fri 21 Dec 2012, 00:05    Post subject:  

pemasu wrote:
Are you using Frisbee and you need manual static ip - gw configuration ?
If I understood right, there is inside Frisbee panel to setup manual static ip address - default gateway etc...

Click Frisbee - choose Configure Network Interfaces and untick Auto DHCP and type in your static parameters.

Thnx for the reply pemasu:
I did as per ur instructions, worked nicely.
I was setting the ip using default network interface Smile
Regards
UMAIR
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 3048
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 27 Nov 2013, 02:13    Post subject: Polarpup now with kernel 3.0.25 (Racy5.3)
Subject description: Brand new QT distro !
 

Pelo, nobody cares ! Sad
Last edited by Pelo on Tue 25 Mar 2014, 11:08; edited 2 times in total
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo


Joined: 10 Sep 2011
Posts: 3048
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 27 Nov 2013, 03:58    Post subject: Sfs Load on the fly 'XnView'
Subject description: Loading a recent version of 'sfs on the fly' solves the matter
 

My brand new Polarpup Racy / I am enjoying it ...
Some little defaults, Polarpup accepts only sfs type 3, not type 4.
Despite that Racy could do it.
Answer (few minutes later)
SFS load on the fly V.1.9.9 works with squasfs type 4, no problem !
Squashfs.jpg
 Description   
 Filesize   16.85 KB
 Viewed   157 Time(s)

Squashfs.jpg

Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 33 of 34 [499 Posts]   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1077s ][ Queries: 13 (0.0224s) ][ GZIP on ]