Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 01:07
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Firefox Font Frustrations (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
bones01

Joined: 11 Aug 2008
Posts: 371
Location: Melbourne, Aus

PostPosted: Thu 20 Oct 2011, 06:07    Post subject:  Firefox Font Frustrations (Solved)
Subject description: Why do they look better on some puppies than others?
 

Hi all,

I've had this problem with a few versions of Puppy, but now the time has come to try and find an explanation. In the images below, you'll see the differences in the fonts on Firefox in 5.2.0 and 5.2.8 My question is, why do the fonts look better in 520? I have checked the preferences in Firefox on both puppies and they match, but obviously 520 is better - particularly on my favourite Forum page.

Is this a Puppy issue or a Firefox issue? Any help would be appreciated.

I'm using Firefox 7.01. I've installed the recommended NVidia driver. I've checked the font files that I can.

Thanks.

Bones
fox on 5.2.8 b.png
Description  Not so good on 528
png

 Download 
Filename  fox on 5.2.8 b.png 
Filesize  333.38 KB 
Downloaded  327 Time(s) 
fox on 5.2.5 b.png
Description  Looks good on 520 (Yes, it is 520. It does look this good on Macpup 525 as well, although some other pages don't. Weird.)
png

 Download 
Filename  fox on 5.2.5 b.png 
Filesize  203.16 KB 
Downloaded  314 Time(s) 

_________________
Dell Latitude D630 running Puppy 5.2.8 frugal, Macpup 525 frugal (if I can get it working again)
Precise Puppy 5.4 live DVD

Last edited by bones01 on Fri 21 Oct 2011, 00:11; edited 1 time in total
Back to top
View user's profile Send private message 
Iguleder


Joined: 11 Aug 2009
Posts: 1872
Location: Israel, somewhere in the beautiful desert

PostPosted: Thu 20 Oct 2011, 06:20    Post subject:  

It's /etc/fonts/local.conf and /etc/fonts/fonts.conf. Copy both from Macpup to Lupu to work around this problem.

I had to edit /etc/fonts/local.conf (or fonts.conf, I don't remember which one exactly) and uncomment the section that disables bitmap fonts to get nice fonts in Firefox and Seamonkey.

_________________
My homepage
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
01micko


Joined: 11 Oct 2008
Posts: 7782
Location: qld

PostPosted: Thu 20 Oct 2011, 07:30    Post subject:  

Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--  Enable sub-pixel rendering -->
   <match target="font">
      <test qual="all" name="rgba">
         <const>unknown</const>
      </test>
      <edit name="rgba" mode="assign"><const>rgb</const></edit>
   </match>

<!-- suggested by 'upnorth' http://murga-linux.com/puppy/viewtopic.php?t=54294&start=15
 Reject bitmap fonts -->
 <selectfont>
  <rejectfont>
   <pattern>
     <patelt name="scalable"><bool>false</bool></patelt>
   </pattern>
  </rejectfont>
 </selectfont>
</fontconfig>


That's Iguleder's ....in Slacko (and Spup)

/etc/fonts/local.conf

bewdiful!
fonts.png
Description  Slacko RC, Seamonkey-2.4.1, pfix=ram :)
png

 Download 
Filename  fonts.png 
Filesize  147.31 KB 
Downloaded  303 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Burn_IT


Joined: 12 Aug 2006
Posts: 958
Location: Tamworth UK

PostPosted: Thu 20 Oct 2011, 07:41    Post subject:  

I keep a directory with the Microsoft core fonts in it and Symlink to it.

A search of the forum will throw up how to do it.

_________________
I can't remember the last time I forgot something!
Back to top
View user's profile Send private message 
bones01

Joined: 11 Aug 2008
Posts: 371
Location: Melbourne, Aus

PostPosted: Fri 21 Oct 2011, 00:13    Post subject:
Subject description: Gotta love this forum
 

01micko wrote:
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--  Enable sub-pixel rendering -->
   <match target="font">
      <test qual="all" name="rgba">
         <const>unknown</const>
      </test>
      <edit name="rgba" mode="assign"><const>rgb</const></edit>
   </match>

<!-- suggested by 'upnorth' http://murga-linux.com/puppy/viewtopic.php?t=54294&start=15
 Reject bitmap fonts -->
 <selectfont>
  <rejectfont>
   <pattern>
     <patelt name="scalable"><bool>false</bool></patelt>
   </pattern>
  </rejectfont>
 </selectfont>
</fontconfig>


That's Iguleder's ....in Slacko (and Spup)

/etc/fonts/local.conf

bewdiful!


Micko, I compared my local.conf with the one you posted and found a couple of differences. I had a few more <--- ---> than this. So I deleted them, and voila, all is great.

I love the help and clear advice I get on this forum from people who know.

Thanks Micko, Iguleder & Burn_IT for your help with this.

Bones.

_________________
Dell Latitude D630 running Puppy 5.2.8 frugal, Macpup 525 frugal (if I can get it working again)
Precise Puppy 5.4 live DVD
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Fri 21 Oct 2011, 01:05    Post subject:  

Yes.. thanks for you work on this Iggy. I copied the entire Slacko /etc/fonts dir over to Racy after deleting the included version to solve a few font issues.
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2435
Location: near here

PostPosted: Tue 31 Jan 2012, 07:36    Post subject:  

this is a really useful tip, does it effect any other programs and puppies?

going to add to wiki Cool

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
darkcity


Joined: 23 May 2010
Posts: 2435
Location: near here

PostPosted: Tue 31 Jan 2012, 11:37    Post subject:  

http://puppylinux.org/wikka/ImproveFontRendering

done - i've added a link for Opera font config - don't know if this is any different?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
bones01

Joined: 11 Aug 2008
Posts: 371
Location: Melbourne, Aus

PostPosted: Thu 01 Nov 2012, 00:58    Post subject: This still works  

I'm trying Precise 5.4 and had the same problem with fonts. Looked up my own name as I knew I'd asked the question before. Glad the solution still works. Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0779s ][ Queries: 13 (0.0154s) ][ GZIP on ]