Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Aug 2014, 03:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
pMusic 4.3.9
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 88 of 123 Posts_count   Goto page: Previous 1, 2, 3, ..., 86, 87, 88, 89, 90, ..., 121, 122, 123 Next
Author Message
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Thu 01 Nov 2012, 14:24    Post_subject:  

01micko wrote:
Maybe a simple dependency check and exit should exist in pequalizer.

@line 25 add
Code:
# dep test
if [ ! -f /usr/lib/alsa-lib/libasound_module_ctl_equal.so ]
  then echo "missing dependencies" && exit
fi
done


Thank you
Sigmund


Download pMusic 3 - Beta here

_________________
Stardust resources

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Thu 01 Nov 2012, 15:11    Post_subject:  

01micko wrote:
Sigmund, I have some useful info for you. I must run MultipleSoundCardWizard to get sound. It then changes my default card in a newly created file /etc/asound.conf. In this case, amixer must be run with the "-c 1" option to the "controls" command.

This is what is found in /etc/asound.conf
Code:
defaults.pcm.card 1
defaults.pcm.device 0

So some routine like this might be needed:
Code:
ASOUNDOPTION=""
if [ -f /etc/asound.conf ];then #see if MultipleSoundCardWizard was used
  CARD=$(head -1 /etc/asound.conf)
  DEFAULTCARD=${CARD##* }
  ASOUNDOPTION="-c $DEFAULTCARD"
fi
VOLUMECONTROL=$(amixer $ASOUNDOPTION controls | grep 'Playback Volume')


Good catch. All calls for amixer in func_mixer is using the -c switch, but in func_config it does not.
This is the code I included in func_config to detect speakers for ACTIVE card. Please test in pMusic-2.9.5
Code:
#To find available speakers, we must first detect soundcard number
if [ "$SOUND_DEVICE" = "auto" ]; then
   if [ -f /etc/asound.conf ]; then #see if MultipleSoundCardWizard was used
      TMP=$(head -1 /etc/asound.conf)
      CARD_NR=${TMP##* }
   else
      TMP="`aplay -l | grep -m 1 -F card`" #grab the first card
      CARD_NR="`echo $TMP | cut -d':' -f1 | cut -d' ' -f2`"
   fi
else
   CARD_NR="`echo $SOUND_DEVICE | cut -d':' -f1 | cut -d' ' -f2`"
fi
export SPEAKERS=`amixer -c $CARD_NR controls | grep 'Playback Volume' | cut -d "'" -f 2 | sed -e "s/ Playback Volume//g" | tr -s ' ' '_' | awk '{print "<item>"$1"</item>"}' | tr -s '_' ' '`




Download pMusic 3 - Beta here

_________________
Stardust resources

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Thu 01 Nov 2012, 15:12    Post_subject:  

Mick
I have updated the beta-post with links to your Precise-stuff.


Thank you
Sigmund


Download pMusic 3 - Beta here

_________________
Stardust resources

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Thu 01 Nov 2012, 15:16    Post_subject:  

Flash wrote:
I did install Pequalizer. It didn't complain about missing libs. Confused
I will add dependencies info in the next pet.


Thank you
Sigmund


Download pMusic 3 - Beta here

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Thu 01 Nov 2012, 15:35    Post_subject:  

pMusic Beta2

All known major bugs are fixed.

Download pMusic 3 - Beta2 here

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3250
Location: Ontario

PostPosted: Thu 01 Nov 2012, 15:54    Post_subject: gtkdialog version  

It wouldn't be hard to put a gtkdialog version warning in the pinstall.sh
using Thunar's method
http://murga-linux.com/puppy/viewtopic.php?t=80340

_____________________________________________
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Thu 01 Nov 2012, 17:07    Post_subject:  

pMusic depends on more than gtkdialog. pmusic --help checks the system...... The dependency check is also available from the Help-menu and by the -D switch.


Sigmund


Download pMusic 3 - Beta2 here

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3250
Location: Ontario

PostPosted: Thu 01 Nov 2012, 17:13    Post_subject:  

You have the menu item in the app that does a good job
of checking dependencies but the pinstall.sh script
is the best place to warn an unsuspecting user.

______________________________________________
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Thu 01 Nov 2012, 22:33    Post_subject:  

Sigmund

There is a major bug with "preferences" in 2.9.5, it doesn't open. I guess I will see one of these from you ... >>> Embarassed <<< ... .. it's a silly syntax error, we all do them sometimes.

The other bug is that the routine to sort out the card needs to run in func_mixer too, else it just runs for the first card. Once I fixed those 2 I could set my card to PCM and the volume control works Smile . Oh, I also changed the call from "cut" to "tr" in original lines 23 and 38 becuse I was getting 2 leading spaces before "Mono:" and cut was looking for field 2, which turned up blank, so better to delete and take any number of spaces out of play I guess.

I'll post the diff and also attach the tarball, the forum loses a bit of formatting.
Code:
diff -ru pmusic.orig/func_config pmusic/func_config
--- pmusic.orig/func_config   2012-11-02 11:59:45.739990245 +1000
+++ pmusic/func_config   2012-11-02 01:19:00.000000000 +1000
@@ -17,7 +17,7 @@
 export SOUND_DEVICES="<item>auto</item>`aplay -l | grep -F 'card ' | awk '{print "<item>"$1" "$2" "$3" "$4" "$5" "$6" "$7" "$8" "$9" "$10"</item>"}'`"
 #To find available speakers, we must first detect soundcard number
 CARD_NR="`echo $SOUND_DEVICE | cut -d':' -f1 | cut -d' ' -f2`"
-if [ "$SOUND_DEVICE" = "auto" ]
+if [ "$SOUND_DEVICE" = "auto" ]; then
    if [ -f /etc/asound.conf ]; then #see if MultipleSoundCardWizard was used
       TMP=$(head -1 /etc/asound.conf)
       CARD_NR=${TMP##* }
diff -ru pmusic.orig/func_mixer pmusic/func_mixer
--- pmusic.orig/func_mixer   2008-01-03 03:19:56.000000000 +1000
+++ pmusic/func_mixer   2012-11-02 12:11:30.579505135 +1000
@@ -2,8 +2,15 @@
 
 [ ! "$SPEAKER" ] && . $HOME/.pmusic/pmusicrc
 #Detect soundcard
-[ "$SOUND_DEVICE" = "auto" ] && SOUND_DEVICE="`aplay -l | grep -m 1 -F card`" #grab the first card
-CARD_NR="`echo $SOUND_DEVICE | cut -d':' -f1 | cut -d' ' -f2`"
+if [ "$SOUND_DEVICE" = "auto" ]; then
+   if [ -f /etc/asound.conf ]; then #see if MultipleSoundCardWizard was used
+      TMP=$(head -1 /etc/asound.conf)
+      CARD_NR=${TMP##* }
+   else
+      TMP="`aplay -l | grep -m 1 -F card`" #grab the first card
+      CARD_NR="`echo $TMP | cut -d':' -f1 | cut -d' ' -f2`"
+   fi
+fi
    
 case $1 in
 -mute)
@@ -16,7 +23,7 @@
    fi
    ;;
 -set_volume)
-   if [ "`amixer -c $CARD_NR get "$SPEAKER" | grep 'Mono:' | cut -d ':' -f 2`" ]; then #mono
+   if [ "`amixer -c $CARD_NR get "$SPEAKER" | grep 'Mono:' | tr -d ' ' |tr -d ':'`" ]; then #mono #2 leading spaces
       amixer -c $CARD_NR set "$SPEAKER" $VOLUME"%" > /dev/null 2>&1
    else
       [ ! "$BALANCE" ] && BALANCE=100 #in case in balance slider is provided in gui
@@ -31,7 +38,7 @@
    fi
    ;;
 -get_levels)
-   if [ ! "`amixer -c $CARD_NR get "$SPEAKER" | grep 'Mono:' | cut -d ':' -f 2`" ]; then
+   if [ ! "`amixer -c $CARD_NR get "$SPEAKER" | grep 'Mono:' | tr -d ' ' |tr -d ':'`" ]; then
       VOL_L=`amixer -c $CARD_NR get "$SPEAKER" | grep -m1 'Left:' | cut -d '%' -f 1 | cut -d '[' -f 2`
       VOL_R=`amixer -c $CARD_NR get "$SPEAKER" | grep -m1 'Right:' | cut -d '%' -f 1 | cut -d '[' -f 2`
       [ $VOL_L = 0 ] && VOL_L=1 #1 to avoid dividing with 0



Another thing, the tray icon is not working in these beta releases.

Oh, one more thing, my fault really, MultipleSoundCardWizard is puppy specific. Other distros may have different formatting of an /etc/asound.conf so maybe the test of head -1 isn't so robust. We'll think on that one eh?

Cheers
pmuxic.diff.tar.gz
Description  yeah, intended typo in filename,, :) ..for pmusic-2.9.5 only
gz

 Download 
Filename  pmuxic.diff.tar.gz 
Filesize  992 Bytes 
Downloaded  271 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11011
Location: Arizona USA

PostPosted: Fri 02 Nov 2012, 00:11    Post_subject:  

Sorry I don't have time to do more thorough testing. Here's my latest result after installing the latest Pmusic and Pequalizer .pets:
Code:
# pmusic
mkdir: can't create directory '/root/.pmusic/history_files': File exists
find: File system loop detected; `/root/.usr/lib/i386-linux-gnu' is part of the same file system loop as `/root/.usr/lib'.


grep:  au -: No such file or directory

/usr/local/pmusic/func_player: line 151: [: =: unary operator expected
/usr/local/pmusic/func_player: line 152: [: =: unary operator expected
#

The Pmusic GUI has a funny thing in the middle that looks like a window into something behind it, and it immediately connects with some internet radio station and starts playing heavy metal music. Not good. Laughing
After I turn that off and delete the station from the playlist, Pmusic sulls up and won't show the mp3 files when I navigate to a folder. Sad
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Fri 02 Nov 2012, 00:31    Post_subject:  

01micko wrote:
here is a major bug with "preferences" in 2.9.5
>>> Embarassed <<<
Worst is that I fixed it, but forgot to upload it again Rolling Eyes


Thank you for very great improvements
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Fri 02 Nov 2012, 00:43    Post_subject:  

Flash
Terminal output: I have similar output at first run. But at second run everything is in place, and I get no outputs - do you?

The 'middle window' is Gtk related and out of my reach. Resize pMusic or show/hide search options, and it's gone. I could make the default size a bit bigger to hide it. The downside would be that pMusic wouldn't fit into a 600x800 screen. Or do anyone have another solution?

You might find the autoplaying of Hoovers irritating, but it is done to quickly introduce new users to the interface. What are the Left/Right pane used for?

I can not reproduce your browsing problems....


Thank you for testing
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Fri 02 Nov 2012, 00:43    Post_subject:  

pMusic Beta3







Download pMusic 3 - Beta3 here

_________________
Stardust resources

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7794
Location: qld

PostPosted: Fri 02 Nov 2012, 00:45    Post_subject:  

Just looking at my diff.. and my comments the "cut" delimiter is the ':' , not space, in any case the tr still works fine, and should anyway I think.
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5673
Location: Valåmoen, Norway

PostPosted: Fri 02 Nov 2012, 00:46    Post_subject:  

Mick
The tooltips in pEqualizer is fixed - version 0.8.2

Download pMusic 3 - Beta2 here

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 88 of 123 Posts_count   Goto page: Previous 1, 2, 3, ..., 86, 87, 88, 89, 90, ..., 121, 122, 123 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1300s ][ Queries: 13 (0.0304s) ][ GZIP on ]