Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 16:16
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
No touchpad on new Precise install
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
Cushie

Joined: 31 Oct 2012
Posts: 3

PostPosted: Wed 31 Oct 2012, 13:34    Post subject:  No touchpad on new Precise install  

Not easy to find an install .iso to USB flash drive.
'Create Start up Disk' in Ubuntu 12.04 would not recognise .iso.
Then tried 'Unetbootin' and all seemed ok. On booting up I have no touchpad control of curser! I looked in Hardinfo and it is listed, managed to get to Mouse/Touchpad setup found touchpad ticked but nothing working.

Any help to get this working (without a mouse( woukd be appreciated.
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 31 Oct 2012, 14:27    Post subject: Re: Touchpad
Subject description: No touchpad on new Precise install
 

Cushie wrote:
Not easy to find an install .iso to USB flash drive.
'Create Start up Disk' in Ubuntu 12.04 would not recognise .iso.
Then tried 'Unetbootin' and all seemed ok. On booting up I have no touchpad control of curser! I looked in Hardinfo and it is listed, managed to get to Mouse/Touchpad setup found touchpad ticked but nothing working.

Any help to get this working (without a mouse( woukd be appreciated.


Try "desktop > flSynclient".

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
Cushie

Joined: 31 Oct 2012
Posts: 3

PostPosted: Wed 31 Oct 2012, 15:25    Post subject:  

Thanks 'rjbrewer' In the terminal 'flsyncient' brings up the Pad configure UI which I had already set.

However 'desktop > flsynclient' (both S & s for Synclient with and without a space after >) in the terminal all gave no such command.


I found FnKey +F7 puts touchpad 'on' after a few strokes. Then tried 'synclient' in terminal and found 'Touchpadoff =0'
but sadly the setting does not keep on reboot.

Any help to have this setting permanent would be a real help
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Wed 31 Oct 2012, 15:33    Post subject:  

Cushie wrote:
Thanks 'rjbrewer' In the terminal 'flsyncient' brings up the Pad configure UI which I had already set.

However 'desktop > flsynclient' (both S & s for Synclient with and without a space after >) in the terminal all gave no such command.


"desktop" is the 1st category in the menu.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Thu 01 Nov 2012, 15:53    Post subject:  

I do not know why your touchpad is off, but you can put synclient commands for example to the /root/Startup.
Go to that folder, right click > New > Script. Rename it for example as synclient. Open that script so that it opens in Geany.

Add this row to the file: synclient TouchpadOff=0
so the file content is now:
Code:
#!/bin/sh
synclient TouchpadOff=0

Save. Done. Now that script will be executed at every X start or restart.
You can add other synclient commands to that file if needed.
Back to top
View user's profile Send private message 
iluminameluna

Joined: 20 Oct 2011
Posts: 30

PostPosted: Fri 02 Nov 2012, 02:40    Post subject:  Turning OFF the touchpad at startup
Subject description: If you have a USB mouse, you DON'T want to have the touchpad working.
 

I have the opposite issue. I DON'T want the touchpad activated. I couldn't figure out how to open the file mentioned as I'm used to using the sudo commands in Ubuntu.

In any case, I found the Folder > Startup in the File System > Rox-File Mgr (from the menu list). When I clicked on the Startup folder I found this: load touchpad settings
where I found this:
Code:
#!/bin/bash
flsynclient -s


I've added this:
Code:
#!/bin/sh
synclient TouchpadOff=1


This is opened in Geany and in the /root/Startup directory as the suggestion suggested. Wink

Cushie: I don't know how to access the menu items without a mouse. I hope you figured it out.

I'm really hoping it works 'cause the piece of cardboard I've taped over the touchpad seems to cause overheating of the kb near it. Scary. & might be the reason my ram seems to be misbehaving.
Back to top
View user's profile Send private message 
Cushie

Joined: 31 Oct 2012
Posts: 3

PostPosted: Fri 02 Nov 2012, 05:23    Post subject:  

Thanks for your help, pemasu and iluminameluna. It will be my first attempt at a script and in the meantime I'll look for the startup folder and edit flsynclient.
Back to top
View user's profile Send private message 
iluminameluna

Joined: 20 Oct 2011
Posts: 30

PostPosted: Fri 02 Nov 2012, 05:38    Post subject:  

Cushie wrote:
Thanks for your help, pemasu and iluminameluna. It will be my first attempt at a script and in the meantime I'll look for the startup folder and edit flsynclient.


If you follow my steps, no need to look much further. The ROX-File Manager will open into the /root folder right away and the Startup folder is right there. If you wish to add the lines of code, do a right click on the Starup folder & choose "Open as a text file" (or something similar). It will choose Geany by default so there's no need to overcomplicate that.

At that point, if you have your browser tab or window open to this forum, you can just copy & paste the code to the file. Save and close and you're done. It DID work for me. Very Happy
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11034
Location: Arizona USA

PostPosted: Fri 02 Nov 2012, 08:36    Post subject:  

iluminameluna, if you don't want your touchpad to work, then asking how to do that in a thread about getting a touchpad to work is liable to be ignored. Laughing

It would work better to start a new thread, with a title something like "How do I turn off my touchpad?" Smile
Back to top
View user's profile Send private message 
tytower

Joined: 24 Feb 2007
Posts: 440
Location: Green Island Cairns for the winter

PostPosted: Wed 14 Nov 2012, 05:37    Post subject:  

pemasu wrote:
I do not know why your touchpad is off, but you can put synclient commands for example to the /root/Startup.
Go to that folder, right click > New > Script. Rename it for example as synclient. Open that script so that it opens in Geany.

Add this row to the file: synclient TouchpadOff=0
so the file content is now:
Code:
#!/bin/sh
synclient TouchpadOff=0

Save. Done. Now that script will be executed at every X start or restart.
You can add other synclient commands to that file if needed.


In my install of 5.31 the Startup Directory comes up at the bottom of the root directory as an "APP" file with different colour marking

You can't click on it, you must right click and choose "Look Inside" Then you can add a new text file as above

Alright that sorted, I did this, but I still cant get my "Acecat Flair " touchpad ? tablet ? to start up . It lights up at the boot up stage but when puppy loads the lights go out-Its a tablet but does it work the same as a touchpad?

_________________
Neither my Family nor my Property are Government issues. Governments should do what they were designed to do Manage the larger issues best done by Governments
To stop corruption give them 3 times the penalty. Get their agreement on first employment.
Back to top
View user's profile Send private message 
tytower

Joined: 24 Feb 2007
Posts: 440
Location: Green Island Cairns for the winter

PostPosted: Wed 16 Jan 2013, 15:58    Post subject:  

Hey speak of the devil
I have had my pad sitting here for a few months now unplugged .
Downloaded 5.4.2 recenty and thought to try this and it works now !

The power of suggestion or is somebody monitoring here and fixing broken stuff without saying a word ?

Its certainly worth posting your troubles.

_________________
Neither my Family nor my Property are Government issues. Governments should do what they were designed to do Manage the larger issues best done by Governments
To stop corruption give them 3 times the penalty. Get their agreement on first employment.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0740s ][ Queries: 12 (0.0036s) ][ GZIP on ]