Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 02:23
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Precise Puppy 5.4 and 5.4.2
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 20 of 29 Posts_count   Goto page: Previous 1, 2, 3, ..., 18, 19, 20, 21, 22, ..., 27, 28, 29 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7836
Location: qld

PostPosted: Wed 07 Nov 2012, 19:43    Post_subject:  

akash_rawal wrote:
akash_rawal wrote:

Also gio has problems using modules. It's a glib bug and affects some other distros as well.

I have recompiled glib from original sources and that fixes the module loading problem.
http://dl.dropbox.com/u/58347439/protected/glib-2.32.3-orig-precise540-i686.pet
Did you include jemimah's patches for media/mnt and the help browser? If so, then it would solve bigpup's issue with the help in all gtk apps.
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Wed 07 Nov 2012, 20:07    Post_subject:  

bigpup wrote:
BarryK wrote:
I think that John Murga has made changes to the Forum recently. It keeps on logging me out. Anyone else got this problem?

From the forum FAQ
Quote:
Why do I get logged off automatically?
If you do not check the Log me in automatically box when you log in, the board will only keep you logged in for a preset time. This prevents misuse of your account by anyone else. To stay logged in, check the box during login. This is not recommended if you access the board from a shared computer, e.g. library, internet cafe, university cluster, etc.


What I am reporting is a change in behaviour of the forum.

Sometimes it logs me out only a few minutes after logging in. Even if I am active on the forum.

The previous behaviour was that it would log me out after a certain period of inactivity. I don't recall how long, maybe half an hour. It was a generous period of inactivity.

I used to have this problem with my Telstra mobile broadband connection. I did report the problem to John, but it never got fixed. After I changed to Optus, the problem went away.
Until now, suddenly I have that problem with Optus also.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Wed 07 Nov 2012, 20:14    Post_subject:  

akash_rawal wrote:
Testing precise 5.4.0.90.

Looks like the session saving problem is solved, I'm unable to reproduce it now.

Problems with gdb and gio modules persist.

I'll continue testing and report back more. Smile


Do you mean even after installing your PET:
http://dl.dropbox.com/u/58347439/protected/glib-2.32.3-orig-precise540-i686.pet

Precise still has module loading problems?

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Wed 07 Nov 2012, 20:14    Post_subject:  

akash_rawal wrote:
Finished downloading precise 5.4. Testing it reveals several problems.

On first boot it refused to save the session. After asking for save file name it rebooted without saving session. Next time I ran wmreboot in terminal but this time it worked properly. Confused Will try again to reproduce the problem.

Display, opengl and internet is working properly. Posting from there now.

In devx gdb doesn't work.
Code:

# gdb
gdb: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory
#

Installing libpython2.7_2.7.3-0ubuntu3_i386.deb fixes gdb.

Also gio has problems using modules. It's a glib bug and affects some other distros as well. See here.

Edit: Didn't see precise 5.4.0.90.


Thanks, libpython2.7 will be in the devx.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Thu 08 Nov 2012, 00:46    Post_subject: Infrastructure mods to facilitate addition of Frisbee  

Barry,
Testing of my integrated Frisbee is progressing well. Although I am not ready to submit it for additon to the puppy package library, the infrastructure changes are straightforward and would simplify users' and developers' addition of Frisbee.

Please consider updating woof with the first four packages posted here:
http://www.murga-linux.com/puppy/viewtopic.php?p=662518#662518

The fifth (dhcpcd-dropwait) can also be added to the puppy package library, although substituting it in woof for dhcpcd could benefit connection stability for all network managers.

My main concern, though, is that the woof-resident changes be made, including the addition of a slot for a separate wag_profiles package. Please see the description associated with those packages at the above link. I recognize that it is late in the cycle, but ask for it because it would avoid users needing to modify to puppy infrastructure.
Richard
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7048
Location: Perth, Western Australia

PostPosted: Thu 08 Nov 2012, 05:31    Post_subject: Re: Infrastructure mods to facilitate addition of Frisbee  

rerwin wrote:
Barry,
Testing of my integrated Frisbee is progressing well. Although I am not ready to submit it for additon to the puppy package library, the infrastructure changes are straightforward and would simplify users' and developers' addition of Frisbee.

Please consider updating woof with the first four packages posted here:
http://www.murga-linux.com/puppy/viewtopic.php?p=662518#662518

The fifth (dhcpcd-dropwait) can also be added to the puppy package library, although substituting it in woof for dhcpcd could benefit connection stability for all network managers.

My main concern, though, is that the woof-resident changes be made, including the addition of a slot for a separate wag_profiles package. Please see the description associated with those packages at the above link. I recognize that it is late in the cycle, but ask for it because it would avoid users needing to modify to puppy infrastructure.
Richard


Richard,
It is too late in the development cycle for Precise 5.4.1. This is almost ready to be released, and anyway the intention was bug-fixes only relative to 5.4.

Infrastructure changes to support Frisbee can be considered after 5.4.1 is released.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Thu 08 Nov 2012, 06:10    Post_subject: Re: regular expression evaluation and learning tool
Sub_title: regetron, another tool
 

BarryK wrote:
L18L wrote:
file:///usr/share/doc/HOWTO-regexps.htm wrote:
[Note: Puppy has a regular expression evaluation and learning tool in the Utilities menu]


Once upon a time (version 1.04) I have used it much.
But now it seems to have disappeared Crying or Very sad


Yes, that was a long time ago. If I recall rightly, there were two of them, one was written in tcl/tk, the other gtk1.2.

Which was why we had to leave them behind.

Hi Barry,
I have searched, found and installed another tool:
my console wrote:
# regetron
Regetron! The regex teaching SHELL.
Type your regex at the prompt and hit enter. It'll show you the
lines that match that regex, or nothing if nothing matches.
Hit CTRL-d to quit (CTRL-z on windows).
>

installed:
Code:
git clone git://gitorious.org/regetron/regetron.git
cd regetron
python setup.py install

like advised at
http://regex.learncodethehardway.org/book/learn-regex-the-hard-waych1.html#x6-100001
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Thu 08 Nov 2012, 10:43    Post_subject:  

01micko wrote:
akash_rawal wrote:
akash_rawal wrote:

Also gio has problems using modules. It's a glib bug and affects some other distros as well.

I have recompiled glib from original sources and that fixes the module loading problem.
http://dl.dropbox.com/u/58347439/protected/glib-2.32.3-orig-precise540-i686.pet
Did you include jemimah's patches for media/mnt and the help browser? If so, then it would solve bigpup's issue with the help in all gtk apps.

No, I used the original, unmodified source. I'll check out the patch soon.

Till now abiword is the only program I find with help not working, irrespective of manually compiled glib or precise glib. "Operation not supported" is the warning printed on terminal. Is this problem you are talking about?

But running gdb on abiword reveals it uses its own c++ functions to implement help.
Code:

Breakpoint 1, 0xb70207f0 in g_log () from /lib/libglib-2.0.so.0
(gdb) bt
#0  0xb70207f0 in g_log () from /lib/libglib-2.0.so.0
#1  0x083affb6 in XAP_UnixAppImpl::openURL(char const*) ()
#2  0x08189b9f in helpLocalizeAndOpenURL(char const*, char const*, char const*)
    ()
#3  0x08189c4a in ap_EditMethods::helpContents(AV_View*, EV_EditMethodCallData*) ()
#4  0x082850bd in EV_Menu::invokeMenuMethod(AV_View*, EV_EditMethod*, UT_String const&) ()
#5  0x083cf590 in EV_UnixMenu::menuEvent(int) ()
#6  0xb7142b3c in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#7  0xb7140dd4 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#8  0xb71537d9 in ?? () from /usr/lib/libgobject-2.0.so.0
#9  0xb715c02f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#10 0xb715c233 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#11 0xb7d03395 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#12 0xb7be0667 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
...


So maybe you are talking about something else I didn't get...
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Thu 08 Nov 2012, 10:49    Post_subject:  

BarryK wrote:
akash_rawal wrote:
Testing precise 5.4.0.90.

Looks like the session saving problem is solved, I'm unable to reproduce it now.

Problems with gdb and gio modules persist.

I'll continue testing and report back more. Smile


Do you mean even after installing your PET:
http://dl.dropbox.com/u/58347439/protected/glib-2.32.3-orig-precise540-i686.pet

Precise still has module loading problems?


No, I meant even in precise 5.4.0.90 I have to install the pet to correct the problem.

The problem is solved after installing the pet.
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1778
Location: wales

PostPosted: Thu 08 Nov 2012, 11:11    Post_subject:  

there's a bug when installing .deb files. the categories section of the .desktop file in /usr/share/applications gets changed!
this has also been noted by Jejy69 http://www.murga-linux.com/puppy/viewtopic.php?t=81852

for example in the openshot.deb, /usr/share/applications/openshot.desktop looks like this
Code:
Categories=GNOME;GTK;AudioVideo;Video;AudioVideoEditing;

after installing though it looks like this
Code:
Categories=Utility


same with the deadbeef.deb from
Code:
Categories=AudioVideo;Player;GTK;
to
Code:
Categories=Utility


this is making nearly everything installed from the ppm end up in the 'utility' menu

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=93998
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Thu 08 Nov 2012, 11:43    Post_subject: Re: Infrastructure mods to facilitate addition of Frisbee  

BarryK wrote:
Richard,
It is too late in the development cycle for Precise 5.4.1. This is almost ready to be released, and anyway the intention was bug-fixes only relative to 5.4.

Infrastructure changes to support Frisbee can be considered after 5.4.1 is released.
Right. The goal is to get the implementation into the woof structure for all puppies, not precise 5.4.1. Thanks for clarifying that for me.
Richard
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Thu 08 Nov 2012, 12:12    Post_subject:  

Glade interface designer doesn't work.
Code:

# glade
glade: error while loading shared libraries: libgtk-3.so.0: cannot open shared object file: No such file or directory
#

Instead of adding gtk3 maybe it would be better to provide glade separately, as gtk3 could be large?
Back to top
View user's profile Send_private_message 
dennis-slacko531


Joined: 18 Jan 2012
Posts: 103
Location: Oregon

PostPosted: Thu 08 Nov 2012, 15:52    Post_subject: Help with finding BlueGriffon  

Maybe I belong in the beginners forum, but I hope not. BlueGriffon is a wysiwyg website builder I'd like to try. It's popular so I expected it to be found with PPM --but nothing available. I appreciate any & all help.

** FREE CONCERT:
I'm discovering this puppy is excellent with multimedia. If anyone wants to hear Bob Dylan's (live & great) concert from last month at the Hollywood Bowl, here's the link from a DJ that I Twitter follow.

http://www.radio4all.net/responder.php/podcast/podcast.xml?program_id=64169&version_id=71326&version=1
Back to top
View user's profile Send_private_message Visit_website 
tlchost

Joined: 05 Aug 2007
Posts: 1727
Location: Baltimore, Maryland USA

PostPosted: Thu 08 Nov 2012, 17:33    Post_subject: I'll try again  

This latest version of precise does not recognize my audio chip. I tried all the steps...what information to I need to post to allow someone to either tell me how to fix the problem, or not to continue the effort.

Thanks
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7836
Location: qld

PostPosted: Thu 08 Nov 2012, 18:02    Post_subject: Re: Help with finding BlueGriffon  

dennis-slacko531 wrote:
Maybe I belong in the beginners forum, but I hope not. BlueGriffon is a wysiwyg website builder I'd like to try. It's popular so I expected it to be found with PPM --but nothing available. I appreciate any & all help.


You can get from here: http://distro.ibiblio.org/puppylinux/pet_packages-slacko/bluegriffon-1.5.2-i686.pet

-

akash_rawal

To save you the hunt I've attached the glib patch I use in Slacko-beta series based on slackware-14.0. This is based directly on jemimah's work.

Cheers
glib-2.32.4_slacko-121002.patch.gz
Description 
gz

 Download 
Filename  glib-2.32.4_slacko-121002.patch.gz 
Filesize  815 Bytes 
Downloaded  377 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 20 of 29 Posts_count   Goto page: Previous 1, 2, 3, ..., 18, 19, 20, 21, 22, ..., 27, 28, 29 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1251s ][ Queries: 13 (0.0144s) ][ GZIP on ]