Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 15:41
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Precise Puppy 5.4 and 5.4.2
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 21 of 29 Posts_count   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 27, 28, 29 Next
Author Message
afishe2000

Joined: 29 Jan 2010
Posts: 37

PostPosted: Thu 08 Nov 2012, 18:17    Post_subject: Re: regular expression evaluation and learning tool  

Quote:
file:///usr/share/doc/HOWTO-regexps.htm wrote:
[Note: Puppy has a regular expression evaluation and learning tool in the Utilities menu]


Once upon a time (version 1.04) I have used it much.
But now it seems to have disappeared Crying or Very sad


If you are running Python you can use redemo.py

I created redemo.sh and made it executable

Code:
python /usr/lib/python2.6/site-packages/scripts/redemo.py
Back to top
View user's profile Send_private_message 
majorfoo

Joined: 07 Mar 2011
Posts: 446
Location: Wish I knew

PostPosted: Thu 08 Nov 2012, 20:51    Post_subject:  

Full Install of 5.4.0.90 PAE to ext4 partition

Confirming that black screen no longer appears on bootup

Have installed about dozen pets from storage partition and everything works.
Back to top
View user's profile Send_private_message 
Peter.M

Joined: 08 Nov 2012
Posts: 4
Location: NSW in AUS

PostPosted: Thu 08 Nov 2012, 21:22    Post_subject:  

Somehow (new to forum) I think this has also gone somewhere else as well - appologies

Notifying BUG here as it concerns my test of 5.4.1 beta

Have just downloaded beta, tried on my Dell Vostro V360 all in one desktop. It boots to a totally black screen (nothing visible) which blinks the desktop on for about 0.5 seconds every 10-15 seconds. I also understand it affects some laptops as well of both Dell and other brands that use the nvidia optimus gt525 video chipset

This is a known bug with ubuntu 12.04 precise and I believe affects all kernels in all distros kernel 2.6 thru 3.5 that use a video driver unless it uses vesa. I understand the bug has been fixed in later 3.5 and up kernels

see this: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/918769

and this which is too technical for me !! : https://bugs.freedesktop.org/attachment.cgi?id=62301

Has anyone else had this problem?

Hope this helps make Puppy better and more versatile Very Happy
Back to top
View user's profile Send_private_message 
otropogo


Joined: 24 Oct 2009
Posts: 702
Location: Southern Rocky Mt. Trench

PostPosted: Fri 09 Nov 2012, 03:05    Post_subject:  

Peter.M wrote:
Somehow (new to forum) I think this has also gone somewhere else as well - appologies

Notifying BUG here as it concerns my test of 5.4.1 beta

Have just downloaded beta, tried on my Dell Vostro V360 all in one desktop. It boots to a totally black screen (nothing visible) which blinks the desktop on for about 0.5 seconds every 10-15 seconds. I also understand it affects some laptops as well of both Dell and other brands that use the nvidia optimus gt525 video chipset

This is a known bug with ubuntu 12.04 precise and I believe affects all kernels in all distros kernel 2.6 thru 3.5 that use a video driver unless it uses vesa. I understand the bug has been fixed in later 3.5 and up kernels

see this: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/918769

and this which is too technical for me !! : https://bugs.freedesktop.org/attachment.cgi?id=62301

Has anyone else had this problem?

Hope this helps make Puppy better and more versatile Very Happy



I haven't tried beta .1 yet, but reported very similar video issues on page 16 of this thread, which apparently were not deserving of Barry's response.

If I hadn't had two monitors available, I wouldn't have been able to do any experimentation at all with Puppy 5.4. As it is, configuring a display was gruesomely difficult, and at times both monitors were blacked out, and only one was even marginally usable at the available settings.

And these are problems I've never encountered with any Puppy from 1.1 through 5.2.8.

_________________
otropogo@gmail.com facebook.com/otropogo
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Fri 09 Nov 2012, 06:00    Post_subject:  

otropogo wrote:
I haven't tried beta .1 yet, but reported very similar video issues on page 16 of this thread, which apparently were not deserving of Barry's response.


Not the kind of comment that is going to get me "onside".

I often don't respond to a bug report simply because I haven't got a clue how to fix it. If someone reports a "black screen", there is not much to go on.

Often the only apparent solution is to use some other puplet or even other distro that does work with that hardware.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
666philb


Joined: 07 Feb 2010
Posts: 1962
Location: wales

PostPosted: Fri 09 Nov 2012, 06:06    Post_subject:  

menu entries still not working 100% http://bkhome.org/blog2/?viewDetailed=00021
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Fri 09 Nov 2012, 06:09    Post_subject:  

Precise Puppy 5.4.1 coming soon.

That's enough, I reckon that we have got this pup in good shape. I am going to do a build of 5.4.1-final right now, then do some sanity testing, then upload it.

The sanity-testing is required, as it is always possible that the recent fixes, such as the menu-category fix when installing packages, and the glib/gio module-loading fix, may themselves introduce some other bug -- even though they may seem like straight-forward fixes, I know from experience to be very cautious.

Well, it is even possible that my sanity test might miss some new subtle bug, but it is a question of the odds being in favour of everything being ok.

After 5.4.1 is released, the "Puppy community" is invited to take over and work toward 5.4.2+. If there is a consensus of developers, for a group or particular individual to coordinate, then go for it!

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Fri 09 Nov 2012, 06:32    Post_subject:  

Um, here is an example of a potential last-minute bug...

I have put in the glib PET from akash_rawal, but I just looked at his compile configure:

./configure --prefix=/usr --sysconfdir=/etc --enable-debug=yes

...there is no "--build" parameter, so although the name of the PET specified that it is for "i686", there is no guarantee that this is so. The compile could be optimised for whatever CPU that akash_rawal has.

Therefore, I won't take the risk. I will build 5.4.1-final without akash_rawal's glib PET.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
PANZERKOPF

Joined: 16 Dec 2009
Posts: 280
Location: Earth

PostPosted: Fri 09 Nov 2012, 10:51    Post_subject:  

BarryK wrote:

./configure --prefix=/usr --sysconfdir=/etc --enable-debug=yes

Note "--enable-debug=yes" increases a size of compiled binary.
The default option is "--enable-debug=minimal" but if we want to get a smallest binary,
we must use "--enable-debug=no".
This also true for GTK and Pango libraries.

_________________
SUUM CUIQUE.
Back to top
View user's profile Send_private_message 
otropogo


Joined: 24 Oct 2009
Posts: 702
Location: Southern Rocky Mt. Trench

PostPosted: Fri 09 Nov 2012, 13:05    Post_subject:  

BarryK wrote:
otropogo wrote:
I haven't tried beta .1 yet, but reported very similar video issues on page 16 of this thread, which apparently were not deserving of Barry's response.


Not the kind of comment that is going to get me "onside".

I often don't respond to a bug report simply because I haven't got a clue how to fix it. If someone reports a "black screen", there is not much to go on.

Often the only apparent solution is to use some other puplet or even other distro that does work with that hardware.


My report on page 16 described the most serious display configuration issues I've encountered in all the Puppies I've used since 1.1 - much more than a mere "black screen" report.

Ignoring bug reports because you dislike the poster simply undermines confidence in your work, as well as discouraging essential feedback.

_________________
otropogo@gmail.com facebook.com/otropogo
Back to top
View user's profile Send_private_message Visit_website 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Fri 09 Nov 2012, 14:42    Post_subject:  

01micko wrote:

akash_rawal

To save you the hunt I've attached the glib patch I use in Slacko-beta series based on slackware-14.0. This is based directly on jemimah's work.

Cheers


Thanks.

I applied the patch and rebuilt glib, and abiword's help works Smile

One slight problem, with an additional volume monitor running a mounted volume is listed twice in the filechooser sidebar. I modified it so that the native mount monitor is turned off on exporting "GIO_IGNORE_NATIVE_VOLUME_MONITOR" environment variable.

Package:
http://dl.dropbox.com/u/58347439/protected/glib-2.32.3-patched-precise-i686.pet

New patch:
http://dl.dropbox.com/u/58347439/protected/glib-2.32.3-precise5409.patch.gz
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Fri 09 Nov 2012, 14:46    Post_subject:  

otropogo wrote:
Ignoring bug reports because you dislike the poster simply undermines confidence in your work, as well as discouraging essential feedback.


Oh please!!!!

What nonsense.

This is one example of many that have contributed to my desire to withdraw from the "frontline" development.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7100
Location: Perth, Western Australia

PostPosted: Fri 09 Nov 2012, 14:48    Post_subject:  

Precise 5.4.1 has been released, and I have started a new Forum thread:

http://murga-linux.com/puppy/viewtopic.php?t=82092

_________________
http://bkhome.org/news/
Back to top
View user's profile Send_private_message Visit_website 
Q5sys


Joined: 11 Dec 2008
Posts: 1074

PostPosted: Fri 09 Nov 2012, 15:30    Post_subject:  

BarryK wrote:
otropogo wrote:
Ignoring bug reports because you dislike the poster simply undermines confidence in your work, as well as discouraging essential feedback.


Oh please!!!!

What nonsense.

This is one example of many that have contributed to my desire to withdraw from the "frontline" development.


Barry,
Please keep in mind that for every one of the people out there who acts like this... you have hundreds (if not thousands) who appreciate all the work you do. This entire community woudlnt exist if it werent for you. Please dont let the bad apples discourage you.

_________________



Back to top
View user's profile Send_private_message Visit_website 
oldyeller


Joined: 15 Nov 2011
Posts: 822
Location: Mishawaka IN

PostPosted: Fri 09 Nov 2012, 15:55    Post_subject:  

Q5sys wrote:
BarryK wrote:
otropogo wrote:
Ignoring bug reports because you dislike the poster simply undermines confidence in your work, as well as discouraging essential feedback.


Oh please!!!!

What nonsense.

This is one example of many that have contributed to my desire to withdraw from the "frontline" development.


Barry,
Please keep in mind that for every one of the people out there who acts like this... you have hundreds (if not thousands) who appreciate all the work you do. This entire community woudlnt exist if it werent for you. Please dont let the bad apples discourage you.


I would differently agree on this one two, keep it up Barry and don't let anyone discourage you on what you have done which is to bring us a little puppy to play with.

Cheers
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 21 of 29 Posts_count   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23, ..., 27, 28, 29 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1063s ][ Queries: 13 (0.0112s) ][ GZIP on ]