Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Sep 2014, 20:33
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
màj seamonkey impossible
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [27 Posts]   Goto page: Previous 1, 2
Author Message
beekeeper

Joined: 05 Oct 2012
Posts: 57

PostPosted: Thu 15 Nov 2012, 08:17    Post subject:  

Argolance wrote:
Si le dossier qui contient les fichiers de Seamonkey s'appelle 'seamonkey' tout court, ce qui semble être le cas, il faut créer un raccourci (clic droit, lier...) qui pointe sur ce dossier 'seamonkey' et portant le nom de l'ancien, c'est-à-dire, 'seamonkey-2.6.1'!

Mon problème est toujours le même: je ne peux créer ce raccourci, bicause "symlink: file exists"!
Back to top
View user's profile Send private message 
beekeeper

Joined: 05 Oct 2012
Posts: 57

PostPosted: Thu 15 Nov 2012, 08:39    Post subject:  

Je viens d'aller voir en ram pour tenter de trouver une explication: par défaut, seamonkey est dans un dossier "seamonkey-2.6.1". Le lien symbolique, lui, s'appelle simplement "seamonkey". POur respecter les liens il faudrait donc que je crée un lien "seamonkey" qui pointe vers le nouveau dossier seamonkey. Et c'est là où ça merde:
Le nouveau seamonkey que j'ai chargé s'appelle "seamonkey", donc quand je veux nommer le lien symbolique il ne veut pas car il existe déjà un dossier appelé "seamonkey" (le nouveau)! D'où le "file exists". La question est: puis je renommer le dossier seamonkey en lui rajoutant quelque chose, puis créer un lien "seamonkey" qui pointerait vers le dossier? C'est ce que je vais essayer de faire dés que j'ai 2 minutes...
Back to top
View user's profile Send private message 
beekeeper

Joined: 05 Oct 2012
Posts: 57

PostPosted: Thu 15 Nov 2012, 09:02    Post subject:    

Bon!
J'ai renommé mon dossier "seamonkey" en "seamonkey-a", créé un lien vers ce dossier, nommé "seamonkey" (comme était nommé le lien d'origine). Ben... ça marche pas!
Alors j'ai supprimé tout ça, retrouvé le seamonkey d'origine ("seamonkey-2.6.1") et recréé un lien vers ce même dossier appelé "seamonkey". Et là, pas de problème, l'ancienne version de seamonkey se lance. D'où vient donc le problème? Ça te semble vraiment si simple, asriedu? Shocked
C'est comme si le dossier du nouveau seamonkey était corrompu. Je viens de retélécharger SM, décompressé dans usr/lib, recréé un lien vers lui, et ça ne marche toujours pas... Comme le "old", lui, ne pose pas de problème, j'en conclue qu'il y a une incompatibilité quelque part... non? et j'abandonne la partie pour l'instant, dans l'attente de vos avis éclairés!
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 1826
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 15 Nov 2012, 19:21    Post subject:  

Hello,
Désolé de t'avoir embringuée dans tant de complications. J'ai fait ça sur mes trois ordinateurs et ça fonctionne sans problème.
Bon, le plus simple:
    1 - renommer 'seamonkey-2.6.1' comme tu voudras.
    2 - copier le nouveau dossier de Seamonkey téléchargé dans /usr/bin
    3 - le renommer en 'seamonkey-2.6.1', exactement comme l'autre.
    4 - supprimer l'ancien (si ça marche!)
Dans le pire des cas, si ça ne fonctionne toujours pas, ASRI va, comme promis, te préparer un joli petit paquet cadeau qui résoudra ça une bonne fois pour toutes! Wink

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 2448
Location: France

PostPosted: Thu 15 Nov 2012, 21:59    Post subject:  

Argolance wrote:
Hello,
Désolé de t'avoir embringuée dans tant de complications. J'ai fait ça sur mes trois ordinateurs et ça fonctionne sans problème.
Bon, le plus simple:
    1 - renommer 'seamonkey-2.6.1' comme tu voudras.
    2 - copier le nouveau dossier de Seamonkey téléchargé dans /usr/bin
    3 - le renommer en 'seamonkey-2.6.1', exactement comme l'autre.
    4 - supprimer l'ancien (si ça marche!)
Dans le pire des cas, si ça ne fonctionne toujours pas, ASRI va, comme promis, te préparer un joli petit paquet cadeau qui résoudra ça une bonne fois pour toutes! Wink

Cordialement.

Désolé, je rentre d'une réunion et à cette heure tardive je n'ai pas la motivation pour enligner un paquet.
Demain soir j'ai une autre réunion, alors en fonction de l'heure le paquet devra attendre samedi.

Pour effectuer quelques tests sur Puppy precise, je me suis préparé un paquet seamonkey.
Pour ce paquet, j'ai :
- téléchargé la dernière version de Seamonkey fr http://www.seamonkey-project.org/
- modifié deux fichiers dans /usr/bin
- placé le contenu de l'archive seamonkey dans /usr/lib/seamonkey
- modifié quelques fichiers dans /usr/local/bin
Cette solution n'est pas forcément un joli paquet cadeau (Argolance plaisante évidemment), mais j'ai tendance à penser qu'avec ces modifications je devrais pouvoir affronter la prochaine mise à jour de Seamonkey sans trop de soucis.
Dans le doute, je te conseille te tester le paquet en liveCD avec l'option "puppy pfix=ram" (ainsi, tu es sûr de ne pas toucher à ta configuration existante).

Cordialement,
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 2448
Location: France

PostPosted: Wed 21 Nov 2012, 08:58    Post subject:  

@ beekeeper
Je te propose de tester le paquet disponible sur ce fil http://www.murga-linux.com/puppy/viewtopic.php?t=82379
Cordialement,
Back to top
View user's profile Send private message Visit poster's website 
beekeeper

Joined: 05 Oct 2012
Posts: 57

PostPosted: Wed 26 Jun 2013, 15:23    Post subject:  

Bonjour,
Après plusieurs mois passés loin de puppy (je n'ai même pas remercié Asri edu ni Argolance pour leur aide: MERCI), je tente à nouveau la màj de seamonkey afin de me bricoler un petit puppy de voyage sur clé usb. J'ai donc chargé le .pet amoureusement préparé par Asri edu (après avoir créé une clé bootable par unetbootin), installé celui ci. Tout avait l'air de bien se passer, sauf que... seamonkey apparait bien dans le menu en français (je le distingue car je n'ai pas encore installé le paquet francophone), mais ni le navigateur ni le courriel seamonkey ne se lancent quand je clique sur leurs icônes (alors que ça marchait avant)! C'est normal (??)?
Merci pour votre aide.
Back to top
View user's profile Send private message 
Jejy69


Joined: 20 Jan 2011
Posts: 707
Location: Perpignan

PostPosted: Wed 26 Jun 2013, 15:37    Post subject:  

Bonsoir beekeeper,

Quel est le résultat lorsque tu tapes "seamonkey" dans un terminal s'il te plaît ? Cela nous donnera peut-être une idée de ce qui ne va pas.
Après, non, ce n'est pas normal à priori Very Happy

_________________
I'm Commander Shepard and this is my favorite Linux distrbution on the Citadel.
Back to top
View user's profile Send private message 
beekeeper

Joined: 05 Oct 2012
Posts: 57

PostPosted: Thu 27 Jun 2013, 05:42    Post subject:  

Code:
XPCOMGlueLoad error for file /usr/lib/seamonkey/libxpcom.so:libdbus-glib-1.so.2: cannot open shared object file: no such file or directory. Couldn't load XPCOM

Ya bien un problème!
Back to top
View user's profile Send private message 
Jejy69


Joined: 20 Jan 2011
Posts: 707
Location: Perpignan

PostPosted: Thu 27 Jun 2013, 12:56    Post subject:  

En effet, mais rien de bien méchant à première vue.
Il semblerait qu'une dépendance soit manquante.
Installer ceci devrait résoudre ton problème :
http://security.ubuntu.com/ubuntu/pool/main/d/dbus-glib/libdbus-glib-1-2_0.84-1ubuntu0.3_i386.deb

Affaire à suivre ! Smile

_________________
I'm Commander Shepard and this is my favorite Linux distrbution on the Citadel.
Back to top
View user's profile Send private message 
beekeeper

Joined: 05 Oct 2012
Posts: 57

PostPosted: Thu 27 Jun 2013, 15:53    Post subject:  

Fichier .deb bien installé, mais... maintenant il manque la suivante!
Code:
XPCOMGlueLoad error for file /usr/lib/seamonkey/libxpcom.so:libdbus-glib-1.so.3: cannot open shared object file: no such file or directory. Couldn't load XPCOM

Je suis allé voir la liste sur ubuntu.com (passque quand même, avant de demander aux autres...), pas de libdbus-glib-1.3. Comment faire maintenant? J'avoue ne pas très bien comprendre, le .pet d'Asri edu aurait du convenir, non?
Back to top
View user's profile Send private message 
beekeeper

Joined: 05 Oct 2012
Posts: 57

PostPosted: Fri 28 Jun 2013, 10:20    Post subject:  

Heuu, une idée, bête peut être, mais le paquet d'ASRIedu était fait pour Toutou 431... Mon problème ne vient il pas de là (j'esaie de l'installer sur une wary 5.3)?
Sinon, il existe la même chose pour wary 5.5? Je ne sais pas trop encore comment chercher ce genre de chose sur internet, idem pour activer le pavé numérique au démarrage, je sais pas comment faire!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [27 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0769s ][ Queries: 12 (0.0069s) ][ GZIP on ]