Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 23:16
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Easy to use random wallpaper changer
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 6 [83 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
sc0ttman


Joined: 16 Sep 2009
Posts: 2368
Location: UK

PostPosted: Sat 27 Oct 2012, 08:02    Post subject:  

SFR wrote:
@Sc0ttman:
I _think_ I found the actual bug, it was /usr/bin/rwc-config:
Code:
exec /usr/local/RWC/rwc-config &

I've no idea why did I put & there, but for 90% it was the cause; most likely /usr/bin/rwc-config process was dying too slow. Interesting that it wasn't happend in Slacko..?
But thanks again, it was definitely RWC bug.
I hope it'll be ok now.

This one seems to work fine, excellent, thanks. Smile

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
rmcellig

Joined: 19 Nov 2011
Posts: 892
Location: Ottawa Ontario Canada

PostPosted: Mon 19 Nov 2012, 19:21    Post subject:  

Where can I find Gtkdialog 0.8.0 or later and how do I install it?
Back to top
View user's profile Send private message Visit poster's website 
SFR


Joined: 26 Oct 2011
Posts: 882

PostPosted: Tue 20 Nov 2012, 05:57    Post subject:  

Most likely you have it already (0.8.0), unless you're using some older Puppy at present.
Open terminal window and type:
Code:
gtkdialog4 --version

to be sure.

The latest Gtkdialog-0.8.2 you can compile yourself (here's the appropriate thread) or search for a .pet.
IIRC, I've seen Oldyeller's, RSH's (for Lupu) and 01micko's (for Slacko) packages somewhere in the forum.

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
rmcellig

Joined: 19 Nov 2011
Posts: 892
Location: Ottawa Ontario Canada

PostPosted: Tue 20 Nov 2012, 06:21    Post subject:  

Thanks!!

I'll see if I can find a pet. I really like RWC ( your wallpaper changer) !!
Back to top
View user's profile Send private message Visit poster's website 
rmcellig

Joined: 19 Nov 2011
Posts: 892
Location: Ottawa Ontario Canada

PostPosted: Tue 20 Nov 2012, 07:35    Post subject:  

After I install 1.6.4, I noticed it didn't have a menu entry so where did it install it and how do I invoke it? Thanks!!!
Back to top
View user's profile Send private message Visit poster's website 
SFR


Joined: 26 Oct 2011
Posts: 882

PostPosted: Tue 20 Nov 2012, 07:47    Post subject:  

On which Puppy you have installed it?
I've noticed that it happens in the latest Precise-5.4.1.
Try this:
1. Open terminal, type: fixmenus and wait until it finish.
2. Then go to Desktop -> JWM configuration and press "Restart JWM now?" button.

Should help...

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
rmcellig

Joined: 19 Nov 2011
Posts: 892
Location: Ottawa Ontario Canada

PostPosted: Tue 20 Nov 2012, 08:20    Post subject:  

I am using Openbox in Puppy Linux 5.2.8
Back to top
View user's profile Send private message Visit poster's website 
rmcellig

Joined: 19 Nov 2011
Posts: 892
Location: Ottawa Ontario Canada

PostPosted: Tue 20 Nov 2012, 08:25    Post subject:  

That worked. I can now launch it and it appears in the Desktop menu. I still have the GTKdialog error though even though I installed GTKdialog 0.8.2. Is there something else I need to do? Do I have to restart my machine?
Back to top
View user's profile Send private message Visit poster's website 
rmcellig

Joined: 19 Nov 2011
Posts: 892
Location: Ottawa Ontario Canada

PostPosted: Tue 20 Nov 2012, 08:32    Post subject:  

I uninstalled gtkdialog 0.8.2 and installed 0.8.0. Works fine now.!! Beautiful job!!!
Back to top
View user's profile Send private message Visit poster's website 
SFR


Joined: 26 Oct 2011
Posts: 882

PostPosted: Tue 20 Nov 2012, 09:03    Post subject:  

rmcellig wrote:
I uninstalled gtkdialog 0.8.2 and installed 0.8.0. Works fine now.!! Beautiful job!!!

Great! Smile

However since there's a lot of 'gtkdialog' binaries these days: gtkdialog4, gtkdialog5 and gtkdialog that can be a symlink to gtkdialog4 or gtkdialog5 Laughing - I changed the code a bit to try to handle this.

Additionally I fixed (hopefully) "Only one instance allowed" problem, which popped up again, this time in Lupu.

BTW, which "subversion" of Lupu you have, that there's no Gtkdialog-0.8.0 OOTB?
IIRC since Lupu-528-002 (or 004?) Playdayz had included it into.

The latest Lupu is 528-005-1:
http://www.murga-linux.com/puppy/viewtopic.php?p=622054#622054

Greetings!
RWC-1.6.6.pet
Description  Added support for Compiz in Slacko-5.4
pet

 Download 
Filename  RWC-1.6.6.pet 
Filesize  5.66 KB 
Downloaded  193 Time(s) 
RWC-1.6.5.pet
Description 
pet

 Download 
Filename  RWC-1.6.5.pet 
Filesize  5.67 KB 
Downloaded  354 Time(s) 

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.

Last edited by SFR on Wed 16 Jan 2013, 16:02; edited 1 time in total
Back to top
View user's profile Send private message 
rmcellig

Joined: 19 Nov 2011
Posts: 892
Location: Ottawa Ontario Canada

PostPosted: Tue 20 Nov 2012, 11:30    Post subject:  

I have a full install of 5.2.8 (005).
Back to top
View user's profile Send private message Visit poster's website 
Sky Aisling


Joined: 27 Jun 2009
Posts: 882
Location: Port Townsend, WA. USA

PostPosted: Wed 16 Jan 2013, 13:08    Post subject: Easy to use random wallpaper changer
Subject description: Not able to initiate in Puppy-528.005 running from Live CD and Pupsave on HDD
 

Hello,
I am running Puppy-528.005 from Live CD on a ZaReason Big Lap.
Pupsave file is on HDD.
I've downloaded RWC-1.6.5.pet.
Download went ok.
Menu/Desktop/Random Wallpaper Changer shows.
Dependencies check ok.
Nothing happenings when I initiate Random Wallpaper Changer from Menu/Desktop.
Any clues? Thank you.
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 882

PostPosted: Wed 16 Jan 2013, 14:52    Post subject:  

Hey Sky Aisling

Could you launch it from terminal window by:
Code:
rwc-config

and post the results?

Also:
Code:
gtkdialog --version
gtkdialog4 --version

would be helpful...

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
Sky Aisling


Joined: 27 Jun 2009
Posts: 882
Location: Port Townsend, WA. USA

PostPosted: Wed 16 Jan 2013, 15:18    Post subject: Easy to use random wallpaper changer
Subject description: Code to SFR
 

Coming at you! Smile

sh-4.1# rwc-config

** ERROR **: gtkdialog: Error in line 47, near token '<sensitive>': Unknown tag.

aborting...
/usr/local/RWC/rwc-config: line 361: 15597 Aborted $GTKDIALOG -p MAIN
sh-4.1#

sh-4.1# gtkdialog --version
gtkdialog version 0.7.21 (C) 2004, 2005, 2006, 2007 by Laszlo Pere
sh-4.1#

sh-4.1# gtkdialog4 --version
sh: gtkdialog4: command not found
sh-4.1#
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 882

PostPosted: Wed 16 Jan 2013, 15:40    Post subject:  

Thanks, as I thought - the lack of Gtkdialog-0.8.0 is the problem, but how's that possible..?
Rmcellig had the same kind of problem above.
Before Slacko I used to use Lupuplus-528.005-1 - Gtkdialog-0.8.0 present.
Just a while ago to ensure myself I downloaded Lupu-528.005 (from here) and Gtkdialog-0.8.0 also is present there...
I feel kinda weird... Confused Laughing

I can't find 0.8.0 package for Lupu anywhere, but hopefully this should work:
http://www.murga-linux.com/puppy/viewtopic.php?t=81928

EDIT:
Taking the opportunity, I uploaded v1.6.6 with added support for Compiz in latest Slacko-5.4 (xwin dummy1 & xwin dummy2).
Attached next to v1.6.5 few posts above.

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 6 [83 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0703s ][ Queries: 13 (0.0059s) ][ GZIP on ]