Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 10:45
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Problem automatically setting the time when not booting to X
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
edwin.evans

Joined: 15 Nov 2012
Posts: 60

PostPosted: Tue 20 Nov 2012, 14:43    Post_subject:  Problem automatically setting the time when not booting to X  

I'm having an odd problem. My situation is that I need to run with no keyboard, no mouse, and no monitor. I am running without starting X Windows since that brings up the XOrgWizard that prevents it from fully booting. But whatever I try I'm not able to get it to use the correct time.

I'm running ntpdate to update the time and it works fine if I run it after booting myself manually, but I can't get it to run automatically even though I am putting it in startup scripts and waiting a minute before calling it. Any idea? Does something hold up starting networking until all the scripts have run or something like that?
Back to top
View user's profile Send_private_message 
CatDude


Joined: 03 Jan 2007
Posts: 1479
Location: UK

PostPosted: Tue 20 Nov 2012, 16:20    Post_subject:  

Hello edwin.evans

edwin.evans wrote:
....I'm running ntpdate to update the time and it works fine if I run it after booting myself manually, but I can't get it to run automatically even though I am putting it in startup scripts and waiting a minute before calling it. Any idea? Does something hold up starting networking until all the scripts have run or something like that?


When you say "putting it in startup scripts",
do you mean you are putting the scripts in the: /root/Startup directory Question
If so, then you need to do as explained in this file: /root/Startup/README.txt
    Quote:
    Any executable or scripts (or symlink to) placed in this directory
    will be executed after the X desktop has loaded.

    This is handy if you want something to run automatically.

    You can easily create a "symlink" (symbolic link) to an executable.
    For example, say that you wanted to run /usr/local/bin/rubix (a game)
    everytime Puppy is started. Use ROX-Filer (the file manager) and open
    two windows, one on /usr/local/bin, the other on /root/Startup.
    Then just drag 'rubix' across and a menu will popup and ask if you want
    to copy, move or link, and you choose to link.

    Note, if you want to execute something at bootup and prior to X desktop
    loading, edit /etc/rc.d/rc.local.


Basically, add your script commands into: /etc/rc.d/rc.local

Hope this helps
CatDude
.

_________________

Back to top
View user's profile Send_private_message 
edwin.evans

Joined: 15 Nov 2012
Posts: 60

PostPosted: Wed 21 Nov 2012, 00:57    Post_subject:  

Thanks! I'm good now (see http://www.murga-linux.com/puppy/viewtopic.php?p=666047#666047)
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0438s ][ Queries: 12 (0.0037s) ][ GZIP on ]