Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 05:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Gramps: genealogical research program
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4 Next
Author Message
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Thu 06 Dec 2012, 20:25    Post_subject:  

@ramberler1939,

done, please see the first post.

@tallboy,

I've petified debian packages for graphviz & ttf-freefonts, on the first page, but no idea if they're working properly with gramps?

cheers
Back to top
View user's profile Send_private_message 
tallboy


Joined: 21 Sep 2010
Posts: 449
Location: Oslo, Norway

PostPosted: Sat 08 Dec 2012, 03:16    Post_subject:  

hi muggins, thank you for the latest additions.

I get some warnings when starting gramps from a terminal window, but if the spell checker, image metadata and map functions are not needed, all other functions seem to work as intended. On my dpup484beta4, gramps is also faster that earlier versions.

Code:
6200: WARNING: Spell.py: line 60: Spelling checker is not installed
12365: WARNING: bottombar.gpr.py: line 90: WARNING: pyexiv2 module not loaded.  Image metadata functionality will not be available.
12573: WARNING: geography.gpr.py: line 42: WARNING: osmgpsmap module not loaded. Geography functionality will not be available.
Traceback (most recent call last):
  File "/usr/share/gramps/gen/plug/_manager.py", line 219, in load_plugin
    _module = self.import_plugin(pdata)
  File "/usr/share/gramps/gen/plug/_manager.py", line 256, in import_plugin
    module = __import__(pdata.mod_name)
  File "/usr/share/gramps/plugins/docgen/LaTeXDoc.py", line 51, in <module>
    import Image
ImportError: No module named Image

When I tried to make graphs from the Reports menu, which gramps specifies that Graphviz is used to make, I get this error:
Code:
 error while loading shared libraries: libgvc.so.5: cannot open shared object file: No such file or directory

The font choices with the graphs, besides unspecified Default, are limited to PostScript / Helvetica or TrueType / FreeSans. I am not sure if that is any indication of an error with ttf-freefonts.

I also tried running gramps in retroprecise_5.4.2 with exactly the same results. Since both puppies are debian/ubuntu based, the libgvc.so.5 may be a debian error, I don't know if slacko puppies get the same error message.

Gramps seem to work very well without the additional files and libs, but I am in a phase where adding people to gramps is the main task, not generating reports with graphics, so I haven't tested all functionality.

tallboy

_________________
True freedom is a live Puppy on a multisession CD/DVD.
Back to top
View user's profile Send_private_message 
zippytex

Joined: 06 Feb 2009
Posts: 110

PostPosted: Wed 09 Jan 2013, 18:08    Post_subject:  Just downloaded the latest gramps you converted
Sub_title: Thanks!
 

Just a note to say thank you again for your hard work and it works just like you said it would. I am using it with the latest download of Slakopuppy.

I really appreciate your efforts as gramps frees me from Windows.

Thanks, Mary
Back to top
View user's profile Send_private_message 
zippytex

Joined: 06 Feb 2009
Posts: 110

PostPosted: Fri 29 Mar 2013, 18:19    Post_subject: gramps 3.4.3
Sub_title: update
 

Hi, I am always coming to you with my hand out. Were you going to update the pet pkgs with this update or wait till 4.0 comes out?

Thanks,
Mary
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Wed 03 Apr 2013, 12:35    Post_subject:  

@zippytex,

will try & upload 3.4.3 tomorrow...this time as an sfs.

cheers
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Fri 05 Apr 2013, 17:10    Post_subject:  

OK, I've repackaged the debian gramps as gramps-3.4.3-3.sfs. (9.43Mbytes)

It comes with techno's python, libdb-4.4.so &, (hopefully working?), graphviz.

I tried getting spellcheck & osmgpsmap working but it is beyond my python enfeebled peabrain (I even tried using python easy_install & pip but couldn't even get them to work!)
Back to top
View user's profile Send_private_message 
zippytex

Joined: 06 Feb 2009
Posts: 110

PostPosted: Tue 09 Apr 2013, 09:20    Post_subject:  Sorry it took so long....
Sub_title: Thanks
 

Sorry it took so long to respond, the email notification got lost in my junk mail folder. I have corrected that. Thanks so much for all the effort you put into making this available. I do love this program. Mary
Back to top
View user's profile Send_private_message 
zippytex

Joined: 06 Feb 2009
Posts: 110

PostPosted: Tue 11 Jun 2013, 14:23    Post_subject:  Re: Gramps: genealogical research program
Sub_title: last pet pkg version :)
 

Gramps has issued its last 3.xxx series update. From now on it will be 4.xxx and involves something called, python-gobject (>=3.3.2). As I understand it, they will keep the 3.xxx available for those with, I guess, older systems.

So, since this is the last update, would you consider doing it into a pet friendly form? It is 3.4.5 and after you install it, it comes out 3.4.5.1.

I want you to know that I really appreciate your efforts of support. I could mail you some great! chocolate chip cookies???

If you have the time, thanks and if not thanks!

Mary
Back to top
View user's profile Send_private_message 
don570


Joined: 10 Mar 2010
Posts: 3380
Location: Ontario

PostPosted: Sat 06 Jul 2013, 16:21    Post_subject: new gramps version  


new gramps version gramps-3.4.5
http://www1.datafilehost.com/d/92cf82e9


I dragged the newer version on top of older version and it seems to
work in Slacko 5.5 and Precise, but not in Raring (because of
problems with python). I could only make a pet version.

____________________________________________
Back to top
View user's profile Send_private_message 
zippytex

Joined: 06 Feb 2009
Posts: 110

PostPosted: Sat 06 Jul 2013, 19:29    Post_subject:  

http://www.murga-linux.com/puppy/viewtopic.php?t=87100

I used the info on this thread to install 3.4.5. It also worked on slacko 5.5

Thanks, Mary
Back to top
View user's profile Send_private_message 
Pelo


Joined: 10 Sep 2011
Posts: 3351
Location: Mer méditerrannée (1 kms°)

PostPosted: Sun 06 Oct 2013, 00:53    Post_subject: Gramps 3.4.1.1 Lucid 5.2.8 perfect !  

Gramps 3.4.1.1 Lucid 5.2.8 perfect ! The same for Slacko 5.5.
Very nice product.
Nice too with Puppy : DataCrow collections
click here
Back to top
View user's profile Send_private_message YIM 
fplum

Joined: 14 Oct 2013
Posts: 2

PostPosted: Mon 14 Oct 2013, 23:35    Post_subject: Launching Gramps
Sub_title: Gramps will not run
 

First let me introduce myself. I am Forrest Plumstead. I have used Ubuntu off and on for years. (More off then on.) I have just started using Puppy because it is lighter, and doesn't slow my older computer down.

I have also used Gramps before but not very much. So please treat me as ignorant with both Puppy and Gramps. Speak slowly use one syllable words. Use the Idiots guide and 101 approach. Thank you.

Now my problem. I used Puppy Package Manager to download and install
Gramps. I said yes to all the dependencies, and libraries. I found Gramps under Utilities, but when I click on it nothing happens.

Ideas, thoughts, suggestions, HELP!?!
Back to top
View user's profile Send_private_message 
fplum

Joined: 14 Oct 2013
Posts: 2

PostPosted: Tue 15 Oct 2013, 15:24    Post_subject: Launching Gramps
Sub_title: Gramps will not run
 

Today I ran Check Dependencies installed package. I received this message: gnome-mime-data keyutils krb5 libcanberra libgnome-keyring missing dependencies.
Back to top
View user's profile Send_private_message 
slackfan

Joined: 29 Mar 2009
Posts: 133

PostPosted: Fri 21 Mar 2014, 17:15    Post_subject:  

Hi

Until yet, to use Gramps I did restart my PC and use Ubuntu (actually 13.10) because I didn't know some SFS with Gramps for Puppy.

I did now discover in the last day that there is some one at the depository from RHS for its modulary system available for different Puplets (I am using the LazzYTHD_100 today because it starts on my PC without some Dialog directly in Xorg and works perfectly. it is enough for me!) and I did start gramps:

it works!

but

and it is not a Puppy question

how to make my data on Ubuntu usuable in Puppy in Gramps?

(if it is not possible, It make no sense to try to use gramps in Puppy as my genealogy is about ready in Ubuntu: I can and will not begin again! I will only add some lateral parents if I discover new data on the web).

kind regards

http://www.murga-linux.com/puppy/viewtopic.php?p=766273#766273
Back to top
View user's profile Send_private_message 
slackfan

Joined: 29 Mar 2009
Posts: 133

PostPosted: Sun 23 Mar 2014, 17:57    Post_subject:  

hm

it seems so, that it is perhaps necessary to start gramps in console mode to pass the name of the file. so the manpage of gramps if I do understand correctly.

but how to start a Python application out a LP2_xxx.sfs from console as it is not in the usual file system?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Documents
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0871s ][ Queries: 13 (0.0063s) ][ GZIP on ]