Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 26 Jul 2014, 09:23
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Installer le logiciel Open Sankore :tableau blanc [Résolu]
Moderators: Béèm, darkerror05
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 3 [38 Posts]   Goto page: 1, 2, 3 Next
Author Message
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Wed 05 Dec 2012, 09:43    Post subject:  Installer le logiciel Open Sankore :tableau blanc [Résolu]
Subject description: problème pour trouver les dépendances audio et video
 

Bonjour,
j'essaie, depuis une semaine, d'installer et d'utiliser le logiciel Open Sankore. Mais je rencontre un gros problème : impossible de lire un fichier audio et video.
J'ai essayé avec precise puppy, lxpup, ASRIV300 (lucid puppy) ubuntu et lubuntu. La seule qui fonctionne correctement c'est ubuntu 12.04, j'ai réussi une fois avec la lxpup de faire fonctionner le son, mais avec un bug quand on mettait sur mute.
Nous sommes plusieurs à rencontrer ce problème (site asri

Si quelqu'un pouvait m'aider à faire fonctionner ce logiciel ce serait un gros plus.
Merci

Il existe un post pour l'utilisation de ce logiciel, mais dans une version antérieure et sous toutou4.31.

Last edited by Tomasi on Thu 13 Feb 2014, 11:52; edited 1 time in total
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 2341
Location: France

PostPosted: Wed 05 Dec 2012, 13:08    Post subject:  

J'en profite pour relancer le fil du forum anglophone http://www.murga-linux.com/puppy/viewtopic.php?t=74893
Back to top
View user's profile Send private message Visit poster's website 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Thu 06 Dec 2012, 14:56    Post subject:    

Avec Lxpup
En console j'ai un message d'erreur supplémentaire
Code:
QGtkStyle was unable to detect the current GTK+ theme.



Avec Asri V300
J'arrive à faire tourner un fichier mp3
liste des dépendances

mais toujours pas de vidéo Twisted Evil
Back to top
View user's profile Send private message 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Thu 06 Dec 2012, 18:22    Post subject:  

Pour ceux que cela intéresse voici un pet qui contient les dépendances ci-dessus. J'ai enlevé le dossier doc.
http://dl.dropbox.com/u/51528036/dep_os.pet
Back to top
View user's profile Send private message 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Fri 07 Dec 2012, 18:18    Post subject:  

Voici un autre lien avec les dépendances pour la version lucid puppy asri profs iso

pet des dépendances


Et si il y a des courageux, j'ai réussi une installation fonctionnelle sur une lubuntu 12.04 dont voici la liste des paquets installés (malheureusement j'ai été obligé de faire une mise à jour avant d'installer open-sankore donc il y a beaucoup beaucoup beaucoup de paquets)
ici
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1650

PostPosted: Fri 07 Dec 2012, 19:45    Post subject:  

Bonsoir Tomasi,

Pourquoi remplacer des fichiers existants dans /lib, le cœur du système ! Comme ld-2.11.1.so, libc-2.11.1.so, qui sont déjà présents dans la même version à part une différence de taille et une date plus récente que sur la Lucid ???
Je ne comprend pas la raison de leurs remplacements ?

Certaines libs peuvent être upgradées comme la libglib2.0-0_2.24 en 2.0-0_2.24.1 (Ubuntu Lucid).

Idem dans pour les fichiers d'Alsa plus anciens que sur Lucid !
Comme HDA-Intel donc moins de cartes supportées pour cette série. Sad


Il serai également souhaitable de séparer les fichiers de langues...

Ou encore mieux pour éviter d'écraser les fichiers existants transformer le pet en sfs c'est moins risqué Wink

Cordialement,
Médor.
Capture-différences.jpg
 Description   
 Filesize   135.16 KB
 Viewed   608 Time(s)

Capture-différences.jpg


_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Sat 08 Dec 2012, 03:30    Post subject:  

Merci Médor, je vais regarder cela. Pour les libs déjà présentes, ce sont celles que j'installe suite au message d'erreur en console et en lançant ppm...
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1650

PostPosted: Sat 08 Dec 2012, 08:27    Post subject:  

Bonjour Tomasi,

Pour connaitre les dépendances d'une application :
ldd /usr/bin/xyz

Pour ne sortir que les dépendances manquantes :
ldd /usr/bin/xyz | grep 'not found'

Comme le traitement n'est pas dynamique, d'autres dépendances liées peuvent être absentes, il faut lancer le programme dans la Console une fois qu'il ne reste plus rien par : ldd blabla | grep 'not found', pour voir les messages d'erreurs du programme et tester toutes ses options !

Alsa par exemple est divisé en plusieurs paquets distincts, une partie seulement peut être absente...


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Sat 08 Dec 2012, 16:09    Post subject:  

Merci beaucoup Médor, je ne connaissais pas ces commandes et j'avais une méthode, comment dire, plus empirique : on lance et après on répare.

Je vias regarder de plus près.
Merci
Cordialement
Back to top
View user's profile Send private message 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Sat 08 Dec 2012, 17:42    Post subject:  

@Médor
Suite à la commande que tu indiques (grep not found)
voilà les lib installées (sur Asri V3.00 profs : base puppy lucid)

Puis en lançant le programme j'installe
-libgstreamer
-libstreamer-plugins-base

Effectivement, par ta méthode j'ai moins de paquets. Mais je bloque sur cela:

Ca je l'ai tout le temps
Code:
sh-4.1# /usr/local/Open-Sankore-2.00.00/run.sh
"/root/.local/share/data/Sankore/document/Sankore Document 2012-12-08 22-37-54.244/metadata.rdf"
link use3602 hasn't been detected!
Could not resolve property : pattern9092
Could not resolve property : pattern12010
socket(): Famille d'adresses non supportée par le protocole


Mais ce qui suit est nouveau
Code:

"Attention : Vous n'avez apparemment pas installées les plugins de base de GStreamer.
Le support audio et vidéo est désactivé"
Phonon::GStreamer::Backend: Failed to initialize GStreamer

(<unknown>:18396): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
"/root/.local/share/data/Sankore/document/Sankore Document 2012-12-08 22-37-54.244/metadata.rdf"

J'ai essayé d'installer phonon-gstreamer-backend mais cela ne change rien. J'installe alors gstreamer-plugins-base et ça passe

Ensuite deux nouveaux messages d'erreur
Code:
(gst-plugin-scanner:11135): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstlibvisual.so': libvisual-0.4.so.0: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type

(gst-plugin-scanner:11135): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvideo4linux.so': libgudev-1.0.so.0: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type

J'installe alors libgudev et libvisual.

A ce moment là, plus de messages d'erreur mais rien ne se passe...
Code:
sh-4.1# /usr/local/Open-Sankore-2.00.00/run.sh
"/root/.local/share/data/Sankore/document/Sankore Document 2012-12-08 23-50-00.917/metadata.rdf"
link use3602 hasn't been detected!
Could not resolve property : pattern9092
Could not resolve property : pattern12010
socket(): Famille d'adresses non supportée par le protocole
"/root/.local/share/data/Sankore/document/Sankore Document 2012-12-08 23-50-00.917/metadata.rdf"
sh-4.1#

Désolé d'être long mais je voulais être précis....

Open Sankore est un projet très intéressant et très important pour le monde éducatif : c'est le seul libre et est implanté en Afrique ou Haïti ; et si on arrive à le faire tourner sur puppy (lucid ou precise) il permettrait d'utiliser des pc moins puissants que ceux nécessaires pour les logiciels propriétaires...
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1650

PostPosted: Sat 08 Dec 2012, 19:10    Post subject:  

Bonsoir Tomasi,

Humm !

Une recherche (rapide) donne ce lien pour la doc d'Ubuntu-fr de sankore
Il existe un paquet pour Lucid (32Bits) sankore_1.25.00_lucid_scoude_i386.deb (51,7Mo) depuis ce site : serge.coude.net
Reste à voir les dépendances de ce dernier mais les paquets .deb doivent exister pour Lucid !

D'après la doc d'Ubuntu la version 2 de sankore fonctionne à partir de la Precise 12.04 LTS donc il faudrait passer à la Puppy Precise !

La Lucid a ses limites, elle ne peut pas ingurgiter tout les derniers paquets...


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Sat 08 Dec 2012, 19:27    Post subject:  

Merci pour le lien Médor, mais c'est pour une ancienne version d'open-sankore.
La dernière (2.0) est empaqueté sur le site d'Open-Sankore pour ubuntu 10.04 c'est pour cela que je veux essayer avec une puppy lucid. Je vais donc continuer à chercher et retenter en parallèle avec la lxpup de Jejy69 (mais j'avais également des problèmes). Mais déjà l'installation posait moins de problème sur une ubuntu 12.04 que sous lubuntu 12.04
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 2341
Location: France

PostPosted: Sat 08 Dec 2012, 22:18    Post subject:  

Tomasi wrote:
...
Open Sankore est un projet très intéressant et très important pour le monde éducatif : c'est le seul libre et est implanté en Afrique ou Haïti ; et si on arrive à le faire tourner sur puppy (lucid ou precise) il permettrait d'utiliser des pc moins puissants que ceux nécessaires pour les logiciels propriétaires...

Tomasi dit vrai.
Conjointement, Sankoré est une possibilité de faire entrer Linux dans les écoles et les petites entreprises (le tableau numérique étant souvent utilisé dans les pme).
Back to top
View user's profile Send private message Visit poster's website 
Tomasi

Joined: 14 Dec 2011
Posts: 41

PostPosted: Sun 09 Dec 2012, 13:13    Post subject:  

Bilan des tests en utilisant la méthode fournie par Médor:
sous lxpup et precise5.42 officiel : alors que toutes les dépendances sont installées (ldd n'indique plus rien et acun message dans la console).
Mais si le lecteur s'affiche dans le logiciel impossible de lancer la lecture... Evil or Very Mad
Back to top
View user's profile Send private message 
Médor


Joined: 26 May 2011
Posts: 1650

PostPosted: Sun 09 Dec 2012, 17:51    Post subject:  

Bonsoir,

J'ai fait un sfs du deb de sankore_1.25 (34 Mo juste en FR) celui-ci se lance sur Lucid-528 après avoir ajouté ces deux dépendances :
libt1-5_5.1.2-3build1_i386.deb et libpulse-mainloop-glib0_0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14.1_i386.deb
Le reste des dépendances comme QT sont dans le deb et sont placées dans des sous-répertoires de Sankore avec un run.sh :
Code:
#gnu blabla
#!/bin/sh
export LD_LIBRARY_PATH=`dirname $0`/qtlib:$LD_LIBRARY_PATH
`dirname $0`/Sankore\ 3.1


J'ai un problème avec le navigateur interne (qtweb) sur le site de Sankore car il cherche à se connecter en ftp : service non disponible par Neuf WiFi, ce qui provoque après une multitude de messages : ftp ... "Not connected", la fermeture de sankore en indiquant une erreur de segmentation !

Les libs intégrées de QT sont en version 4.7.3 !

Voici les messages dans la console au lancement :
Code:
# /usr/local/Sankore-1.25.00/run.sh
QPixmap::handle(): Pixmap is not an X11 class pixmap
QPixmap::handle(): Pixmap is not an X11 class pixmap
"/root/.local/share/data/Sankore/document/Sankore Document 2012-12-09 22-14-48.025/metadata.rdf"
QPixmap::handle(): Pixmap is not an X11 class pixmap
...


Comme je n'ai rien testé d'autre pour l'instant, il risque d'y avoir d'autres problèmes...

Même si c'est une ancienne version (ça reste relatif car de Septembre 2011) les dépendances incluses peuvent servir de base pour faire un sfs ou pet pour la dernière version mais l'intégration de QT dans le répertoire de Sankore risque d'alourdir inutilement la distro si l'on utilise déjà QT !


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto TTL
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 3 [38 Posts]   Goto page: 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0919s ][ Queries: 13 (0.0060s) ][ GZIP on ]