Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 21:19
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
DVDStyler-2.3.4-i686 compiled in Precise
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Wed 12 Dec 2012, 17:25    Post subject:  DVDStyler-2.3.4-i686 compiled in Precise  

i just did this compile of DVDStyler-2.3.4 in Precise Beta 5 sorry i am still using a old one http://www.dvdstyler.org/
This may work for other pups.


DVDStyler-2.3.4-i686.pet Download name has been change to vdvStyler-2.3.4-i686.pet because of mediafire blocking stuff that has dvd in its name.

required deps.
wxWidgets-2.9.4-i686.pet Download
wxsvg-1.1.9-i686.pet Download
gstreamer-0.10.36-i686.pet Download
gst-plugins-base-0.10.36-i686.pet Download

for playback you will need xine-ui and xine-lib from my post here http://www.murga-linux.com/puppy/viewtopic.php?t=80775

i really dont know what all is required because my os is heavily modified by now everything needed to run is in my repo http://www.mediafire.com/?mpv88jj3bp0m3 plus dev doc and nls. oh and other stuff you might want i dont post everything i compie cuzz well i dont like writing.

In my modified Precise my dvdauthor-0.7.1-i686.pet that i compiled
works great http://www.mediafire.com/?lg0oxax0r6xjm69 same as above name has changed to vdvauthor-0.7.1-i686.pet to suit site. --edited i had it set to download the doc pet not the program fixed now.

Last edited by scabz on Fri 14 Dec 2012, 21:39; edited 6 times in total
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
Geoffrey


Joined: 30 May 2010
Posts: 1477
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Wed 12 Dec 2012, 17:51    Post subject: Re: DVDStyler-2.3.4-i686 compiled in Precise  

Can't get the file DVDStyler-2.3.4-i686.pet.
Quote:
The file you requested has been blocked for a violation of our Terms of Service.

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Wed 12 Dec 2012, 18:04    Post subject: Re: DVDStyler-2.3.4-i686 compiled in Precise  

Geoffrey wrote:
Can't get the file DVDStyler-2.3.4-i686.pet.
Quote:
The file you requested has been blocked for a violation of our Terms of Service.


weird i can download it fine , did i violate some rules i hope not.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Wed 12 Dec 2012, 18:11    Post subject:  

ok very weird i figured it out everything with the word dvd in it will not let me download if i am sighned out of mediafire but when sighned in i can download fine so i think they have some block on anything with the word dvd in it.
anyone have a place i can upload this to.

--edit maybe i can just change the names of the pets
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Wed 12 Dec 2012, 20:10    Post subject:  

Names have been changed to make downloads work.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Thu 13 Dec 2012, 16:44    Post subject:  

thanks for this Cool

so mediafire doesn't like anything with dvd in the name Evil or Very Mad

I got your package to work on Precise 5.4.1, but had to install

libgstreamer and libgstreamer-plugins-base for ubuntu precise main repository first.

Seems a little buggy, keep getting error messages, do you?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Thu 13 Dec 2012, 16:59    Post subject:  

maybe try my gstreamer from my repo http://www.mediafire.com/?mpv88jj3bp0m3 i have most every gst plugin. Sorry i have alot of stuff i compiled in my precise os so cant list and track down all deps without using too much time.

i have made like 6 dvd's with it, so works great for me, but there are lots of stuff that can cause errors, like changing some settings will fix some issues or error can be caused by mixing pal and ntsc or just bad files post you error message i might be able to help. Sorry i am bad at explaining stuff.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Thu 13 Dec 2012, 17:31    Post subject:  

i am also using my own compile of ffmpeg with this config
Code:
./configure --prefix=/usr --disable-static --enable-shared --enable-nonfree --arch=i686 --enable-libfaac --enable-libmp3lame --enable-libvpx --enable-libx264 --enable-runtime-cpudetect --enable-gpl --enable-libtheora --enable-libvorbis --enable-libxvid --enable-libschroedinger --enable-libopencore-amrnb --enable-libopencore-amrwb --disable-debug --enable-bzlib --enable-zlib --enable-libspeex --enable-version3 --enable-x11grab --enable-libdc1394 --enable-vdpau --enable-vaapi --enable-small --enable-openal


this is what was made after compiles of stuff for ffmpeg


my ffmpeg might help also i dont know though, its all in my repo

i also use my compile of dvdauthor 0.7.1
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Fri 14 Dec 2012, 07:15    Post subject:  

Many thanks, I installed you gstreamer and plugins-base (x.0.36) and it seem to work a bit better.

One problem I had was with the sound setting, using ac3 audio encoding lend to the program crashing with Segmentation fault
Quote:

# dvdstyler
...
Output #0, dvd, to '/mnt/home/tempfolders/tempBurn/dvd_tmp/dvd-tmp/menu1-0.mpg_bg.mpg':
Stream #0.0: Video: mpeg2video, yuv420p, 720x576 [PAR 16:15 DAR 4:3], q=2-31, 6000 kb/s, 90k tbn, 25 tbc
Stream #0.1: Audio: ac3, 48000 Hz, 2 channels, fltp, 64 kb/s
[ac3 @ 0x86fcfc0] Specified sample_fmt is not supported.
Segmentation fault


however, using mp2 audio encoding resulted in a successful burn

Cool

BTW i've added a link on wiki page
http://puppylinux.org/wikka/DVDStyler

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
scabz


Joined: 30 Apr 2009
Posts: 308
Location: Tallahassee FL US

PostPosted: Fri 14 Dec 2012, 12:52    Post subject:  

i am glad you got it working, sorry about the ac3 problem i knew about that just didnt remember to say anything.So that carried over to recent Precise builds.i am still on Precise beta5 and i know some of the libs are different but not many, i am happy it works on recent Precise builds.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
darkcity


Joined: 23 May 2010
Posts: 2479
Location: near here

PostPosted: Mon 17 Dec 2012, 15:14    Post subject:  

Yep, its working on Precise 5.4.1 quite well. Will report on 5.4.2 when I upgrade ; - )
_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0687s ][ Queries: 12 (0.0045s) ][ GZIP on ]