Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 06:07
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Xwindows not running for Users
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
sankarv

Joined: 09 Mar 2006
Posts: 18

PostPosted: Tue 15 May 2007, 00:45    Post subject:  Xwindows not running for Users
Subject description: permission problem
 

I have installed Puppy 2.14 to my hard drive.



I have modified the /etc/inittab by just replacing /usr/bin/autologinroot with /usr/bin/login (i just replaced 'autologinroot' with 'login') so that it asks for login.



Then i created an user "test" with adduser command. I tried to login as test, it is logging in but i cannot run xwindows. When i tried with startx it says permission denied when it tries to access the /etc/X11/* directory, the /tmp/* directory and returns to prompt saying startx failed.



pls help me getting run xwindows with normal user....
Back to top
View user's profile Send private message AIM Address Yahoo Messenger 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Tue 15 May 2007, 01:16    Post subject:  

you need to make a number of changes ... for example, you must run X as root whether you like it or not, so that you have the permissions to access the hardware using the video drivers ... so X (Xvesa or Xorg) must be owned by root and the uid bit must be set

when X starts, it accesses and possibly changes certain files in /etc, /tmp, /root, /var etc etc etc ... you need to set the permissions on those various files

you will need to set the permissions on various devices so that they will work properly with your unprivileged user

various programs like the drive mounter programs will need to be rewritten

and if you make one mistake, you can create security problems that would allow others to access your machine and data ... running as an unprivileged user is not an automatic guarantee that you have a secure system

it is possible to run Puppy as an unprivileged user, but if you really do not want to run as root, it might be better to use another operating system ... GrafPup, for example
Back to top
View user's profile Send private message 
Lyle

Joined: 29 Dec 2012
Posts: 3

PostPosted: Sun 30 Dec 2012, 14:59    Post subject:  

Is this still true? That it's best to always run as root in Puppy LInux?

I just started running 5.4.3 and was surprised that X didn't start automatically for a non-root user.

It's ok. But I've spent years brow-beating my poor sysadmin-self not to work as root all the time.

Thanks....Lyle
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0437s ][ Queries: 12 (0.0042s) ][ GZIP on ]