Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Nov 2014, 20:20
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
glibc upgrade
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4 Next
Author Message
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Sun 30 Dec 2012, 19:17    Post_subject: glibc upgrade  

Thank you jamesbond and pemasu for the clarification.

So Wary Puppy does include glibc2 by default --just not the version needed to run OpenOffice?

It may be that I am most confused by the file names and versioning... Hmm... it wouldn't be the first time I was confused... Confused Rolling Eyes That said, I owe simargl an apology for having misunderstood what he was trying to tell me.

In the readme file for OpenOffice 3.4 here are the system requirements:


Quote:
* Linux Kernel version 2.6.18 or higher
* glibc2 version 2.5 or higher
* gtk version 2.10.4 or higher
* Pentium compatible PC (Pentium III or Athlon recommended)
* 256 MB RAM (512 MB RAM recommended)
* Up to 1.55 GB available hard disk space
* X Server with 1024x768 resolution (higher resolution recommended), with at least 256 colors
* Window Manager
* Gnome 2.16 or higher, with the gail 1.8.6 and the at-spi 1.7 packages, required for support of assistive technology tools (AT tools)


Notice that it refers to glibc2 yet in Wary Puppy I can only find reference to glibc in Puppy Package Manager and when I do a file search of my system. (By the way, PPM shows glibc -2.6.1.-1 in the repos as the latest version.) So my conclusion was that Wary Puppy does not have glibc2, hence the confusion. In short, "it's all in the languaging" so-to-speak.

While I have installed the glibc2 package from the download link provided by Tman and it appears to have not caused any problems, yet, I will heed your warnings that this upgrade could be risky and advise everyone to make sure they have backed up their important files before doing this update so as to try running Apache OpenOffice.

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send_private_message 
jamesbond

Joined: 26 Feb 2007
Posts: 2230
Location: The Blue Marble

PostPosted: Sun 30 Dec 2012, 19:36    Post_subject: Re: glibc upgrade  

Monsie wrote:
Thank you jamesbond and pemasu for the clarification.
No worries, we're helping each other here.

Quote:
So Wary Puppy does include glibc2 by default just not the version needed to run OpenOffice?
Correct. glibc, glibc2, libc6 - all those are just packaging names. I just pulled out my copy of Wary 5.0 (the first ever Wary) and it came with glibc 2.10.1 - the same as the pet pointed by pemasu above.

Quote:
In the readme file for OpenOffice 3.4 here are the system requirements:


Quote:
* Linux Kernel version 2.6.18 or higher
* glibc2 version 2.5 or higher
* gtk version 2.10.4 or higher
* Pentium compatible PC (Pentium III or Athlon recommended)
* 256 MB RAM (512 MB RAM recommended)
* Up to 1.55 GB available hard disk space
* X Server with 1024x768 resolution (higher resolution recommended), with at least 256 colors
* Window Manager
* Gnome 2.16 or higher, with the gail 1.8.6 and the at-spi 1.7 packages, required for support of assistive technology tools (AT tools)
It said it requires glibc 2.5 - so by logic it should work with Wary's glibc, which is 2.10.1 (newer than 2.5). Why it doesn't work, I have no idea Shocked

Quote:
Notice that it refers to glibc2 yet in Wary Puppy I can only find reference to glibc in Puppy Package Manager and when I do a file search of my system.
Yes, it's just packaging names.

Quote:
(By the way, PPM shows glibc -2.6.1.-1 in the repos as the latest version.) So my conclusion was that Wary Puppy does not have glibc2, hence the confusion. In short, "it's all in the languaging" so-to-speak.
Not your fault. The names have changed a couple of times, and to make it more confusing every distro may package / name them differently. Look at Barry's exasperation with Ubuntu's package splitting (and naming) Laughing But Wary does have "glibc2". In fact, it is better to state the version - Wary has glibc 2.10.1. Now, why PPM only shows glibc 2.6.1, I believe that's another problem as pemasu has pointed out that glibc-2.10.1-1-w5c.pet is in fact available in Wary's PPM repository.

Quote:
While I have installed the glibc2 package from the download link provided by Tman and it appears to have not caused any problems, yet, I will heed your warnings that this upgrade could be risky and advise everyone to make sure they have backed up their important files before doing this update so as to try running Apache OpenOffice.
I think the practice of replacing glibc is quite popular in Puppy community. As long as people are aware of the consequences (and hopefully able to undo the damage if it happens), then that's fine.

cheers!

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
amigo

Joined: 02 Apr 2007
Posts: 2276

PostPosted: Mon 31 Dec 2012, 04:45    Post_subject:  

There is no such thing as 'glibc2'. libc is a generic name for any of the c-lib alternatives. libc5 was the old original (circa Slackware 8.0 and older). When the glibc(GNU libc) project was started, they used the alternate name 'libc6' since it was not binary-compatrible with libc5.

I'm wondering if someone hasn't been confusing glibc2 with glib2??

Anyway, the whole idea of upgrading glibc without doing a complete upgrade is bound to fail -at some point. Nerly everything on your system uses glibc -fully-statically-linked programs being the exception (like /sbin/init -the real one, which Puppy does not have).
If you simply upgrade glibc and not all the rest, then you run the risk of having old programs not be compatible with the new glibc -resulting in hard-to-diagnose failures.

If you need a newer glibc for a certain program, then place the newer glibc in some out-of-the-way path and write a wrapper for the program which adds LD_LIBRARY_PATH to point to the newer library. This avoids all conflicts.
Back to top
View user's profile Send_private_message 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Tue 01 Jan 2013, 01:19    Post_subject:  

amigo wrote:
Quote:
If you need a newer glibc for a certain program, then place the newer glibc in some out-of-the-way path and write a wrapper for the program which adds LD_LIBRARY_PATH to point to the newer library. This avoids all conflicts.

Can anyone demonstrate how to do this, in steps?
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Tue 01 Jan 2013, 01:25    Post_subject:  

Put the updated glibc libraries in a folder, lets say $HOME/newer-glibc

Now, let's say the program you want to run is google-chrome.

Write a script called google-chrome.sh:
Code:
#!/bin/bash
LD_LIBRARY_PATH=$HOME/newer-glibc:$LD_LIBRARY_PATH
exec google-chrome "$@"


Put that script in your executable path and call it however you like.

NOTE: just an example for demo purposes

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Tue 01 Jan 2013, 05:23    Post_subject:  

01micko wrote:
Quote:
Put that script in your executable path and call it however you like.

Thanks, Mick. Smile
Does this mean I can open a Window / Terminal Here in the folder, then write the script?

Edit:
(See below)
Thanks, amigo. Smile

Edited_time_total
Back to top
View user's profile Send_private_message 
amigo

Joined: 02 Apr 2007
Posts: 2276

PostPosted: Tue 01 Jan 2013, 07:48    Post_subject:  

Browse with the filer to a place in your PATH, then right-click on the filer window and choose New -> File. Then open the new file with an editor and compose/paste your script and save. Be sure to make the file executable so it can be run.
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 635

PostPosted: Thu 03 Jan 2013, 07:01    Post_subject: Glibc or glibc2?  

The Debian packages site reported that glibc is a virtual package of what you name glibc2 or libc6. I tried the 01micko suggestion in wary. With peazip I put the content of libc6 in a DIR. With the script launching Firefox I used the command LD_LIBRARY_PATH indicating the paths of the subdirectories of DIR with libc6 and I tried to install a recent google-talkplugin which needs glibc >= 2.11. I did have not success: error in the terminal "file too short" with a library of the debian libc6 package. Perhaps we should compile for wary glibc source:

http://ftp.gnu.org/gnu/glibc/

I don't have the skill to do this. With the compiled glibc (make install DESTDIR=DIR...) we should try the 01micko suggestion.
Back to top
View user's profile Send_private_message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Sat 05 Jan 2013, 18:51    Post_subject: Re: Glibc or glibc2?  

watchdog wrote:
Perhaps we should compile for wary glibc source:

http://ftp.gnu.org/gnu/glibc/

I don't have the skill to do this. With the compiled glibc (make install DESTDIR=DIR...) we should try the 01micko suggestion.


Compiling glibc from source is no easy feat... it could be called: The mother of all compilations Laughing An easier approach might be to re-work the debian package for libc6-2.11.3-4 It turns out that the debian package overwrites the existing libc files in Puppy. While it appears to work at first, attempts to un-install this package will break my Wary system... as I later found out... so be sure to have a backup in place.

I have re-packaged the debian files for libc6 using the local pathway. (In fact, the developers recommend compiling the source to the local directory so as not to risk breaking your existing configuration). While I have installed and un-installed my re-packaged Pet numerous times without any apparent repercussions, I cannot confirm that it works because I am having difficulties writing a workable script to test Apache OpenOffice.

Here is the script I wrote and put in /opt/openoffice.org3/program directory while following Mick's example:
Code:
#!/bin/sh
LD_LIBRARY_PATH=$usr/local/lib:$LD_LIBRARY_PATH
exec soffice.bin "$@"

The script is executable, and the new libc files have full permissions also.

Here is an excerpt from my xerrors.log

Quote:
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /opt/openoffice.org3/program/../basis-link/program/libsvt.so)


So it shows that OpenOffice does need libc6-2.11 or better... which means the system requirements in the documentation need to be updated.... but also, that OpenOffice is not able to detect the path to the newer libc6 files...

At this point, I have worked on this for two days, and now I feel stuck --ideas anyone?

Thanks,
Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send_private_message 
postfs1


Joined: 27 Mar 2010
Posts: 831

PostPosted: Sat 05 Jan 2013, 20:41    Post_subject: Re: Glibc or glibc2?  

Monsie wrote:
...
At this point, I have worked on this for two days, and now I feel stuck --ideas anyone?
...


Maybe there are some tools which will give statistics about realization of paths, which new version of library does require.

Arrow http://www.graphviz.org/

Arrow http://en.wikipedia.org/wiki/Strace
Information about the Internet page: Text is available under the Creative Commons Attribution-ShareAlike License; additional terms may apply. See Terms of Use for details.

_________________
  • I don't know why laboratories are named a hospitals.
  • The alive personage is like a tea bag with granules of unknown density inside, at that one the packet was made of organic material and was placed in the evaporated liquid or liquid.

Back to top
View user's profile Send_private_message 
Semme

Joined: 07 Aug 2011
Posts: 4042
Location: World_Hub

PostPosted: Sat 05 Jan 2013, 21:07    Post_subject:  

For examples sake, how would this poster pipe something like freshclam via script?
Code:
#!/bin/bash
LD_LIBRARY_PATH=$HOME/glibc-2.15:$LD_LIBRARY_PATH
exec ???
Back to top
View user's profile Send_private_message 
jamesbond

Joined: 26 Feb 2007
Posts: 2230
Location: The Blue Marble

PostPosted: Sat 05 Jan 2013, 21:56    Post_subject:  

Monsie,

I'm assuming you put the copy of debian's glibc in /usr/local/lib (is this what you call as the "local pathway"?).

Your code was:
Quote:
#!/bin/sh
LD_LIBRARY_PATH=$usr/local/lib:$LD_LIBRARY_PATH
exec soffice.bin "$@"

It should be
Quote:
#!/bin/sh
LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
exec soffice.bin "$@"

Note: no dollar-sign in front of /usr/local/lib

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
Monsie


Joined: 01 Dec 2011
Posts: 633
Location: Kamloops BC Canada

PostPosted: Sun 06 Jan 2013, 07:54    Post_subject: glibc upgrade  

jamesbond wrote:
Monsie,

I'm assuming you put the copy of debian's glibc in /usr/local/lib (is this what you call as the "local pathway"?)

Your code was:
Quote:
#!/bin/sh
LD_LIBRARY_PATH=$usr/local/lib:$LD_LIBRARY_PATH
exec soffice.bin "$@"

It should be
Quote:
#!/bin/sh
LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
exec soffice.bin "$@"

Note: no dollar-sign in front of /usr/local/lib


Thanks, jamesbond

Yes, that is what I refer to as the local pathway... and that small change to the script that I overlooked makes a lot of sense. Smile

Unfortunately, I still cannot get the script to work. I think the script is okay, in and of itself so-to-speak, but just not quite what is needed here. OpenOffice looks for the libc files in the main /lib folder by default, and I suspect one or more of its (OpenOffice) existing files needs to be changed in order to point OpenOffice in the right direction... So far, I am unable to find such file(s) or related code.

I went to the Apache OpenOffice forums and found that indeed other users are having a problem with older libc files who want to run OpenOffice 3.4 --especially the Redhat folks. While I wasn't able to find the kind of answer to the problem here, I did find out that the Apache developers also compiled OpenOffice 3.4 for distros with glibc 2.5 -- i.e. older than glibc 2.11.1 the latter of which is a system requirement for the regular download of OpenOffice 3.4 --hope this isn't too confusing. So, it turns out that there is another easier solution for Wary Puppy users and OpenOffice 3.4 and I will post more about this in Mick's thread re: OpenOffice when I've had a chance to test this alternate version further.... hopefully, later today.

In the mean time, it would still be useful to resolve this issue of putting an upgraded glibc package in a safe location along with a working script to point where to load the necessary libc6 files...

Monsie

_________________
My username is pronounced: "mun-see". Derived from my surname, it was my nickname throughout high school.
Back to top
View user's profile Send_private_message 
jamesbond

Joined: 26 Feb 2007
Posts: 2230
Location: The Blue Marble

PostPosted: Sun 06 Jan 2013, 08:18    Post_subject:  

Actually, there was this large elephant sitting in my eye but I can't see (that is, I gave your incomplete not working advice Embarassed ) ... the script should have been this:

Quote:
#!/bin/sh
export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
exec soffice.bin "$@"


Note the "export" in blue colour Embarassed

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sun 06 Jan 2013, 08:50    Post_subject:  

Nah.. I'll take that one, triple Embarassed Embarassed Embarassed
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 2 of 4 Posts_count   Goto page: Previous 1, 2, 3, 4 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1192s ][ Queries: 13 (0.0079s) ][ GZIP on ]