Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 22 Nov 2014, 19:39
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Can't ssh to puppy machine- connection refused. <SOLVED>
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
Nexus

Joined: 08 Jun 2012
Posts: 14

PostPosted: Thu 03 Jan 2013, 01:18    Post subject:  Can't ssh to puppy machine- connection refused. <SOLVED>
Subject description: Turn off the firewall!
 

Hi all,

I have two laptops, a new one running Mint and an ancient IBM Thinkpad running Puppy. I want to set up synergy on them so that I can use the old lappy as a second screen.

I've successfully set up IPs for both computers and I can ping both ways. I can ssh the Mint machine from the Puppy one, but not the other way round. The error I get is

ssh: connect to host 192.168.1.2 port 22: Connection refused

Does anyone know how to fix this?

Last edited by Nexus on Thu 03 Jan 2013, 06:14; edited 1 time in total
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Thu 03 Jan 2013, 02:25    Post subject:  

Puppy by default doesn't ship with ssh server, just client. You can install it though. In Slacko, the infrastructure is already there, just install it from the PPM, (search for openssh) Make sure that /etc/init.d/sshd is set to executable and start the service. This will initiate your gpg key.

If not running Slacko then it should be in the PPM, or search this forum.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Nexus

Joined: 08 Jun 2012
Posts: 14

PostPosted: Thu 03 Jan 2013, 03:02    Post subject:  

sshd is configured right and is running, but I still cannot connect. Anyway, wouldn't that mean I can't connect from Puppy to Mint, rather than the other way round?
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Thu 03 Jan 2013, 04:08    Post subject:  

The pup machine needs to be running sshd as it's the server if you want to log into it remotely. Just check your config file (/etc/ssh/sshd_config). something like this should do it:
Code:
# override default of no subsystems
Subsystem   sftp   /usr/libexec/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
   X11Forwarding yes
   AllowTcpForwarding yes
   X11DisplayOffset 10
   X11UseLocalhost yes
Once that's good restart the service then see if you can log in from the remote Mint box.

BTW: just tested by ssh with my raspberry pi running slackware arm to one of my laptops running slacko-5.4. Also works in the other direction too.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Nexus

Joined: 08 Jun 2012
Posts: 14

PostPosted: Thu 03 Jan 2013, 06:14    Post subject:  

GAH! Problem solved. It turned out to be the firewall on pup. I should have taken "connection refused" in its most literal sense.
Back to top
View user's profile Send private message 
zrdc28

Joined: 06 Jan 2013
Posts: 1

PostPosted: Sun 06 Jan 2013, 02:55    Post subject:  

Nexus wrote:
GAH! Problem solved. It turned out to be the firewall on pup. I should have taken "connection refused" in its most literal sense.


How did you do it I have the same problem and have tried manipulating the firewall with no results. Please be gentle with me as I am new to puppy.
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Tue 08 Jan 2013, 06:27    Post subject:  

setting the ssh server is easier if you first ssh your localhost.

check the pic in here
http://www.murga-linux.com/puppy/viewtopic.php?search_id=706405762&t=63523

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0596s ][ Queries: 12 (0.0115s) ][ GZIP on ]