Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 05:57
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Installed Wary won't boot (PC running, black screen)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
kedit


Joined: 03 Jan 2013
Posts: 7
Location: Latvija

PostPosted: Thu 03 Jan 2013, 20:59    Post subject:  Installed Wary won't boot (PC running, black screen)  

I installed Wary (puppy linux) on HDD (Full installation) on separate partition.

Puppy counts:
sda1 (Windows partition)
sda2 (Wary linux)
sdb1 (Windows Data storage)

I can boot Windows OS, but can't boot Wary - PC is running but screen is black and nothing happens.

grub menu.lst:

title Windows (on /dev/sda1)
rootnoverify (hd0,0)
makeactive
chainloader +1

title Linux (on /dev/sda2)
root (hd0,1)
kernel /boot/vmlinuz root=/dev/sda2 ro vga=773

Maybe I should change vga=773 to something?
Also I don't understand (hd0, 0)? Does it mean first HDD and first partition?

Any advice!?
Thank You!
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 03 Jan 2013, 21:42    Post subject:  

What is the make and model of the pc?
Which version of Wary?
(hd0,0) is correct.
You might try vga=normal.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 606

PostPosted: Fri 04 Jan 2013, 04:13    Post subject: Re: Can't boot Wary linux (PC running, black screen)  

kedit wrote:

title Linux (on /dev/sda2)
root (hd0,1)
kernel /boot/vmlinuz root=/dev/sda2 ro vga=773
Any advice!?
Thank You!


Are you sure vmlinuz is in /boot? I am not expert of full install but I found that the right line should be:

kernel /vmlinuz pmedia=atahd root=/dev/sda2 ro vga=773

Substitute atahd with that of your case.
Back to top
View user's profile Send private message 
kedit


Joined: 03 Jan 2013
Posts: 7
Location: Latvija

PostPosted: Fri 04 Jan 2013, 13:59    Post subject:  

rjbrewer: I changed vga To normal. And don't know how, but it's working! Now I am from Full installation (booted from HDD)
Thank, You!

watchdog: Yes, vmlinuz is under /boot!

I have PC:
AMD Duron (TM) CPU 850Mhz, 512Mb of RAM
installed:
Wary Puppy version 5.3, released Apr 2012 (I looked in HELP)
maybe should make some command in terminal to know really version?
uname -a
Linux puppypc7862 2.6.32.59 #1 Mon Apr 2 19:19:10 GMT-8 2012 1686 GNU/Linux

First, I booted in Linux from HDD, it had no network interface found.
But from live CD it worked fine.

Some how I trayed some network tools, later I choosed random network driver? one of REALTEK, and some more steps and I got Network ruuning.
So I can be on internet Wink

Thank You!
Now I have access and it's time to set up tools for edu Wink
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0476s ][ Queries: 12 (0.0074s) ][ GZIP on ]