Posted: Fri 04 Jan 2013, 21:34 Post subject:
Perl version mismatch
I'm trying to use ndiswrapper to get wireless, but this is the error I get:
Perl API version v5.16.0 of Fcntl does not match v5.14.0 at /usr/share/perl15/XSLoader.pm line 92.
Compilation failed in require at /usr/sbin/ndiswrapper-1.9 line 20.
BEGIN failed--compilation aborted at /usr/sbin/ndiswrapper-1.9 line 20.
perl --version confirms that I am using version 5.14.2 (not 5.14.0!), which came with my fresh full install of Precise Puppy 5.4.3. No idea where these references to 5.16 come from. How can I fix this problem?
Joined: 29 Sep 2011 Posts: 103 Location: Georgia USA
Posted: Sat 05 Jan 2013, 13:51 Post subject:
If Perl comes with Precise and you have the devx loaded you could possibly have two versions of Perl on your machine. I had a similar situation with Python on Puppy 5.2.8. Both versions of Python were too comingled to fix so I reloaded Puppy from backup. _________________ Puppy 528, Full Install
You cannot post new topics in this forum You cannot reply to topics in this forum You cannot edit your posts in this forum You cannot delete your posts in this forum You cannot vote in polls in this forum You cannot attach files in this forum You can download files in this forum