Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 09:57
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
LazY Puppy 2.0.2 Final - Build 0.0.5 DE!
Moderators: MU
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 33 of 50 Posts_count   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34, 35, ..., 48, 49, 50 Next
Author Message
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Sun 06 Jan 2013, 11:03    Post_subject:  

Hallo, Wolfgang.

Wolfgang wrote:
Hallo Rainer,

in 203 funktioniert die Ladefunktion vom Server für alle abhängigen so weit richtig gut. In 202 habe ich es noch nicht getestet.
Hat das schon jemand ausprobiert?


RSH wrote:
Da dieses PET für Wolfgangs PhyTech zum Testen gedacht ist, poste ich dies hier. Es sollte zwar in allen LazY Puppy Versionen funtkionieren, ist aber nicht als offizielles Update gedacht.

Besser NICHT für das offizielle 2.0.2 verwenden. Ich werde es gleich wieder entfernen, da es ja eigentlich nur für Dein 2.0.3 zum Testen gedacht war.

Wolfgang wrote:
Beim Nachladen des eigentlichen Programms z.B. LP2_Gnumeric-1.10.13.sfs
gibt es die Fehlermeldung "Broken Link" und dann sinngemäß: Datei nicht gefunden, obwohl sie natürlich vorhanden ist.

Dafür gibt es eine ganz einfache Erklärung.

Gnumeric wird üblicherweise von smokey01.com heruntergeladen (so definiert, durch den angegebenen Link, bei der Startskripterzeugung). Die Datei ist dort aber nicht vorhanden, da sie in 2.0.2 noch eingebaut ist.

Für 2.0.3 hatte ich Dir eine Version gesendet.

Wenn Du nun aber versuchst, Gnumeric von Deinem eigenen Server herunterzuladen, dann muß Gnumeric auch in der entsprechenden Liste (in /usr/sbin/ceelab/lp2_sys_data/LP2_SFS_Apps_Ext) als Dein eigenes Modul definiert (angegeben) sein. Da es sich hierbei jedoch um ein Modul handelt, das zuvor in meiner eigenen Liste definiert wurde, muß es natürlich aus dieser Liste entfernt werden. Denn Deine Liste wird zuletzt abgefragt; folglich wird sie nicht abgefragt, wenn ein Modul bereits in einer der anderen Listen (selbes Verzeichnis!) gefunden wurde.

Hattest Du es bereits in Deiner Liste angegeben? Warum wirfst Du dann nicht auch einen Blick in die anderen Dateien des Verzeichnisses?

RSH wrote:
So weit ich das im Kopf habe kam das auch bei 202 vor.

Da mußt Du Dich irren, denn:
RSH wrote:
da sie in 2.0.2 noch eingebaut ist.

Wolfgang wrote:
Hat schon mal jemand alle sfs im Bootverzeichnis gehabt und damit gearbeitet?

Ja, ich. Ständig. Und sogar in mehreren Verzeichnissen (für 2.0.3, 2.0.2 und Osiris Studio (ein LazY Puppy Derivat)).

Wolfgang wrote:
Bei mir treten dann merkwürdige Effekte auf z.B. werden abhängige sfs geladen die im Hauptprogramm überhaupt nicht definiert sind.

Also: es ist immer sinnvoll, erhaltene Informationen nicht nur im entsprechenden Kontext zu betrachten; zur Kenntnis zu nehmen, sondern sie eben auch in einem anderen Kontext zu betrachten; zu Rate zu ziehen.

Bezüglich Deiner Anfrage in einer Deiner letzten PMs bezüglich einer Liste von ausgebauten Programmen, die nun als Abhängigkeit hinzugeladen werden, teilte ich Dir mit, daß ich aktuell über keine solche Liste verfüge. Als Nebeninformation übermittelte ich Dir, daß das Erweiterungs SFS (XXX_Extension.sfs) die meisten dieser ausgebauten Programme (Qt, SQLite GtkMM, etc.) als zu ladende Abhängigkeiten definiert hat).

RSH sinngemäß wrote:
...falls Du Dich einmal wunderst, wo die vielen geladenen Module plötzlich herkommen.

Während der Entwicklung der LazY Puppy Bootoptionen (und auch danach hin und wieder) veröffentlichte ich eine Liste der Bootoptionen im Forum bzw. machte ich deutlich, daß das Erweiterungs SFS immer beim Starten hinzugeladen wird, wenn es vorhanden ist (gefunden wird). Um dieses NICHT zu laden, muß eine spezielle Bootoption gesetzt sein.

LazY Puppy Guides zu den Bootoptionen wrote:
lpextsfs=nolpextsfs - startet LazY Puppy 2.0.2 Final ohne ein weiteres Modul

Wolfgang wrote:
Also, Lazy wird ohne Speicherdatei gestartet und dann nur ein Programm geladen, dann befinden sich plötzlich 5 bis 6 sfs als geladen im System!
LazY arbeitet dann auch ständig im Hintergrund, was an der Prozessoranzeige rechts zu sehen ist. Irgendwann hängt dann das System ganz.
Habe jetzt erst mal wieder alle sfs aus dem Bootverzeichnis gelöscht und lade nur die, die in meinen verchiedenen Oberlächen (Gruppen) vorhanden sind.

Da nach jeder Startskriptausführung (Programmstart über ein solches) überprüft wird, ob alle notwendigen SFS Abhängigkeiten geladen sind und die noch nicht geladenen dann geladen werden, sind spätestens nach dem ersten Ausführen eines Startskriptes sämtliche Abhängigkeiten des beim Systemstart geladenen Erweiterungs SFS natürlich geladen.

Wolfgang wrote:
Nach dem Remastern sind alle pets weiterhin im Programmmanager zu sehen und könnten wieder entladen werden. Mit welcher Einstellung werden die geladenen PETs wie bei der originalen Remasterfunktion ausgeblendet?

Welcher Programmmanager? Ich habe keinen entwickelt. PETs? Seit wann können PETs entladen werden?

Du meinst (so vermute ich) wohl den Puppy Package Manager (PPM) und den Umstand, daß installierte PETs in diesem nach einem Remaster weiterhin angezeigt werden und somit deinstalliert werden könnten?

Nun, dann hast Du die entsprechende Option in der Remaster Suite aktiviert ('Installierte Programme' erneuern).

Tooltip zu 'Installierte Programme' erneuern wrote:
Die Datei 'user-installed-packages' wird für die neue LazY Puppy Betriebssystem-CD aktualisiert

Es gibt Tooltips zu all diesen Optionen. Einfach 'mal einen Blick darauf werfen.

Und, bitte: sprich vom Installieren bzw. deinstallieren, wenn Du dieses (pet) meinst und vom Laden und Entladen, wenn Du jenes (sfs) meinst. Ich mußte nämlich erst einmal scharf überlegen, was Du wohl meinen könntest!

---

Fazit:

Ich denke, Du verstehst inzwischen, warum ich 2.0.3 (und darüber) nicht veröffentlichen will?

Ich meine, Du kennst das System wohl, neben mir selbst, mit am Besten. Was würde wohl über mich hereinbrechen, würde ich 2.0.3 veröffentlichen?

Besonders im englischsprachigen Forum!

Obendrein scheint im Forum aktuell die PM-Manie zu grassieren, was mich dazu nötigt, Antworten doppelt und dreifach geben zu müssen und keine Möglichkeit zu haben, einfach einen Link zu einer bereits gegebenen Antwort posten zu können.

Das ist Zeitverschwendung, und wird mir zuviel.

Verwende besser die offizielle 2.0.2 Version für Dein PhyTech.

Gruß,

Rainer

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Sun 06 Jan 2013, 17:07    Post_subject:  

Hallo Rainer,

Quote:
Verwende besser die offizielle 2.0.2 Version für Dein PhyTech.

Das mache ich nun auch wieder!

Im Hintergund von 203 laufen für mich nicht nachvollziehbare Prozesse ab, was an der CPU-Anzeige des PWidget zu sehen ist. Wenn man über die Shutdown Gui versucht alle sfs zu entladen, dann geht das manchmal und manchmal nicht. Witzig ist auch, dass schon entladene sfs nach kurzer Wartezeit plötzlich wieder in der Liste auftauchen ohne, dass ein Programm gestartet wurde.

Eine Sache ist mir noch bei PWidgets aufgefallen und zwar unabhängig ob 202 oder 203.
Wenn ich die Einstellungen so vornehme wie auf den Fotos dann werden die Laufwerke sda2 und sda5 nicht mehr als gemounted angezeigt obwohl sie das sind. Nemen ich Puppy Space heraus dann ist alles ok.
Eine Idee woran es liegt?

Es sieht auch so aus, als ob die Reihenfolge in der Anzeige irgendwie nicht immer der Reihenfolge in der Definition folgt. Da scheint in PWidgets noch ein Fehler zu sein.

LG
Wolfgang
2_easyshot.jpg
 Description   
 Filesize   16.98 KB
 Viewed   517 Time(s)

2_easyshot.jpg

1_easyshot.jpg
 Description   
 Filesize   31.64 KB
 Viewed   515 Time(s)

1_easyshot.jpg

Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Sun 06 Jan 2013, 21:11    Post_subject:  

Quote:
Eine Sache ist mir noch bei PWidgets aufgefallen und zwar unabhängig ob 202 oder 203.
Wenn ich die Einstellungen so vornehme wie auf den Fotos dann werden die Laufwerke sda2 und sda5 nicht mehr als gemounted angezeigt obwohl sie das sind. Nemen ich Puppy Space heraus dann ist alles ok.
Eine Idee woran es liegt?

Es sieht auch so aus, als ob die Reihenfolge in der Anzeige irgendwie nicht immer der Reihenfolge in der Definition folgt. Da scheint in PWidgets noch ein Fehler zu sein.

Ja, da scheint einiges mit PWidgets nicht zu stimmen. Den Tip, Puppy Space herauszunehmen, veröffentlichte erst letztens jemand im englsichsprachigen Forum. Ich verwende PWidgets nicht mehr und werde es auch im nächsten 2.0.2 ISO (wenn es denn noch einmal eines gibt) ausgebaut haben (bei mir ist es das bereits).

Vielleicht gibt es eine neuere Version von PWidgets; ich weiß es nicht, denn ich habe mich nicht mehr darum gekümmert.

Quote:
Im Hintergund von 203 laufen für mich nicht nachvollziehbare Prozesse ab, was an der CPU-Anzeige des PWidget zu sehen ist. Wenn man über die Shutdown Gui versucht alle sfs zu entladen, dann geht das manchmal und manchmal nicht. Witzig ist auch, dass schon entladene sfs nach kurzer Wartezeit plötzlich wieder in der Liste auftauchen ohne, dass ein Programm gestartet wurde.

Na ja, 2.0.3 ist halt meine private Bastelversion. Bereits einen Tag nachdem ich das 2.0.3 ISO für DIch hochgeladen hatte, verfügtest Du über eine alte Version!

Module, die entladen wurden und dennoch anschließend wieder im System vorhanden sind, zeigen an, daß sie von einem anderen, noch geladenen Modul benötigt werden. Wie in meinem vorherigen Post notiert, wird regelmäßig geprüft, ob alle Modulabhängigkeiten geladen sind etc.pp.

Das Erweiterungsmodul wird übrigens in der Liste der geladenen Module nicht angezeigt - niemals, da es intern behandelt wird, als würde es sich um das zdrv.sfs handeln. Ist es geladen, werden natürlich die darin definierten Abhängigkeiten erneut geladen, wenn sie zuvor beim Entladen eines anderen Modules mitentladen oder manuell entladen wurden.

---

Edit:

Ich habe gerade einmal nachgesehen; 2.0.2-005 ist nicht für den Download von Modulen von Deinem Server vorbereitet. Du kopierst dafür die entsprechende Dateien (die mit der Liste Deiner Module und dem Link zu Deinem Server) in den/die entsprechenden Ordner und verwendest die Startskripterzeugung von 2.0.3. Da diese Version der Startskripterzeugung ImageMagick als Modul nachlädt (ist in 2.0.3 ausgebaut) machst Du aus den entsprechenden Codezeilen Kommentare. Oder installiere das letzte TestPet probeweise in 2.0.2-005 und laß mich wissen, ob es läuft.

Btw: ich kann meine E-Mail Adresse aktuell nicht löschen, da sonst mein Mediafire-Repo flöten geht, was zur Folge haben würde, daß sämtliche Daten verlorengehen würden und ihr ohne dasteht.

Muß mir da erst etwas anderes überlegen. Bis ich eine Lösung gefunden habe, kann ich mich also weiterhin hier ebenfalls einloggen. Alles andere steht und bleibt aber, wie in meiner betreffenden PM erklärt.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 07 Jan 2013, 00:59    Post_subject:  

Ok.

Ich habe nachgesehen, und es gibt eine neue Version von PWidgets, 2.4.1!

Ich habe ein Programm-Modul daraus erstellt (inkl. deutscher .desktop Datei) und es zu smokey01.com hochgeladen. Ebenso Gnumeric.

LazY Puppy Repo

Die Liste der aktuell verfügbaren Programm-Module wurde aktualisiert (im zweiten Forumsbeitrag).

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Mon 07 Jan 2013, 13:44    Post_subject:  

Hallo Rainer,

dann muss ja erst das 2.3.8 entfernt werden.
Wenn ich das mit Remove builtin packages wird in der Liste nicht PWidgets gelistet. Es ist ja wohl nicht "wget" oder "pwsget"?
Wenn ich das 2.4.1.sfs einfach so mit LP2_sfs-load lade dann wird es zwar geladen aber 2.3.8 ist weiterhin aktiv.

Quote:
Ich habe gerade einmal nachgesehen; 2.0.2-005 ist nicht für den Download von Modulen von Deinem Server vorbereitet. Du kopierst dafür die entsprechende Dateien (die mit der Liste Deiner Module und dem Link zu Deinem Server) in den/die entsprechenden Ordner und verwendest die Startskripterzeugung von 2.0.3. Da diese Version der Startskripterzeugung ImageMagick als Modul nachlädt (ist in 2.0.3 ausgebaut) machst Du aus den entsprechenden Codezeilen Kommentare. Oder installiere das letzte TestPet probeweise in 2.0.2-005 und laß mich wissen, ob es läuft.

Genau das war mir auch aufgefallen, nach dem ich mich kurz gewundert hatte Laughing
Werde mich gleich mal daran machen.
Mit dem TestPet meinst du das TestPet2 von heute? Habe heute ein Update für 202 bekommen. Ist es das? Die TestPets von 203 habe ich nicht gespeichert sondern immer gleich geladen.

EDIT: Habe die Dateien soweit angepasst und mein Spezial "Wolfgangs-Startskripterzeugung-LP203.sfs" geladen. Jetzt wird bei meinen Programmen auch meine Downloadadresse beim Erzeugen wird eingetragen und der Download sowohl des Hauptprogramms als auch des abhängigen Moduls, hier LP2_Wine.sfs funktioniert!

Das ist also schon mal gelöst!

Jetzt noch die Sache mit PWidgets.....

LG

Wolfgang
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 07 Jan 2013, 17:31    Post_subject:  

Quote:
dann muss ja erst das 2.3.8 entfernt werden.
Wenn ich das mit Remove builtin packages wird in der Liste nicht PWidgets gelistet. Es ist ja wohl nicht "wget" oder "pwsget"?
Wenn ich das 2.4.1.sfs einfach so mit LP2_sfs-load lade dann wird es zwar geladen aber 2.3.8 ist weiterhin aktiv.

Builtin Packages sind Programme, die wohl bei der Erstellung eines System mithilfe von "woof", installiert (eingebaut) wurden.

Alles andere sind User Installed Packages.

PWidgets taucht in keiner der Listen auf.

Am Besten öffnest Du das 2.4.1 und kopierst den Inhalt manuell ins System, oder erstelle ein .pet aus dem .sfs und instaliere es. Die Tools hat LazY Puppy ja allesamt.

Quote:
Mit dem TestPet meinst du das TestPet2 von heute? Habe heute ein Update für 202 bekommen. Ist es das? Die TestPets von 203 habe ich nicht gespeichert sondern immer gleich geladen.

Nein, falls Du das angebotene .pet des Online Updaters meinst.

Die darin präsentierten und angebotenen Updates enthalten eine Informationsdatei, die Online gelesen werden kann (Info button) sowie einen Screenshot, zum Online Ansehen der Oberfläche des Programmes mithife des defaultimageviewer(s) (Bild button).

PET auswählen und den entsprechenden Button klicken. Ein Klick auf Info gibt Dir alle benötigten Informationen zum .pet ---> vor der Installation!

Cool, oder?

Das .pet, das ich meinte, ist das TestPet für die Startskripterzeugung (welches ich ein paar Posts zuvor angehängt hatte).

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 07 Jan 2013, 18:06    Post_subject:  

Quote:
Habe die Dateien soweit angepasst und mein Spezial "Wolfgangs-Startskripterzeugung-LP203.sfs" geladen.

Wenn Du das schreibst, bedeutet das, daß Du die Startskripterzeugung als solche nicht mehr im System hast, sondern nachlädst?

Anderenfalls würde das Laden des "Wolfgangs-Startskripterzeugung-LP203.sfs" ja keine Wirkung erzielen. Ich hatte das doch als .pet geposted, oder nicht?

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Mon 07 Jan 2013, 18:22    Post_subject:  

Quote:
Anderenfalls würde das Laden des "Wolfgangs-Startskripterzeugung-LP203.sfs" ja keine Wirkung erzielen. Ich hatte das doch als .pet geposted, oder nicht?

Sorry, hatte mich verschrieben! Ist natürlich das Pet!

PWidgets 2.4.1 ist installiert und wird auch benutzt hat aber keine Wirkung bzw. der Fehler ist immer noch genau wie vorher!

Dann muss ich vermutlich erst mal damit leben, dass nur das sda1 korrekt angezeigt wird.

Benutzt du eigentlich für die Erstellung der GUIs ein Hilfsprogramm wie Glade oder so was?
Wenn ich mal wieder etwas mehr Zeit habe, wollte ich auch mal eine schöne Oberfläche basteln. Cool

LG

Wolfgang
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Mon 07 Jan 2013, 18:49    Post_subject:  

Quote:
Benutzt du eigentlich für die Erstellung der GUIs ein Hilfsprogramm wie Glade oder so was?

Nein, ich mache gerne alles manuell und selbst - sofern ich es vermag. Am Liebsten würde ich sogar mit einer 16- oder 24-Spur-Bandmaschine arbeiten (Musik aufzeichnen etc.).

LazY Puppy 2.0.2-005 hat übrigens ein paar nette Additionen bezüglich eigener Skripte. Führe einmal einen Rechtsklick in einem geöffneten ROX Fenster aus - auf eine leere Fläche.

Du bekommst dann unter dem Eintrag "Neu" verschiedene Ordner und Dateien als Vorlagen angeboten. Unter anderem drei (3) gtkdialog BasisSkripte, lokalisiert (ordner locals) mit verschiedenen GUI Grundtypen etc.pp

Wenn nichts angezeigt wird, dann den Ordner /root/.config/rox.sourceforge.net/Templates löschen oder die Dateien aus /root/Choices/Templates dorthin kopieren.

Es sollte aber eigentlich alles angezeigt werden.

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Tue 08 Jan 2013, 19:12    Post_subject:  

Quote:
Du bekommst dann unter dem Eintrag "Neu" verschiedene Ordner und Dateien als Vorlagen angeboten. Unter anderem drei (3) gtkdialog BasisSkripte, lokalisiert (ordner locals) mit verschiedenen GUI Grundtypen etc.pp

Ja, wird angezeigt!

Oberflächenbau und Funktion würde ich als zwei Teile sehen die am Ende zusammen gehören. Den Bau der Oberfläche würde ich aber aus Zeitgründen lieber mit einem Programm erledigen.

Habe manchmal ein Problem mit dem Einhängen von ntfs-Partitionen wenn ich vor dem herunterladen von Programmen aus dem Netz nicht erst das Laufwerk anklicke! Wenn ich also von einer Partition boote (frugal ohne Speicherdatei) dann gehe ich eigentlich davon aus, dass dieses Laufwerk automatisch eingehängt wird! Das würde auch den Installationsfehler mit dem HD-Installer beheben wenn von CD gebootet wird.
Wird das CD-Laufwerk nach dem booten nicht einmal angeklickt und damit eingehängt kommt nach der HD-Installation zwar die Info, dass alles installiert ist, leider wurde aber nichts installiert!
Das hatten wir schon mal besprochen aber vielleicht lässt sich das jeweilige Bootlaufwerk ja doch automatisch einhängen?!

Die Sache mit dem Nachladen von Programmen vom Server wenn von CD gebootet wurde lässt mir auch keine Ruhe! Wenn ich von CD boote und ein sfs "von Hand" downloade, wird es nach "Downloads" geschoben und ich kann es dann ganz normal laden. Warum geht das nicht auch automatisch wenn von CD gestartet wurde?

Natürlich hat man das Problem nicht, wenn man mit Stick arbeitet aber ältere PC booten halt oft nicht von Stick!

LG

Wolfgang
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Tue 08 Jan 2013, 22:46    Post_subject:  

Quote:
Habe manchmal ein Problem mit dem Einhängen von ntfs-Partitionen wenn ich vor dem herunterladen von Programmen aus dem Netz nicht erst das Laufwerk anklicke!

Das ist einfach zu erklären und ebenso einfach zu beheben.

Sagen wir 'mal, Dein PhyTech steckt in sda1; ist sda1 nicht eingebunden, erzeugt das Download Skript einen Ordner sda1 in /mnt und speichert den Download dort. Wenn Du anschließend sda1 einbinden willst, dann stellt pmount fest, daß unter /mnt/sda1 bereits Dateien existieren und geht davon aus, daß es sich um ein bereits eingebundenes Laufwerk handelt.

Einfach die Daten in /mnt/sda1 löschen (natürlich nur, wenn es sich Dabei NICHT um Daten vom "echten" sda1 Laufwerk handelt). und dann sda1 einbinden. Fertig.

Quote:
Wenn ich also von einer Partition boote (frugal ohne Speicherdatei) dann gehe ich eigentlich davon aus, dass dieses Laufwerk automatisch eingehängt wird! Das würde auch den Installationsfehler mit dem HD-Installer beheben wenn von CD gebootet wird.
Wird das CD-Laufwerk nach dem booten nicht einmal angeklickt und damit eingehängt kommt nach der HD-Installation zwar die Info, dass alles installiert ist, leider wurde aber nichts installiert!
Das hatten wir schon mal besprochen aber vielleicht lässt sich das jeweilige Bootlaufwerk ja doch automatisch einhängen?!

Exakt, das hatten wir bereits.

Aktuell sehe ich da keine andere Möglichkeit, als folgende:

Du baust den HD- und den USB-Installer aus und machst aus ihnen Programm-Module. Diese packst Du zum ISO (die Remaster Suite bietet Optionen dafür an).

Da die Programme dann als Modul vom ISO bzw. vom CD-Laufwerk geladen werden, ist das ISO bzw. das CD-Laufwerk auf jeden Fall eingebunden.

Edit:

Ist vielleicht eine gute Idee, das in einer zukünftigen Version exakt so anzulegen.

Ende Edit:

Ist zwar für Dich ein wenig Arbeit, aber so -wenn man selbst daran herumbastelt- lernt man das System kennen. Und mir erspart es obendrein eine Menge Arbeit, für die ich zurzeit absolut keine Zeit erübrigen kann.

Außerdem: ich denke, es ist besser, der Linux Neuling lernt, daß man unter Linux Laufwerke vor der Verwendung erst einbinden muß, bereits beim Installieren von CD, als später erst, beim Speichern eigener Dateien (die dann möglicherweise verloren gehen). Exclamation

Quote:
Die Sache mit dem Nachladen von Programmen vom Server wenn von CD gebootet wurde lässt mir auch keine Ruhe! Wenn ich von CD boote und ein sfs "von Hand" downloade, wird es nach "Downloads" geschoben und ich kann es dann ganz normal laden. Warum geht das nicht auch automatisch wenn von CD gestartet wurde?

Das Alles ist so, weil LazY Puppy eben nun mal für den Betrieb vom USB Stick optimiert ist. Das war von Anfang an so. Ich hatte vorher Muppy 08.3F gut 1 Jahr lang vom USB Stick betrieben und wollte das so beibehalten.

Würde ich das nun so etablieren, wie von Dir vorgeschlagen, müßte ich exzessive Änderungen an der Startskripterzeugung und den erstellten Startskripten vornehmen - und dafür kann ich jetzt keine Zeit aufwenden. Außerdem müßten dann alle Startskripte neu erstellt werden, und Du erstellst ja nicht so gerne neue Startskripte. Laughing

Und schließlich ist LazY Puppy zuerst einmal MEIN Puppy; als solches wurde das Projekt "LazY Puppy" gestartet. Meine Absicht war es NICHT, mich als Puppy Linux Developer zu etablieren, sondern mein eigenes Puppy zu erstellen; und das aus den unterschiedlichsten Gründen. Daß es nun so ist, wie es ist, und auch für viele andere Anwender interessant zu sein scheint, ist eine glückliche Fügung (neben der vielen Arbeit).

Ich selbst war aber eigentlich schon mit LazY Puppy 1 (528-4) zufrieden. Wer weiß? Wäre ich nicht über diggs Idee zu verschiedenen Anwendermodi gestolpert, ich hätte LazY Puppy vielleicht nicht viel weiter entwickelt.

Quote:
Natürlich hat man das Problem nicht, wenn man mit Stick arbeitet aber ältere PC booten halt oft nicht von Stick!

Auch ich verwende LazY Puppy an einem PC, der nicht vom USB Stick booten kann. Auf diesem verwende ich entweder die auf HD installierte 2.0.2 Version, oder ich verwende den Plop Bootmanager. Der bootet den PC von CD und läßt mich dann ein Bootmedium (u.a. den USB Stick) auswählen.

_________________
LazY Puppy
RSH's DNA
SARA B.

Edited_time_total
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Wed 09 Jan 2013, 02:01    Post_subject:  

Hallo.

Oui stellte fest:
Quote:
LazyPup? Ja, das ist Puppy-HighTech und liefert Dir alles, was Du brauchst.

Ich stelle fest:

LazY Puppy 2.0.2, nun Build 0.0.5 DE ist,

1. so, wie es ist, im weitesten Sinne ein optimales Betriebssystem
2. das einzige Puppy Linux, das innnerhalb eines länger zurückliegenden Zeitraumes mit wirklich neuen Funktionen ausgestattet wurde
3. das einzige deutschsprachige Puppy Linux, das innerhalb desselben Zeitraumes veröffentlicht wurde
4. das einzige Puppy Linux, das eine grafische Benutzeroberfläche bietet, um Einstellungen für ein Remaster vornehmen zu können
5. das z.Z. einzige Puppy Linux Derivat, daß automatisch Aktualisierungen zum Herunterladen/Installieren anbietet und anbieten kann

Weitergehende Spezialwünsche für LazY Puppy Anwender oder Derivative Developer zu erfüllen, liegt zurzeit weit außerhalb meiner Planungen und Absichten.

Es ist aber ein Jeder gerne gesehen, mit eigenen Beiträgen zur Weiterentwicklung beizutragen. Das Eine oder Andere wird dann sicherlich in ein neues ISO eingebaut werden - siehe VarioMenü!

Neben meiner grundsätzlichen Absicht, mich ein wenig rar zu machen, was meine Forumsarbeit sowie die Weiterentwicklung von LazY Puppy (Web Versionen) bzw. Funktionen und Programmen für LazY Puppy (Web Versionen) betrifft (von Fehlerbereinigungen und Aktualisierungen abgesehen), richtet sich meine Aufmerksamkeit bezüglich der Programmentwicklung zukünftig darauf, einige der wirklich nützlichen und komfortablen Programme und Funktionen von LazY Puppy für andere Puppies zu erhalten.

Aktuell arbeite ich hauptsächlich (wenn ich denn programmiere) daran, LazY Puppy SFS P.L.U.S. mit SFS P.L.U.S. 2.x.x für andere Puppies (im Forum Utilities) zu kombinieren; also eine Version, SFS P.L.U.S. 3.0.0, für alle Systeme zu haben.

Als ich letztens genau dafür ein Test-Remaster mit Three Headed Dog anfertigte, fühlte ich mich beim Remastern wieder wie der Neuling - das Standard-Remaster-Skript ist eben doch etwas Anderes, im Vergleich zur LazY Puppy Remaster Suite. Ich benötigte glatt mehrere Anläufe, bis ich alle benötigten Dateien im neu erstellten System hatte. Das dürfte für einen wirklichen Neuling wohl kaum zu bewerstelligen sein. Also baute ich testweise die Remaster Suite ebenfalls ein - und siehe da: es funktionierte. Nun ist Three Headed Dog ebenfalls -wie LazY Puppy- ein Lucid Puppy, was das Funktionieren der Remaster Suite erklären mag. Jedenfalls funktionierte dasselbe ebenfalls mit dem normalen Lucid.

Bei Precise und anderen Puppies wird dies aber wohl vorhersehbar nicht so sein, also erschuf ich SFS P.L.U.S. Remaster. Ein vollständig neu entwickeltes Remasterskript, das nur jene Veränderungen in ein neues System übernimmt, die durch seine eigene Installation bzw. durch die Installation von SFS P.L.U.S. selbst sowie den aus Programm-Modulen erstellten Startskripten und den daraus hervorgehenden Änderungen entstehen.

Siehe Screenshot im Anhang.

Das Programm erstellt aktuell mein eigenes System (105 MB) als 105 MB großes System - egal, wieviele Module ich währenddessen geladen habe. Es übernimmt nur die Änderungen in den für die Startskripte und Icons zuständigen Verzeichnissen!

In einem zweiten Schritt soll das Programm erkennen können, ob es bereits in einem neu erstellten System installiert ist oder zum ersten mal installiert wurde. Dies deshalb, damit beim ersten Remaster nach der ersten Installation die zusätzlich installierten, notwendigen Tools in das neue System übernommen werden (sfs_load >=1.9, xdotool).

Somit sollte das ganze dann auch von einem Neuling zu bewerkstelligen sein bzw. könnte man ganz schnell und einfach von jedem neuen Puppy Linux ein System mit SFS P.L.U.S. erstellen. Am Besten gleich mit einigen Startskripten versehen, um z.B GIMP und andere wichtige Programme zur Verfügung zu haben und verwenden zu können sowie mit entferntem Hundegebell - noch jeder in meinem Bekanntenkreis, dem ich in den ersten Tagen mein selbst erstelltes (damals) Lucid 525 vorführte, erschrak sich angesichts des Startsounds und zeigte sich anschließend wenig begeistert.

Um Windowsnutzer wirklich zum Umstieg auf Puppy Linux bewegen zu wollen (falls diese Ziel tatsächlich jemand verfolgen sollte und als verfolgenswert erachtet), sollte man diesen Stolperstein definitiv entfernen und gegen einen herzerwärmenden, auch in größerer Lautstärke wohltuenden Klang austauschen. Very Happy

Wenn SFS P.L.U.S. 3.0.0 fertiggestellt ist, wird dies bei dessen Installation automatisch getan werden!

Also dann,

viel Spaß mit LazY Puppy 2.0.2 - Build 0.0.5 DE

RSH
image-2.jpg
 Description   
 Filesize   19.77 KB
 Viewed   332 Time(s)

image-2.jpg


_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Wed 09 Jan 2013, 09:04    Post_subject:  

Hallo Rainer,

das bedeutet, dass man mit dem "Plop Bootmanager" von jedem PC mit USB-Anschluss auch von Stick booten kann?
Das wäre eine gute Sache und hätte natürlich Vorteile gegnüber einem Start mit CD! Werde ich mal testen.

LG

Wolfgang
Back to top
View user's profile Send_private_message 
RSH


Joined: 05 Sep 2011
Posts: 2420
Location: Germany

PostPosted: Wed 09 Jan 2013, 09:31    Post_subject:  

der-schutzhund wrote:
Hallo Rainer,

das bedeutet, dass man mit dem "Plop Bootmanager" von jedem PC mit USB-Anschluss auch von Stick booten kann?
Das wäre eine gute Sache und hätte natürlich Vorteile gegnüber einem Start mit CD! Werde ich mal testen.

LG

Wolfgang

Exactemento!

Könnte aber sein, daß Du im Netz nur neuere Versionen findest, die dann auf einem alten PC nicht starten.

Für diesen Fall, hier ein ältere Version!

_________________
LazY Puppy
RSH's DNA
SARA B.
Back to top
View user's profile Send_private_message 
der-schutzhund

Joined: 26 Nov 2007
Posts: 781
Location: Blomberg / Germany

PostPosted: Wed 09 Jan 2013, 17:15    Post_subject:  

Hallo zusammen,

Plop Bootmanager läuft sehr gut und zwar sowohl von CD als auch von Diskette.

An einem PC gibt es allerdings ein Problem, hat natürlich nichts mit Plop zu tun, aber mit Lazy / Lucid!

Die Verbindung zum Internet über den Browser funktioniert nicht.
Ich kann einen Zugang über den Internet-Connection-Wizard herstellen. So weit so gut aber wenn ich mit einem Browser, egal welchem, in Netz möchte dann kommt die Fehlermeldung: "ERROR: Dns can't resolve..."
Habe dann mal ein Wenig gesucht und die Info gefunden, dass man etwas an der Datei etc/resolv.conf ändern soll.
Habe also mal die Datei geöffnet und siehe da sie ist bis auf zwei Kommentare leer. Also die Einträge von einem anderen PC der ebenfalls mit Lazy betrieben wird und über den gleichen Router arbeitet übertragen aber der Fehler bleibt weiterhin!
Mit 431 gab es mit dem PC kein Problem!

Woran kann es liegen?

LG

Wolfgang
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 33 of 50 Posts_count   Goto page: Previous 1, 2, 3, ..., 31, 32, 33, 34, 35, ..., 48, 49, 50 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1725s ][ Queries: 13 (0.0073s) ][ GZIP on ]